Mouse and touchpad don't work well together

Bug #13912 reported by Alex Fraser on 2005-03-13
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)

Bug Description

When the touchpad and USB mouse on my laptop are both enabled, neither gets
initialised properly.

After booting and logging in, the pointer seems to get stuck to the first widget
it is clicked on in each window. For example, I can drag a box on the desktop,
but then I can't activate any icons by clicking on them. If I open a calculator,
the first button I click on works, but then none of the others even receive
"enter" signals. Strangely, after clicking the middle mouse button everything
works perfectly.

If I disable the USB mouse in xorg.conf the touchpad works fine. Attempting to
disable the touchpad doesn't seem to work - it just starts acting like a regular
mouse, and sends data to /dev/input/mice.

I'm running a recent version of Hoary:
 * linux-image-2.6.10-4-k7 Version: 2.6.10-27
 * xserver-common, xserver-xorg, xorg-common Version: 6.8.2-2
 * xorg-driver-synaptics Version: 0.13.6-0ubuntu4

My laptop is a Compaq Presario 700. The mouse is a Logitech iFeel mouse.

I'll attach my xorg.conf and xorg log files, and dmesg output.

Alex Fraser (alex-phatcore) wrote :

Created an attachment (id=1631)
Default configuration (quirky mouse behaviour)

In this config file, both the USB mouse and touchpad are configured and

Alex Fraser (alex-phatcore) wrote :

Created an attachment (id=1632)
Xorg log (mouse and touchpad enabled)

Alex Fraser (alex-phatcore) wrote :

Created an attachment (id=1633)
Output of dmesg

Daniel Stone (daniels) wrote :

This bug has been marked as a duplicate of bug 12124.

Alex Fraser, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from .

If it remains an issue, could you please run the following command in the development release from a Terminal as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg 13912

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

Thank you for your understanding.

Helpful bug reporting tips:

Changed in xorg (Ubuntu):
assignee: Daniel Stone (daniels) → nobody
status: Invalid → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.