DRI_PRIME=1 has no effect in Ubuntu 14.10

Bug #1388647 reported by Dominic Chambers on 2014-11-02
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Low
Unassigned

Bug Description

On an Optimus laptop with both GPUs enabled, having run this command so that the Nvidia GPU can be used to offload 3D work from the Intel GPU:

```
xrandr --setprovideroffloadsink nouveau Intel
```

Then running this command:

```
DRI_PRIME=1 glxinfo | grep "OpenGL vendor string"
```

provides the incorrect output:

```
OpenGL vendor string: Intel Open Source Technology Center
```

when it should actually show that the Nouveau driver is in use for the program.

This worked previously in Ubuntu 14.04. Apart from only having a 3.16 kernel (instead of 3.17) Ubuntu 14.10 actually supports recent enough versions of the requisite packages necesarry to get DRI 3 offloading support, so perhaps this is part of the problem.

Or, more likely, I notice a Nouveau failure after startup, and then again after running xrandr commands, for example:

```
[ 170.912483] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 217.550205] thinkpad_acpi: EC reports that Thermal Table has changed
[ 223.857442] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 223.858395] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 223.860200] nouveau E[ PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x002140 [ !ENGINE ]
[ 224.654622] thinkpad_acpi: EC reports that Thermal Table has changed
[ 825.172094] thinkpad_acpi: EC reports that Thermal Table has changed
[ 831.132156] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 831.133030] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 831.134832] nouveau E[ PBUS][0000:01:00.0] MMIO read of 0x00000000 FAULT at 0x002140 [ !ENGINE ]
```

Perhaps this is just a regression in either the Nouveau or Intel drivers for my hardware. I'm using a Lenovo T430. I can confirm that I'm able to start the laptop without errors when I only enable the Intel GPU or NVidia GPU separately, and only see this error when both GPUs are enabled simultaneously.

Extra Info:

1: Description: Ubuntu 14.10
Release: 14.10

2: N/A

3: The text 'nouveau' should have appeared in the output of the command.

4: The text 'Intel' appeared in the output of the command.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1388647/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → xorg (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Pedro Armando (astroty-br) wrote :

I can confirm the bug with DRI_PRIME
Current setup is Intel Ivy Bridge + AMD Radeon 7730M

Reverting the following packages and their dependencies to their trusty-update version fixed the issue
(Following packages with their dependencies)
xserver-xorg-input-all
xserver-xorg-input-wacom
xserver-xorg-video-glamoregl
xserver-xorg-input-synaptics
xserver-xorg-input-evdev
xserver-xorg-core
xserver-xorg-input-mouse
xserver-xorg-video-vesa
xserver-xorg-video-mach64
xserver-xorg-video-fbdev
xserver-xorg
xserver-xorg-input-vmmouse
xserver-xorg-video-modesetting
xserver-xorg-video-r128

The problem most probably is contained in the package xserver-xorg, since most of these dependencies shouldn't affect prime (input)

That's a clever trick, being able to downgrade dependencies like that. Any pointers on how one goes about doing it, since even if I add 'trusty' sources to `/etc/apt/sources.list' then I still only see a single version available to install if I run `apt-show-versions xserver-xorg`?

Anyway, great work narrowing it down so quickly!

goodeye (mikk150) wrote :

Can confirm with Ivy Bridge + AMD 7650M

Pedro Armando (astroty-br) wrote :

Issue seems fixed using latest packages from vivid

goodeye (mikk150) wrote :

can confirm on my other machine as well
Ivy Bridge + Nvidia 650M

Alain Rouet (alain-rouet) wrote :

Found a solution, thanks to this: http://nouveau.freedesktop.org/wiki/Optimus/

First, you have to add "drm.rnodes=1" to the kernel parameters: https://wiki.ubuntu.com/Kernel/KernelBootParameters
Then, you need to make sure you (the user) are in the video group: sudo usermod -a -G video <user>

Reboot, and it should work.

goodeye (mikk150) wrote :

So appearently this isn't a bug but ubuntu maintainers forgot to enable it
Works on my Ivy Bridge + AMD 7650M, due to that my Nvidia machine has binary blob installed now, I am not willing to test it out

Alain's workaround also works for me (on Intel+AMD)

Simon K (octav14n) wrote :

I can confirm that this is still an issue in Ubuntu 14.10 with Intel+ATI.
Workaround worked for me though.

Dominic Chambers, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg 1388647

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

As well, given the information from the prior release is already available, testing a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xorg (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

Hi Christopher,

I can confirm that this issue has been fixed in the current daily build of Ubuntu 15.04.

Thanks, Dominic.

Dominic Chambers, would you need a backport to a release prior to Vivid or may this be closed as Status Invalid?

Hi Christopher,

No backport required by me thanks. Alain Rouet's work-around solves this problem.

Thanks, Dominic.

Dominic Chambers, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1388647/comments/13 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xorg (Ubuntu):
status: Incomplete → Invalid

Well, I found that it's an issue with setting the right Paths for the right installed NVIDIA driver, in my case GT540M 2GB. (Ubuntu 14.10)

It was poiting to nvidia-current, while I have the latest installed by default for some reason which is way greater than the current, and I've found also that optimus was set to use Nouveau instead, hence I changed that to nvidia, and set the right paths and everything's working great including EditShare Lightworks and The Foundry Nuke Studio.

So check your config again.

Btw, I lost the confs after one Update and had to re-do it manually again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers