Backport xserver-xorg-input-synaptics 1.8.1 to 14.04 LTS

Bug #1380218 reported by Stephan Fabel on 2014-10-12
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Low
Unassigned

Bug Description

Clickpads are a part of a wide range of professional Lenovo Thinkpad machines. The touchpads/clickpads on these laptops do not work well with the synaptics driver version 1.7.x. Since the 14.04 is an LTS version, I do not plan to upgrade to 14.10. I imagine many users of the Lenovo Thinkpad line are in a similar situation.

Since version 1.8.x fixes a lot of these issues, see commit here:

http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/tag/?id=xf86-input-synaptics-1.8.1

and blog post here:

http://who-t.blogspot.de/2014/03/xorg-synaptics-support-for-lenovo-t440.html

Please offer 1.8.x as backported package in 14.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed

Stephan Fabel, thank you for reporting this and helping make Ubuntu better.

Could you please run the following command once from a terminal by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information:
apport-collect -p xorg 1380218

When reporting xorg related bugs in the future, please do so via the above method. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: xserver-xorg-input-synaptics (Ubuntu) → xorg (Ubuntu)
Changed in xorg (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers