The monitor won't wake up after going to sleep (initiated by locking, automatic or manual)

Bug #1372409 reported by Jan Corazza
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Expired
Low
Unassigned

Bug Description

I am using the 3.16.3 kernel (edit: now 3.17 RC6!) and Mesa/drivers/Xorg from the Oibaf PPA - but this also happens when using drivers from the regular repositories.

Steps to reproduce:
1. Lock computer (Ctrl+Alt+L) or let it lock itself automatically
2. Wait a few seconds for the monitor to shut down (LED blue->yellow and displayed warning)
3. Try to wake it up

Expected behavior: the monitor is woken up and the Ubuntu lock screen is displayed

Actual behavior: the monitor stays off, black screen

Additional information:
 - Suspending and resuming works fine.
 - Switching to a TTY doesn't work either, but the keyboard is responding (can turn caps lock on/off).
 - I have to restart the computer to get it in a working state after this happens. (therefore SEVERE)
 - monitor: HP ZR2330w

WORKAROUND: Don't lock the computer, and disable automatic lock in Brightness & Lock settings.

WORKAROUND: Use proprietary AMD drivers (fglrx).

WORKAROUND: Use kernel 3.13.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xorg 1:7.7+1ubuntu8
Uname: Linux 3.16.3-031603-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,staticswitcher,workarounds,scale,expo,ezoom,dbus]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Mon Sep 22 13:07:00 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
ExtraDebuggingInterest: I just need to know a workaround
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Bonaire XT [Radeon HD 7790/8770 / R9 260 OEM] [1002:665c] (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. [MSI] Radeon HD 7790 OC [1462:2930]
InstallationDate: Installed on 2014-07-14 (69 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: To be filled by O.E.M. To be filled by O.E.M.
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.3-031603-generic root=UUID=6e991daa-60a1-41a6-86b9-099d96d697f2 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/09/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2501
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: M5A97 EVO R2.0
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2501:bd04/09/2014:svnTobefilledbyO.E.M.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnASUSTeKCOMPUTERINC.:rnM5A97EVOR2.0:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: To be filled by O.E.M.
version.compiz: compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56+git1409220630.666788~gd~t
version.libgl1-mesa-dri: libgl1-mesa-dri 10.4~git1409220730.d69faf~gd~t
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.4~git1409220730.d69faf~gd~t
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.99+git1409110730.56c7fb~gd~t
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.916+git1409220730.376037~gd~t
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11+git1409010731.3cd4c8~gd~t
xserver.bootTime: Mon Sep 22 13:01:53 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input LITEON Technology USB Multimedia Keyboard KEYBOARD, id 8
 input Logitech USB Optical Mouse MOUSE, id 9
 input Eee PC WMI hotkeys KEYBOARD, id 10
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.1-0ubuntu2.1
xserver.video_driver: radeon

Revision history for this message
Jan Corazza (corazza) wrote :
Jan Corazza (corazza)
description: updated
Jan Corazza (corazza)
description: updated
Jan Corazza (corazza)
description: updated
Jan Corazza (corazza)
description: updated
Jan Corazza (corazza)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Jan Corazza, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg 1372409

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

As well, given the information from the prior release is already available, testing a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: added: latest-bios-2501
Changed in xorg (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers