systemsettings > Display Configuration shows bogus monitor

Bug #1313170 reported by Christian González on 2014-04-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Starting from Kubuntu 14.04, when I open systemsettings > Monitor > Display Configuration, I see, additionally to my built-in monitor on my laptop (Samsung RF511 - monitor displayed as "Seiko Epson Corporation"...) an additional screen named "VGA-1-2" - which is enabled.
This "monitor" is detected despite it does not exist. I discovered that because some apps I started did not appear on screen, and the mouse cursor somehow "vanished" behind the right screen edge, until I found out that they were placed on that second screen - I could "drag" the windows per Alt+LeftClick blindly from somewhere in the right to my actual monitor.

a screnshot of systemsettings is attached.
Then I attached a *real* second monitor to my laptop - systemsettings detects it correctly and expands the screen - but now tells me that I have *three* monitors...

This is really a regression to 13.10, and as the monitor is detected *and* enabled by default, it is not really good to work with, as windows are "vanishing" somwehere.

I can reproduce this behaviour with a Kubuntu live ISO on my system. So it is NOT my misconfiguration ;-)
I before had Kubuntu 13.10 with KDE 4.12.5, running well without this bug.
I am using a laptop with optimus graphics: intel/nvidia card, corresponding lspci lines:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 3D controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)

What else (log files etc) do you need from me to help resolve this bug?

---
.tmp.unity.support.test.0:

ApportVersion: 2.17.2-0ubuntu1.5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
DistUpgraded: 2015-05-21 14:12:51,319 DEBUG enabling apt cron job
DistroCodename: vivid
DistroRelease: Ubuntu 15.04
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.3.30, 3.19.0-26-generic, x86_64: installed
 vboxhost, 4.3.30, 3.19.0-28-generic, x86_64: installed
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Samsung Electronics Co Ltd Device [144d:c0a5]
InstallationDate: Installed on 2015-02-25 (213 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
MachineType: SAMSUNG ELECTRONICS CO., LTD. RF511/RF411/RF711
Package: xorg 1:7.7+7ubuntu4
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.19.0-28-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.19.0-28.30-generic 3.19.8-ckt5
Tags: vivid ubuntu compiz-0.9
Uname: Linux 3.19.0-28-generic x86_64
UpgradeStatus: Upgraded to vivid on 2015-05-21 (128 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 04/26/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 10HX.M034.20110426.SSH
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: RF511/RF411/RF711
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: 10HX
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr10HX.M034.20110426.SSH:bd04/26/2011:svnSAMSUNGELECTRONICSCO.,LTD.:pnRF511/RF411/RF711:pvr10HX:rvnSAMSUNGELECTRONICSCO.,LTD.:rnRF511/RF411/RF711:rvr10HX:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
dmi.product.name: RF511/RF411/RF711
dmi.product.version: 10HX
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
version.compiz: compiz 1:0.9.12.1+15.04.20150410.1-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.60-2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.5.9-2ubuntu1~vivid2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.5.9-2ubuntu1~vivid2
version.xserver-xorg-core: xserver-xorg-core 2:1.17.1-0ubuntu3.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2build1
xserver.bootTime: Tue Sep 22 11:36:07 2015
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 NOUVEAU(G0): [XvMC] Failed to initialize extension.
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 13642
 vendor SEC
xserver.version: 2:1.17.1-0ubuntu3

Rohan Garg (rohangarg) wrote :

Hi there!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. While we appreciate your issue, it would be better if it was tracked at https://bugs.kde.org, so that the KDE developers can deal with this speedily and have direct communication with you as the reporter for more effective debugging.

Thanks!

Changed in kde-workspace (Ubuntu):
status: New → Invalid
Christian González (droetker) wrote :

Sorry to insist.
This bug is not invalid, at least not because of KDE specifity. I just tested it with an Ubuntu (Unity!) live CD. Same situation. As I already stated, I used KDE until now (4.12.5 in Kubuntu 13.10) without problems. While there *could* be a KDE regression from 5.12.5 to 4.13, this would not explain why the Unity systemsettings show the bogus monitor as well.

Changed in kde-workspace (Ubuntu):
status: Invalid → New
Rohan Garg (rohangarg) wrote :

Aha, this might indicate that this is a bug in the driver, I'm reassigning the bug to the Xorg package

affects: kde-workspace (Ubuntu) → xserver-xorg-video-nouveau (Ubuntu)

Christian González, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect -p xorg 1313170

Please ensure you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

affects: xserver-xorg-video-nouveau (Ubuntu) → xorg (Ubuntu)
Changed in xorg (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

apport information

tags: added: apport-collected compiz-0.9 ubuntu vivid
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Christian González (droetker) wrote :

I'm sorry - I ran the command multiple times and it attached I think 4 times the files.
Sorry for spamming. I deleted all the duplicate attachments. Should be ok now.
Hope it helps - I still have the bogus monitor in system settings (Unity now).

description: updated
Christian González (droetker) wrote :

It's a "Samsung NP-RF511-S05DE".

Christian González, any change with http://cdimage.ubuntu.com/daily-live/current/ ?

Changed in xorg (Ubuntu):
importance: Low → Medium
Christian González (droetker) wrote :

No difference. tried with daily from today, freshly downloaded and made an USB live system. Three monitors when 2 are really there (1 laptop internal, 1 external). shows "2" when only laptop internal is there.
What else do you need?

Christian González (droetker) wrote :

xrandr --verbose
(relevant monitor) - if you not already have this information:
VGA-1-2 connected (normal)
 Identifier: 0x41
 Timestamp: 22568
 Subpixel: unknown
 Clones:
 CRTCs: 3 4
 Transform: 1.000000 0.000000 0.000000
             0.000000 1.000000 0.000000
             0.000000 0.000000 1.000000
            filter:
 scaling mode: None
  supported: None, Full, Center, Full aspect
 color vibrance: 150
  range: (0, 200)
 vibrant hue: 90
  range: (0, 180)
  1024x768 (0x43) 65.0MHz -HSync -VSync
        h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.4KHz
        v: height 768 start 771 end 777 total 806 clock 60.0Hz
  800x600 (0x44) 40.0MHz +HSync +VSync
        h: width 800 start 840 end 968 total 1056 skew 0 clock 37.9KHz
        v: height 600 start 601 end 605 total 628 clock 60.3Hz
  800x600 (0x45) 36.0MHz +HSync +VSync
        h: width 800 start 824 end 896 total 1024 skew 0 clock 35.2KHz
        v: height 600 start 601 end 603 total 625 clock 56.2Hz
  848x480 (0x46) 33.8MHz +HSync +VSync
        h: width 848 start 864 end 976 total 1088 skew 0 clock 31.0KHz
        v: height 480 start 486 end 494 total 517 clock 60.0Hz
  640x480 (0x47) 25.2MHz -HSync -VSync
        h: width 640 start 656 end 752 total 800 skew 0 clock 31.5KHz
        v: height 480 start 489 end 492 total 525 clock 59.9Hz
  1024x768 (0x43) 65.0MHz
        h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.4KHz
        v: height 768 start 771 end 777 total 806 clock 60.0Hz
  800x600 (0x44) 40.0MHz
        h: width 800 start 840 end 968 total 1056 skew 0 clock 37.9KHz
        v: height 600 start 601 end 605 total 628 clock 60.3Hz
  800x600 (0x45) 36.0MHz
        h: width 800 start 824 end 896 total 1024 skew 0 clock 35.2KHz
        v: height 600 start 601 end 603 total 625 clock 56.2Hz

Christian González, could you please advise which package precisely the regression is in when you upgraded from 13.10 to 14.04?

tags: added: wily
Christian González (droetker) wrote :

Eh - what exactly do you mean? I think this is out of my knowledge. I don't know which package is responsible for detecting the monitor. IMHO it is the kernel? or xorg?
But really, there must help someone with deeper knowledge than I have ;-)

Christian González, if you use the nvidia proprietary drivers as outlined in https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia does this provide a WORKAROUND?

Christian González (droetker) wrote :

Yes, AFAIK this is a workaround. But no solution for me. The nvidia drivers have other issues - I'd really like to stay with the nouveau driver as it works perfectly besides that.
The better and easier workaround is just disabling the monitor in Systemsettings/Display.
Then everything works as expected. But the (disabled) monitor stays in the systemsettings view.

Changed in xorg (Ubuntu):
status: Incomplete → Triaged
tags: removed: vivid wily
To post a comment you must log in.