Blank screen after resume if lid closed

Bug #1307114 reported by Bruce Merry on 2014-04-13
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Lenovo G570 laptop (Intel Sandy Bridge graphics). If I suspend via the user interface, then resume by pressing the power button, everything works. However, when closing the lid to suspend, I observe the following sequence:

1. Close lid, wait a few seconds for suspend.
2. Open lid. Laptop starts up, light-locker screen is visible.
3. Type password into light-locker, hit enter.
4. Screen goes blank. It is totally black i.e. it seems that the backlight is off.

Moving the mouse, pressing keys or trying to change the brightness with the keyboard shortcut does not bring back the display. I can get a console by C-A-F1 and then restart lightdm to get a working display again.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xorg 1:7.7+1ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Apr 13 13:14:37 2014
InstallationDate: Installed on 2014-03-10 (34 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140225)
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)

Bruce Merry (bmerry) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers