system crashes on launching Mathematica 9.0.1, return to login window

Bug #1250635 reported by saturasl on 2013-11-12
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

After I updated my system (13.10) this morning, I cannot launch Mathematica. Everytime I try to launch it, the screen becomes black then go back to the login screen.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: compiz-core 1:0.9.10+13.10.20131011-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 304.88 Wed Mar 27 14:26:46 PDT 2013
 GCC version: gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu8)
.tmp.unity.support.test.0:

ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDmesg:

Date: Tue Nov 12 14:23:24 2013
DistUpgraded: 2013-10-18 11:49:20,327 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 nvidia-304, 304.88, 3.11.0-12-generic, x86_64: installed
 nvidia-304, 304.88, 3.11.0-13-generic, x86_64: installed
 nvidia-304, 304.88, 3.8.0-31-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 NVIDIA Corporation GF108 [GeForce GT 440] [10de:0de0] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd Device [1458:3518]
InstallationDate: Installed on 2012-10-28 (379 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Gigabyte Technology Co., Ltd. Z68A-D3H-B3
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic root=UUID=c9a4d91b-71b2-4040-9ac5-e455a0d33e0f ro recovery nomodeset
SourcePackage: compiz
UpgradeStatus: Upgraded to saucy on 2013-10-18 (25 days ago)
dmi.bios.date: 05/06/2011
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F4
dmi.board.name: Z68A-D3H-B3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF4:bd05/06/2011:svnGigabyteTechnologyCo.,Ltd.:pnZ68A-D3H-B3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnZ68A-D3H-B3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: Z68A-D3H-B3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.1-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.1-1ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.14.3-3ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Tue Nov 12 14:11:42 2013
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Logitech USB Optical Mouse MOUSE, id 8
 input Logitech USB Keyboard KEYBOARD, id 9
 input Logitech USB Keyboard KEYBOARD, id 10
xserver.errors:
 open /dev/dri/card0: No such file or directory
 open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.14.3-3ubuntu2

saturasl (saturasl) wrote :

confirming the same crash on a laptop running fglrx and a desktop pc running nvidia drivers. the /var/log/Xorg.0.log.old on a fglrx machine reports a segmentation violation in libgl. the crash happens probably during the mathematica startup and gl init...

with nvidia drivers the crash probably happens too fast and no tail is left in the xorg log...

btw, these two machines run xfce without any compiz, so this bug is not really related to the compiz but more with the gl libraries.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

saturasl, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg REPLACE-WITH-BUG-NUMBER

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: added: bios-outdated-f13
Changed in compiz (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
affects: compiz (Ubuntu) → xorg (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.