if DDC succeeds but doesn't provide sync ranges, the Debconf flag never gets set

Bug #12143 reported by Janis Blechert on 2005-01-22
18
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Daniel Stone

Bug Description

I just installed hoary from cd, everything worked fine till the setup was
succesfully completed. I have choosen nv driver because I have a Geforce 2 MX
400 graphics card (ASUS something). In the past I often had troubles with live
cds because of a wrong modeline which was to much for my monitor. However, after
lowering the resolution to 1024x768 - at which it normally works - the screen
still went blank. I then changed the driver from nv to vesa and it works
reasonable (I haven't tried composite but all vital functions work as good as
they get expect that my repetition rate is at 60Hz which is not the max for the
given resolution). I never had any problems with the nv driver in any
configuration, with 4.10 it works flawless in 1280x1024.
I have no clue why it would not work, however I am quite experienced in using
linux so if you have some idea I could check it out.

Janis Blechert (janis-blechert) wrote :

I just found the problem:
In 4.10 HorizSync and VertRefresh were set in the XF86Config, in hoary they are
missing. I found this out while configuring nvidia because every modeline was
out of hsync (or something), so to fix this I had to copy the HorizSync and
VertRefresh from the old XF86Config file and this also fixed the nv-bug.

What I changed:
Section "Monitor"
 Identifier "Generic Monitor"
 Option "DPMS"
EndSection

to

Section "Monitor"
 Identifier "Generic Monitor"
 HorizSync 31.5-79
 VertRefresh 50-90
 Option "DPMS"
EndSection

Daniel Stone (daniels) wrote :

This is a known problem and has been fixed locally; the upload should happen
tomorrow or such.

Daniel Stone (daniels) wrote :

*** Bug 12130 has been marked as a duplicate of this bug. ***

Daniel Stone (daniels) wrote :

 xorg (6.8.1-1ubuntu12) hoary; urgency=low
 .
   * Resync Imakefiles for Mesa, so t_vb_cull gets built, and i915_dri is
     loadable (closes: Ubuntu#5664).
   * Also from Mesa 6.2.x branch, grab fix for lockups on Radeon M7-class chips
     (fd.o#2361).
   * Update from 6.8 branch; remove patches #096 and #601 as they were merged in
     this morning. This release is almost entirely equivalent to 6.8.1.903
     (aka 6.8.2RC3).
   * Disable building of largely defunct XRX plugin in linux.cf.
   * Guess at a reasonable default for $DISPLAY_TYPE if xresprobe doesn't feed
     us a display type (closes: Ubuntu#5639).
   * Set $LAPTOP in xserver-xorg.postinst.in.
   * Move the test for resolutions-via-DDC-but-no-sync-ranges around in
     xserver-xorg.postinst.in, so $NRES is set when we call it (closes:
     Ubuntu#5754).
   * Write sync ranges for all r128s on powerpc (closes: Ubuntu#5940).
   * Remove speedo and v4l from the list of modules loaded per default.
   * Fix comments at the top of the config file to be more accurate (closes:
     Ubuntu#5748).
   * Don't load GLcore in the default set of modules, per Adam Jackson.
   * Add hardened Linux support via a small call in postinst.
   * Change default builder from canonical.com -> ubuntu.com.
   * Add <X11/Xlib.h> to scrnsaver.h's #includes, add libx11-dev dep to
     libxss-dev.

> This is a known problem and has been fixed locally; the upload should happen
> tomorrow or such.

Is it really fixed ? I just installed Hoary Array 4, and I think I still have
the same problem.
It failed to detect my monitor (despite Warty detecting it perfectly, a Nec
MuliSync M700), put genereic values and that resulted left me with no option but
640x480 at 60Hz.
I tried modifying xorg.conf with the correct 'monotir' section from Warty, but
Hoary hung while rebooting, and always hangs, so I don't know if the mods would
have worked... now waiting for Array 5 then I guess !! ;o)

Vince

Jeez, I am amazed at how many typos I managed to make in just a few lines, my
keyboard really doesn't like me !! ;o)
Sorry.

Matt Zimmerman (mdz) wrote :

The upload in question was reverted in order to fix a critical bug for array 4.
 The fix will be reinstated very soon.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.