phoronix benchmarks on nouveau is 4 times slower today than it was last thursday

Bug #1214066 reported by Chris Gagnon on 2013-08-19
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
High
Unassigned

Bug Description

Description
phoronix benchmarks on nouveau is 4 times slower today than it was last thursday

* this is with both xmir and plain xorg

steps:
1. install saucy from 20130815 on system using nvidia card (I am using two different systems nvidia gt640 and nvidia gt440)
2. sudo apt-get install phoronix-test-suite
3 phoronix-test-suite install openarena
4 phoronix-test-suite run openarena
5. install saucy from 20130819
6. sudo apt-get install phoronix-test-suite
7 phoronix-test-suite install openarena
8 phoronix-test-suite run openarena

expected results
test results from 20130819 image are about the same or better than 20130815 image

actual results:
test results from 20130819 image are about 4 times worse

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xorg 1:7.7+1ubuntu5
ProcVersionSignature: Ubuntu 3.11.0-2.5-generic 3.11.0-rc5
Uname: Linux 3.11.0-2-generic x86_64
ApportVersion: 2.12-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Mon Aug 19 17:49:00 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 NVIDIA Corporation GF108 [GeForce GT 440] [10de:0de0] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:838a]
InstallationDate: Installed on 2013-08-19 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130818)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-2-generic root=UUID=47d5d3bb-9722-4bd4-8d63-e13352d65c1a ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/08/2012
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BHZ7710H.86A.0057.2012.0208.1904
dmi.board.name: DZ77BH-55K
dmi.board.vendor: Intel Corporation
dmi.board.version: AAG39008-400
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrBHZ7710H.86A.0057.2012.0208.1904:bd02/08/2012:svn:pn:pvr:rvnIntelCorporation:rnDZ77BH-55K:rvrAAG39008-400:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.6-2ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.6-2ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2.901-2ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.14-4ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.8-0ubuntu3
xserver.bootTime: Mon Aug 19 16:39:23 2013
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Raritan D2CIM-DVUSB KEYBOARD, id 8
 input Raritan D2CIM-DVUSB MOUSE, id 9
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.14.2.901-2ubuntu1
xserver.video_driver: nouveau

Chris Gagnon (chris.gagnon) wrote :
Chris Gagnon (chris.gagnon) wrote :
Download full text (42.0 KiB)

package diff between saucy 20130815 and 20130819 image

diff dpkg-list-15.log dpkg-list-19.log
18c18
< ii acpid 1:2.0.18-1ubuntu1 amd64 Advanced Configuration and Power Interface event daemon
---
> ii acpid 1:2.0.18-1ubuntu2 amd64 Advanced Configuration and Power Interface event daemon
33c33
< ii apparmor 2.8.0-0ubuntu23 amd64 User-space parser utility for AppArmor
---
> ii apparmor 2.8.0-0ubuntu24 amd64 User-space parser utility for AppArmor
49c49
< ii at-spi2-core 2.9.4-1ubuntu3 amd64 Assistive Technology Service Provider Interface (dbus core)
---
> ii at-spi2-core 2.9.5-1ubuntu1 amd64 Assistive Technology Service Provider Interface (dbus core)
92c92
< ii cpp-4.8 4.8.1-8ubuntu1 amd64 GNU C preprocessor
---
> ii cpp-4.8 4.8.1-9ubuntu1 amd64 GNU C preprocessor
97,103c97,103
< ii cups 1.6.3-1 amd64 Common UNIX Printing System(tm) - server
< ii cups-browsed 1.0.34-3ubuntu1 amd64 OpenPrinting CUPS Filters - cups-browsed
< ii cups-bsd 1.6.3-1 amd64 Common UNIX Printing System(tm) - BSD commands
< ii cups-client 1.6.3-1 amd64 Common UNIX Printing System(tm) - client programs (SysV)
< ii cups-common 1.6.3-1 all Common UNIX Printing System(tm) - common files
< ii cups-daemon 1.6.3-1 amd64 Common UNIX Printing System(tm) - daemon
< ii cups-filters 1.0.34-3ubuntu1 amd64 OpenPrinting CUPS Filters
---
> ii cups 1.6.3-1ubuntu2 amd64 Common UNIX Printing System(tm) - server
> ii cups-browsed 1.0.36-0ubuntu2 amd64 OpenPrinting CUPS Filters - cups-browsed
> ii cups-bsd 1.6.3-1ubuntu2 amd64 Common UNIX Printing System(tm) - BSD commands
> ii cups-client 1.6.3-1ubuntu2 amd64 Common UNIX Printing System(tm) - client programs (SysV)
> ii cups-common 1.6.3-1ubuntu2 all Common UNIX Printing System(tm) - common files
> ii cups-daemon 1.6.3-1ubuntu2 amd64 Common UNIX Printing System(tm) - daemon
> i...

description: updated
summary: - phoronix benchmarks with nouveau driver is 4 times slower today than it
- was last thursday
+ phoronix benchmarks on nouveau is 4 times slower today than it was last
+ thursday
description: updated
Changed in xorg (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
tags: added: needed-xmir-automation
description: updated
Maarten Lankhorst (mlankhorst) wrote :

different versions:
- xserver updated, maybe try old 1.14.2-0ubuntu8 ? I don't think it's causing it.
- kernel updated?
- libgl updated, but nothing interesting, can you try the old one?

Changed in xorg (Ubuntu):
status: New → Incomplete
Olli Ries (ories) on 2013-08-30
Changed in xorg (Ubuntu):
assignee: Chris Halse Rogers (raof) → nobody
Changed in xorg (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Maarten Lankhorst (mlankhorst)
Changed in xorg (Ubuntu):
status: Incomplete → In Progress
Maarten Lankhorst (mlankhorst) wrote :

The bug appears to be syncing to vblank, I get multiples of 30 fps for all tests.
Running glmark2 --off-screen gets the expected fps, so I do not think this is a critical performance bug. There is a bug in the way measurements are performed though, but I don't think the actual performance changed.

Chris Gagnon (chris.gagnon) wrote :

adding Section "Device" \n Identifier "nv01" \n Driver "nouveau" \n Option "glxvblank" "false" \n EndSection to xorg.conf does not speed up the benchmark.

Chris Gagnon (chris.gagnon) wrote :

the test doesn't run at on the old xorg with the new kernel.

Changed in xorg (Ubuntu):
status: In Progress → Fix Committed
Changed in xorg (Ubuntu):
importance: Critical → High
Daniel van Vugt (vanvugt) wrote :

Won't fix. Due to lack of activity. The original reporter and the assignee are both no longer with us. And even the bug title is relative to "last Thursday" which was back in 2013.

Changed in xorg (Ubuntu):
assignee: Maarten Lankhorst (mlankhorst) → nobody
status: Fix Committed → Won't Fix
status: Won't Fix → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers