[Feisty AMD64]Closing tab in Firefox kills xorg

Bug #112637 reported by der_vegi
2
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

this is kind of strange: sometimes when i close a tab by hitting strg + w in firefox, the x-server restarts, i have to log in again.
unfortunately, i cannot alway reproduce the bug, it has happened several times on http://direct2dell.com/one2one/default.aspx and one times on www.seb.de. when firefox crashed on the dell site, i logged in again, restored the session, closed the tab and ended up with a restart of x again.

i'm using feisty final on an amd64 machine.

Revision history for this message
der_vegi (m-may) wrote :

maybe the log file helps?

description: updated
Revision history for this message
Bryce Harrington (bryce) wrote :

Hmm, there isn't an obvious error message in the Xorg.0.log file.

Can you run `strace firefox` in a console, run it until it crashes, and then attach the last 100 lines or so here?

Also, please tell what version of firefox you're using.

Fwiw, I've had firefox crash while using dell's website, but not Xorg. Have you looked in the firefox bug tracker to see if this is a known issue for them?

Changed in xorg:
status: Unconfirmed → Needs Info
Revision history for this message
Bryce Harrington (bryce) wrote :

Is this still a problem? If so, if you could answer at least some of the above questions it may help. Note that after the crash, the error might be in your Xorg.0.log.old file, so if you could, please check and upload that.

Revision history for this message
der_vegi (m-may) wrote :

Okay, this doesn't happen anymore. I'm using the latest firefox from the repos Mozilla/5.0 (X11; U; Linux x86_64; de-de; rv:1.8.1.4) Gecko/20061201 Firefox/2.0.0.4 (Ubuntu-feisty).

Revision history for this message
Bryce Harrington (bryce) wrote :

Thanks for confirming the issue no longer occurs. Closing as fixed. If you do spot it again though, please reopen.

Changed in xorg:
status: Incomplete → Fix Released
Revision history for this message
der_vegi (m-may) wrote :

another webpage, similar problem

Changed in xorg:
status: Fix Released → Incomplete
Revision history for this message
der_vegi (m-may) wrote :

okay, it happened again. now by browsing the site www.atomausstieg-selber-machen.de and opening all the news articles between july 20th and july 24th in new tabs. i open these tabs and while loading them, xorg crashes.

Revision history for this message
der_vegi (m-may) wrote :

hmpf. i've run firefox with strace several times, but where does the output go? now running strace with the -o option, but now i can't reproduce the crash anymore...

Revision history for this message
der_vegi (m-may) wrote :

ah, finally. here the output of strace firefox.

Revision history for this message
Bryce Harrington (bryce) wrote :

Hi der_vegi,

Unfortunately this still isn't providing an error message, which will make it difficult to troubleshoot.
Can you please follow the steps at https://wiki.ubuntu.com/DebuggingXorg to obtain a backtrace of xorg?

Also, please attach the output of lspci -vnn, and a copy of your /etc/X11/xorg.conf.

Revision history for this message
der_vegi (m-may) wrote :

Can't reproduce this bug anymore on Feisty with all the latest updates till sep. 25th.

Changed in xorg:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers