Ubuntu

[nvidia-glx] X module Int10 fails to initialize - Feisty

Reported by dolphinholmer on 2007-04-24
8
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Unknown
xorg (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg

Having set up xorg.conf with a ServerLayout for S-Video output to TV, when executing the said layout I receive this:

(EE) NVIDIA(0): Unable to initialize the X Int10 module; the console may not
(EE) NVIDIA(0): be restored correctly on your TV.

I haven't touched the Section "Module" in xorg.conf where int10 is listed.
The 18KB file 'libint10.so' is present in /usr/lib/xorg/modules last modified Wed 04 April 2007

I assume this file/module is provided in the xserver-xorg package - installed version 1:7.2-0ubuntu11

Had this working fine in Dapper with xserver-xorg version 7.0.0-0ubuntu45

Sitsofe Wheeler (sitsofe) wrote :

Thank you for your bug report.

dolphinholmer:
Please could you add the output of running:
dpkg -l nvidia-\* | grep ii
to this bug report?

(Sounds similar to the issue raised in Bug #89290 )

Setting to needsinfo pending reply from dolphinholmer.

Changed in xorg:
status: Unconfirmed → Needs Info
dolphinholmer (pgchapman) wrote :

ii nvidia-glx 1.0.9631+2.6.20.5-15.20 NVIDIA binary XFree86 4.x/X.Org driver
ii nvidia-kernel-common 20051028+1ubuntu7 NVIDIA binary kernel module common files

dolphinholmer (pgchapman) wrote :

After reading the link you gave to Bug #89290 I thought I would mention the following:
I have two devices section in xorg.conf:

Section "Device"
    Identifier "nVidia Corporation NV17 [GeForce4 420 Go 32M]"
    Driver "nvidia"
    Option "UseDisplayDevice" "DFP"
EndSection

Section "Device"
    Identifier "GeForce4 420 Go 32M TVOut"
    Driver "nvidia"
    Option "TVOutFormat" "SVIDEO"
    Option "TVStandard" "PAL-I"
    Option "ConnectedMonitor" "TV"
EndSection

I had to add "UseDisplayDevice" "DFP" to the main device section as X always failed with a blank laptop screen. I am of course using the other Device section for the TV-Out that is currently failing, but don't know if this addition could have affected things.

Changed in xorg:
status: Needs Info → Unconfirmed
dolphinholmer (pgchapman) wrote :

Does anyone suspect this may be resolvable soon-ish? I'll have to re-install Dapper if not.
Thanks.

PaulBawon (alkemiman) wrote :

I have exactly the same issue using the 9775 driver. My output from dpkg -l nvidia-\* | grep ii is:

ii nvidia-glx-new 1.0.9755+2.6.20.5-15.20 NVIDIA binary XFree86 4.x/X.Org 'new' driver
ii nvidia-kernel-common 20051028+1ubuntu7 NVIDIA binary kernel module common files

I have a GeoForce 6150. I believe this is what is causing my machine to not reboot properly. Everytime a reboot happens xserver crashes whilst starting up. After three or four reboots it eventually starts correctly.

dolphinholmer (pgchapman) wrote :

Have found reference to very similar (same?) bug in Debian X - http://<email address hidden>/msg60955.html

I didn't mention earlier the xserver-xorg-core package version is 2:1.2.0-3ubuntu8

David Garcia Rojo (ouioui51) wrote :

i have the same problème (feisty and nvidia 9631) in my Xorg.0.log:

(WW) NVIDIA(0): Unable to load "xf86ExecX86int10".
(EE) NVIDIA(0): Unable to initialize the X Int10 module; the console may not
(EE) NVIDIA(0): be restored correctly on your TV.

Simon Oosthoek (simon-margo) wrote :

I don't know if this makes sense, but dolphinhomer, could you try changing the config to something simpler. I was given the advice in bug https://bugs.launchpad.net/bugs/82312 (see there for specifics) to indicate my tvout config in a different way and it seemed to work (after messing a round a bit). Apparently nvidia drivers are now more self-managing, so they need less specific input from xorg.conf. You may need to add the nvidia-settings package to your system.

Another thing you could try is to dig around on the nvidia forum, perhaps you can get a hint of the meaning of the error message? It's very uninformative on its own.

good luck

Simon

dolphinholmer (pgchapman) wrote :

Thanks. It already is quite 'simple' however.
TV Device Section:

Section "Device"
    Identifier "GeForce4 420 Go 32M TVOut"
    Driver "nvidia"
    Option "TVOutFormat" "SVIDEO"
    Option "TVStandard" "PAL-I"
    Option "ConnectedMonitor" "TV"
EndSection

Not sure there are too many superfluous Options there! I'll give it a go though...

dolphinholmer (pgchapman) wrote :

I have got the TV to work by specifying it in the same 'ServerLayout' section as the default monitor.
i.e. I now only have one ServerLayout section.

This is a work around as I would much rather be able to invoke a separate layout for the TV when I wish from the default monitor.
It is with this invocation that I am having problems.

glenc (g-callaghan) wrote :

I've had the same problem with Feisty - but no problem at all with TV out in Edgy.

Here's the output of "dpkg -l nvidia-\* | grep ii"

ii nvidia-glx 1.0.9631+2.6.20.5-15.20 NVIDIA binary XFree86 4.x/X.Org driver
ii nvidia-kernel-common 20051028+1ubuntu7 NVIDIA binary kernel module common files

I'm not sure that this relevant, but I tried to use nvidia-settings to turn on tv-out. When I tried to configure the TV-out for Twinview, I got a popup message saying. "Failed to associate display device 'TV-0' with X screen 0. TwinView cannot be enabled with this combination of display devices". It wouldn't modify xorg.conf for me.

I then tried my xorg.conf from Edgy. X didn't start up properly, and the logs showed the problem about initialising X int10 module.

I'll attach the xorg.conf and the xorg log.

glenc (g-callaghan) wrote :

Here's the xorg log from the previous message.

David Garcia Rojo (ouioui51) wrote :

Hi!
Is there any news about this bug?

Why it isn't confirmed?
Lot of people have the same problem in ubuntu feisty and debian etch.

Bryce Harrington (bryce) wrote :

ouioui51, according to upstream, it is fixed as of xserver 1.3, which is available in Gutsy.

Can someone test out one of the Gutsy tribe CD's (tribe 2 was just released today), and see if the issue is still present?

Changed in xorg:
importance: Undecided → Medium
status: New → Confirmed
Changed in xorg-server:
status: Unknown → Fix Released
David Garcia Rojo (ouioui51) wrote :

I have Gutsy in PC installed by dist-upgrade
There is no more errors!
thanks

Bryce Harrington (bryce) wrote :

Thanks for confirming that the fix works. Closing as fixed.

Changed in xorg:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.