lightdm crashes on startup on 3.2.0-24+ running on MacBookPro 8.2

Bug #1025486 reported by Robert on 2012-07-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Low
Unassigned

Bug Description

Trying to boot into Ubuntu, lightdm crashes and I can't get to the UI login screen. I'm running Ubuntu 12.04 kernel version 3.2.0-24 (or 3.2.0-25) on a MacBookPro 8.2. The last version that worked is 3.2.0-23.

dmesg shows the following (hopefully relevant) info:

[ 7.472336] type=1400 audit(1336165354.283:7): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper" pid=865 comm="apparmor_parser"
[ 7.472434] type=1400 audit(1336165354.283:8): apparmor="STATUS" operation="profile_load" name="/usr/sbin/tcpdump" pid=872 comm="apparmor_parser"
[ 7.472504] type=1400 audit(1336165354.283:9): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=866 comm="apparmor_parser"
[ 7.473227] type=1400 audit(1336165354.283:10): apparmor="STATUS" operation="profile_replace" name="/usr/lib/cups/backend/cups-pdf" pid=870 comm="apparmor_parser"
[ 7.490284] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 7.490297] usbcore: registered new interface driver bcm5974
[ 7.490962] Broadcom 43xx driver loaded [ Features: PNL ]
[ 7.497433] input: FaceTime HD Camera (Built-in) as /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2:1.0/input/input9
[ 7.535990] applesmc: key=441 fan=2 temp=29 acc=1 lux=2 kbd=1
[ 7.552684] input: applesmc as /devices/platform/applesmc.768/input/input10
[ 7.558308] usbcore: registered new interface driver uvcvideo
[ 7.558310] USB Video Class driver (1.1.1)
[ 7.558371] Registered led device: smc::kbd_backlight
[ 7.621128] snd_hda_intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 7.621168] snd_hda_intel 0000:00:1b.0: irq 52 for MSI/MSI-X
[ 7.621193] snd_hda_intel 0000:00:1b.0: setting latency timer to 64
[ 7.658417] usb 1-1.1.2: USB disconnect, device number 7
[ 7.675427] input: HDA Intel PCH SPDIF In as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[ 7.793998] input: HDA Intel PCH Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[ 7.794095] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
[ 7.794416] snd_hda_intel 0000:01:00.1: PCI INT B -> GSI 17 (level, low) -> IRQ 17
[ 7.794472] snd_hda_intel 0000:01:00.1: irq 53 for MSI/MSI-X
[ 7.794552] snd_hda_intel 0000:01:00.1: setting latency timer to 64
[ 7.825759] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 7.890344] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7.890526] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 7.944798] HDMI status: Codec=0 Pin=3 Presence_Detect=0 ELD_Valid=0
[ 7.944867] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
[ 8.058060] vesafb: mode is 1400x1050x32, linelength=5632, pages=0
[ 8.058062] vesafb: scrolling: redraw
[ 8.058065] vesafb: Truecolor: size=0:8:8:8, shift=0:16:8:0
[ 8.063670] vesafb: framebuffer at 0x90000000, mapped to 0xf8e00000, using 5824k, total 5824k
[ 8.063809] Console: switching to colour frame buffer device 175x65
[ 8.063836] fb0: VESA VGA frame buffer device
[ 8.481300] BUG: unable to handle kernel paging request at 265fa1a0
[ 8.481303] IP: [<f8907ffa>] firegl_stub_open+0x9a/0x1c0 [fglrx]
[ 8.481327] *pde = 00000000
[ 8.481328] Oops: 0002 [#1] SMP
[ 8.481330] Modules linked in: vesafb snd_hda_codec_hdmi snd_hda_codec_cirrus joydev snd_hda_intel snd_hda_codec snd_seq_midi arc4 snd_hwdep snd_rawmidi snd_seq_midi_event snd_seq snd_pcm snd_seq_device b43 fglrx(P) mac80211 snd_timer apple_gmux cfg80211 snd uvcvideo ssb videodev bcm5974 applesmc soundcore btusb bcma snd_page_alloc input_polldev video mac_hid mei(C) apple_bl rfcomm bnep bluetooth parport_pc ppdev binfmt_misc coretemp lp parport hid_apple firewire_ohci firewire_core sdhci_pci crc_itu_t sdhci usbhid tg3 hid
[ 8.481352]
[ 8.481354] Pid: 1186, comm: Xorg Tainted: P C O 3.2.0-24-generic #37-Ubuntu Apple Inc. MacBookPro8,2/Mac-94245A3940C91C80
[ 8.481357] EIP: 0060:[<f8907ffa>] EFLAGS: 00013293 CPU: 3
[ 8.481372] EIP is at firegl_stub_open+0x9a/0x1c0 [fglrx]
[ 8.481373] EAX: 00000000 EBX: 00000000 ECX: f8b6b160 EDX: f31571a0
[ 8.481375] ESI: f69a8750 EDI: f2379b40 EBP: f10dbde0 ESP: f10dbdac
[ 8.481376] DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[ 8.481377] Process Xorg (pid: 1186, ti=f10da000 task=f16925e0 task.ti=f10da000)
[ 8.481378] Stack:
[ 8.481379] 0000000f 00000000 f8a2c0f8 000002c5 00000000 f8a37d3a f3c39000 c1136060
[ 8.481383] f1495b80 f8a57520 00000000 c19adebc 00000000 f10dbe10 c11368d5 f69a8750
[ 8.481387] f2379b40 f69a8750 f69a8750 f8b6b160 f1495b80 00000000 f2379b40 00000000
[ 8.481391] Call Trace:
[ 8.481395] [<c1136060>] ? mount_fs+0x180/0x180
[ 8.481397] [<c11368d5>] chrdev_open+0xb5/0x1e0
[ 8.481399] [<c113095e>] __dentry_open+0x25e/0x310
[ 8.481401] [<c1136820>] ? cdev_put+0x20/0x20
[ 8.481403] [<c1130eda>] vfs_open+0x3a/0x50
[ 8.481405] [<c1131dd9>] nameidata_to_filp+0x39/0x40
[ 8.481407] [<c113f1d7>] do_last+0x367/0x660
[ 8.481410] [<c1140504>] path_openat+0xa4/0x350
[ 8.481413] [<c10fb547>] ? shmem_setattr+0x67/0x170
[ 8.481415] [<c11408c1>] do_filp_open+0x31/0x80
[ 8.481417] [<c12a5568>] ? strncpy_from_user+0x38/0x70
[ 8.481420] [<c114be43>] ? alloc_fd+0xa3/0xe0
[ 8.481422] [<c1131ec1>] do_sys_open+0xe1/0x1f0
[ 8.481424] [<c114dd78>] ? mntput+0x18/0x30
[ 8.481426] [<c1131ffe>] sys_open+0x2e/0x40
[ 8.481429] [<c1576ed4>] syscall_call+0x7/0xb
[ 8.481432] [<c1570000>] ? encode+0x26/0x2b
[ 8.481433] Code: 90 89 d8 c1 e0 04 8b 90 a4 f9 b6 f8 85 d2 74 db 8b 4f 10 89 4d f0 8b 0a 85 c9 74 22 83 39 02 0f 84 d8 00 00 00 8b 91 70 01 00 00 <64> ff 02 8b 15 48 a4 82 c1 85 d2 75 7a 8b 90 a4 f9 b6 f8 89 57
[ 8.481454] EIP: [<f8907ffa>] firegl_stub_open+0x9a/0x1c0 [fglrx] SS:ESP 0068:f10dbdac
[ 8.481470] CR2: 00000000265fa1a0
[ 8.481471] ---[ end trace a6d45e515b0231af ]---
[ 8.604319] init: lightdm main process (1110) terminated with status 1
[ 10.534611] tg3 0000:02:00.0: eth0: Link is up at 1000 Mbps, full duplex
[ 10.534643] tg3 0000:02:00.0: eth0: Flow control is on for TX and on for RX
[ 10.534671] tg3 0000:02:00.0: eth0: EEE is disabled
[ 10.534813] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 21.358548] eth0: no IPv6 routers present
[ 23.681924] init: failsafe-x main process (1229) terminated with status 1

And here's what lightdm.log looks like:

[+0.01s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.01s] DEBUG: Starting Light Display Manager 1.2.1, UID=0 PID=1021
[+0.01s] DEBUG: Loaded configuration from /etc/lightdm/lightdm.conf
[+0.01s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Registered seat module xlocal
[+0.01s] DEBUG: Registered seat module xremote
[+0.01s] DEBUG: Adding default seat
[+0.01s] DEBUG: Starting seat
[+0.01s] DEBUG: Starting new display for greeter
[+0.01s] DEBUG: Starting local X display
[+0.12s] DEBUG: X server :0 will replace Plymouth
[+0.14s] DEBUG: Using VT 7
[+0.14s] DEBUG: Activating VT 7
[+0.14s] DEBUG: Logging to /var/log/lightdm/x-0.log
[+0.15s] DEBUG: Writing X server authority to /var/run/lightdm/root/:0
[+0.15s] DEBUG: Launching X Server
[+0.15s] DEBUG: Launching process 1073: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
[+0.15s] DEBUG: Waiting for ready signal from X server :0
[+0.15s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.15s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.35s] DEBUG: Process 1073 terminated with signal 9
[+0.35s] DEBUG: X server stopped
[+0.35s] DEBUG: Removing X server authority /var/run/lightdm/root/:0
[+0.35s] DEBUG: Releasing VT 7
[+0.35s] DEBUG: Stopping Plymouth, X server failed to start
[+0.37s] DEBUG: Display server stopped
[+0.37s] DEBUG: Stopping display
[+0.37s] DEBUG: Display stopped
[+0.37s] DEBUG: Stopping X local seat, failed to start a display
[+0.37s] DEBUG: Stopping seat
[+0.37s] DEBUG: Seat stopped
[+0.37s] DEBUG: Required seat has stopped
[+0.37s] DEBUG: Stopping display manager
[+0.37s] DEBUG: Display manager stopped
[+0.37s] DEBUG: Stopping daemon
[+0.37s] DEBUG: Exiting with return value 1

Any ideas?

Logan Rosen (logan) on 2012-07-17
affects: ubuntu → lightdm (Ubuntu)
Robert Ancell (robert-ancell) wrote :

X/driver crash

affects: lightdm (Ubuntu) → xorg (Ubuntu)

Robert, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg <replace-with-bug-number>

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xorg (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers