0408:3003 [Packard Bell oneTwo (PW.U6C)] Touch-screen did work on 11.04 but no longer works on 12.04

Bug #998546 reported by Paddy Landau on 2012-05-12
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

My touch-screen, Quanta Computer OpticalTouchScreen, used to work on Natty 11.04.

But on Precise 12.04 it is not recognised.

I understand this was supposed to have been fixed but it does not work on my system.

I am not sure what other information to provide for you, so here is some:

Ubuntu 12.04 LTS 64-bit (fully updated)
Linux Daisy 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

http://askubuntu.com/questions/134505/touchscreen-broken-after-installing-12-04

Thank you.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-24-generic 3.2.0-24.37
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: paddy 2030 F.... pulseaudio
 /dev/snd/controlC1: paddy 2030 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xfe520000 irq 46'
   Mixer name : 'Realtek ALC662 rev1'
   Components : 'HDA:10ec0662,10250012,00100101'
   Controls : 31
   Simple ctrls : 16
Card1.Amixer.info:
 Card hw:1 'CNFA257'/'Chicony Electronics Co., Ltd. CNFA257 at usb-0000:00:1a.0-1.5, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB04f2:b28b'
   Controls : 2
   Simple ctrls : 1
Date: Sat May 12 21:24:09 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
MachineType: Packard Bell oneTwo L5861
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=a7c09981-302e-47e6-b6dc-5389ae51499e ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
RfKill:

SourcePackage: linux
StagingDrivers: r8712u mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/08/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P01-A4
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: oneTwo L5861
dmi.board.vendor: Packard Bell
dmi.chassis.type: 3
dmi.chassis.vendor: Packard Bell
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP01-A4:bd03/08/2011:svnPackardBell:pnoneTwoL5861:pvr:rvnPackardBell:rnoneTwoL5861:rvr:cvnPackardBell:ct3:cvr:
dmi.product.name: oneTwo L5861
dmi.sys.vendor: Packard Bell

Paddy Landau (paddy-landau) wrote :
Brad Figg (brad-figg) on 2012-05-12
Changed in linux (Ubuntu):
status: New → Confirmed
betzi (s-betzinger-t) wrote :

Touchscreen 0408:3000 working here with 12.04 3.2.0-24-generic and hid-multitouch drivers. Before that i used it with 10.04 (singleclickonly) and windows on another computer.

dmesg:
[ 7900.310709] usbhid: USB HID core driver
[ 7901.706608] input: Packard Bell Viseo 200T as /devices/pci0000:00/0000:00:1d.0/usb6/6-2/6-2:1.0/input/input12
[ 7901.707142] hid-multitouch 0003:0408:3000.0001: input,hidraw0: USB HID v1.10 Device [Packard Bell Viseo 200T] on usb-0000:00:1d.0-2/input0

only single click events are observed, no rightclick no scroll no 2 finger actions...

will there be an extended driver in future?

Ming Lei (tom-leiming) wrote :

As feedback from upstream kernel guys, it is caused by x.org driver, instead of kernel.

See description in the below link:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/913164/comments/40

Joseph Salisbury (jsalisbury) wrote :

Adding xorg package per comment #3.

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: regression-release
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc7-precise/

tags: added: needs-upstream-testing
Paddy Landau (paddy-landau) wrote :

Joseph: I have downloaded and installed your 3.4.0 .deb as instructed.

However, it is not shown on the Grub screen (I have used sudo update-grub).

I notice that your .deb installed a new linux-headers package, but not a linux-image; is that why? Or have I done something wrong?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
bugbot (bugbot) on 2012-05-24
tags: added: kubuntu
bugbot (bugbot) on 2012-05-31
tags: added: natty
tags: added: touch
summary: - Touch-screen did work on 11.04 but no longer works on 12.04
+ 0408:3003 Touch-screen did work on 11.04 but no longer works on 12.04

it worked for me in 12.04 once the 3.4 kernel was installed

any chance of the fix for this being back ported so that it can work out of the box?

Kris Borer (kborer) wrote :

I had this problem as well. Upgrading the kernel to 3.4 did not help, but downgrading to 3.15 did.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.1.5-precise/

Zachary Salzbank (zsalzbank) wrote :

I was able to get around this by patching the kernel. It seems that because my device (ID 03fc:0588 Elitegroup Computer Systems) supported multitouch, it was no longer being picked up by the hid-core and hid-input drivers. This patch removes those checks for now. The real solution is to update hid-multitouch to support my device (and others), but until then, I will do this.

This is for Ubuntu 12.04 3.2.0-29-generic-pae #46

tags: added: patch

The attachment "touchscreen_kernel_patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

How do I go about running that patch, i see its text based and cant find any reference to running a text based patched

Zachary Salzbank (zsalzbank) wrote :

Sorry - the previous patch was garbled for some reason.

Here is a fixed one.

downgrading to 3.1 also worked for me

Paddy Landau (paddy-landau) wrote :

Any advance on this bug?

It is still present in both 12.04 and 12.10 (using kernel 3.5.0-18-generic, according to uname -r).

Zachary Salzbank (zsalzbank) wrote :

Haven't seen any updates on this, but since I need to do this every time I update the kernel, I created a script that will automatically patch the driver for me. I've attached it below. Not that it modifies /etc/depmod.d/ubuntu.conf in order to ensure the custom driver is loaded.

tags: added: quantal

Paddy Landau, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please just make a comment to this?

tags: added: needs-full-computer-model
no longer affects: linux (Ubuntu)
Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Paddy Landau (paddy-landau) wrote :

@Christopher Penalver, thank you for your query.

I have tested the latest 14.04 as you requested, using both a Live USB and an installation. Alas, the touchscreen still does not work. (The hardware still works with Windows.)

Back in July 2012, Benjamin Tissoires (who used to be on this bug's copy list) gave me a solution that worked. However, time and kernels have moved on, and that solution has long been passed by.

Paddy Landau, thank you for testing 14.04. Could you please provide a direct URL to Benjamin Tissoires's July 2012 patch or provide the patch in a comment here for review?

tags: added: trusty
Paddy Landau (paddy-landau) wrote :

Christopher, Benjamin worked it out over a series of emails. As I am not technically minded, I don't really understand what happened; I just followed a few instructions.

Fortunately, I kept all the email correspondence. I have put them into a .tar.bz2 and attached them to this bug. The names of the email files start with the date and time to make for easy chronological ordering. I hope that you can make sense of Benjamin's solution.

Thank you for your time.

Changed in xorg-server (Ubuntu):
status: Incomplete → New
Paddy Landau (paddy-landau) wrote :

Christopher, I should add that I will be happy to help with testing.

Paddy Landau, thank you for your comment. One thing that would be helpful is could you please provide the full computer model as noted on the sticker [ex. Packard Bell oneTwo (PW.U34)]?

Changed in xorg-server (Ubuntu):
status: New → Incomplete
Paddy Landau (paddy-landau) wrote :

There are two stickers at the back. The "standard" sticker reads:
Packard Bell oneTwo L5861
The serial number sticker reads:
Packard Bell oneTwo L17526UK

I hope that helps, and thank you for attending to this.

Changed in xorg-server (Ubuntu):
status: Incomplete → New
elmarikon (unrein-web) wrote :

Hi guys!
Just installed 14.04.
Still no change. the touch screen is still not working.
(0408:3003 Quanta Computer Inc.)

Paddy Landau (paddy-landau) wrote :

I confirm that it doesn't work in 14.04.

Here's the irony. If I load Windows in a virtual machine (Virtual Box), the touch screen works within the virtual Windows machine.

tags: added: bios-outdated-p01.b3
removed: needs-full-computer-model needs-upstream-testing
summary: - 0408:3003 Touch-screen did work on 11.04 but no longer works on 12.04
+ 0408:3003 [Packard Bell oneTwo (PW.U6C)] Touch-screen did work on 11.04
+ but no longer works on 12.04
Paddy Landau (paddy-landau) wrote :

I'm worried that this bug report will be closed due to lack of activity.

There is already a simple solution for this. What needs doing to implement it? (I'm not a programmer, otherwise I'd do it myself!)

Paddy Landau, it wouldn't hurt to test Utopic (live environment is fine) via http://cdimage.ubuntu.com/daily-live/current/ and advise if this would be reproducible in it.

Paddy Landau (paddy-landau) wrote :

Christopher, thank you for the suggestion.

I have tested today's 14.10 both on a virtual machine and using a Live CD.

Sadly, neither one worked.

tags: added: utopic
Paddy Landau (paddy-landau) wrote :

I read on the following link that Unity 8 will work best on a touchscreen.
http://www.techrepublic.com/article/the-science-behind-the-ebb-and-flow-of-ubuntu-unitys-popularity/

This makes me worried, as my touchscreen is still not working (over two years since this was reported, despite a solution having been offered).

Is there any news on this? Is there anything that I can do to help this along (I'm not a programmer so I can't help on that score)?

Paddy Landau, you would want to submit this upstream via https://bugs.freedesktop.org/enter_bug.cgi?product=xorg . You may want to start with Component Input/evdev , and the bug responder will advise accordingly.

Changed in xorg-server (Ubuntu):
status: New → Triaged
Paddy Landau (paddy-landau) wrote :

Christopher, thank you for the link.

I have raised a bug report:

https://bugs.freedesktop.org/show_bug.cgi?id=85916

Please check it for me to ensure that I have filled in the details correctly and that I have given sufficient information. In particular, I have no clue what to enter for the version. Thank you.

Christopher: please don't request that users file bugs for xf86-input-evdev when it's a kernel bug.

Peter Hutterer, thanks for the clarification. From my reading the kernel upstream discussion noted in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/913164/comments/40 it appeared to be a consensus that the issue was an X.Org issue, versus kernel. If this is mistaken, could you please provide technical insight on which would be the appropriate place to file this?

The device wasn't supported by the kernel before the patch, so it was running in mouse emulation mode. That is usually a firmware feature, we often see this on new touchpads before we add support and switch them to raw mode. To userspace (i.e. X.Org) it looked like a mouse device, the gesture support that betzi pointed out in Comment #2 (double click, right click, ...) was implemented in the firmware and looked like normal mouse buttons to us.

With the new kernel, the device is now switched to raw mode, i.e. we get the correct coordinates and we get multitouch features. evdev has supported MT since 2012 or so. What it doesn't do though is gestures though, so those got lost and now rely on the client stack. evdev does some right button emulation, but that's for legacy touchscreens, not true multitouch screens.

If you want this bug closed you need to either support the gestures in the client stack, or drop the patch that _enabled_ the device in the kernel so it goes back to firmware emulation mode. That is of course assuming that the gestures are the issue here, I've asked for more clarification. If the device doesn't work at all, it's a kernel issue but the fdo bug suggests that kernel 3.15 works.

Peter Hutterer, thanks for the quick follow up, and discussion. Just to clarify, the scope of this report is only the original reporter Paddy Landau, whose hardware info is 0408:3003 (not Betzi or anyone else).

Despite this, as per Paddy Landau's previous comments, this has been reproducible since 3.2.x Ubuntu kernel series through 3.16 (largely close to mainline/upstream).

From my limited understanding, a commit set landed in 3.2.x to transition to the use of usbhid. This was to standardize development, but in the process broke functionality for some devices, with the intent of circling back on these and bringing their code up to standard.

Hence, would the transition to usbhid stopping functionality be enough information to conclude this is a kernel issue, or would it be best to have Paddy Landau provide a log to make this more conclusive?

elmarikon (unrein-web) wrote :

Hi guys!

Kind of good news:
I am running Kubuntu 14.10 and by doing the following (sometimes once, sometimes it needs to be done several times),
I got the Quanta Computer OpticalTouchScreen working (single touch only):

xinput set-mode 13 RELATIVE
xinput set-mode 13 ABSOLUTE
sudo rmmod hid-multitouch
sudo modprobe hid-multitouch

Funny enough I have to set the mode to relative first and then back to absolute, I don't know, why...
I tried to put all this in a script with no success. I have the idea, it works randomly... or not...

I hope this helps!

SwK

elmarikon, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Paddy Landau (paddy-landau) wrote :

@elmarikon Thank you, but alas, that doesn't work for me.

The number 13 in your post has to change to the correct ID; I found mine using "xinput --list".

I loaded Ubuntu 14.10 64-bit, fully updated it, rebooted, and tried your commands seven times. On none of the occasions did it work.

It also didn't work on Ubuntu 14.04.

elmarikon (unrein-web) wrote :

@paddy
Well... Nr. 13 is just the number in my setup...

just type xinput and find the number of your Quanta TouchScreen...

jl451 (jl451) on 2015-08-11
Changed in xorg-server (Ubuntu):
status: Triaged → Opinion
Paddy Landau (paddy-landau) wrote :

This has been changed to "Opinion", which means that this doesn't fit with the project (despite the fact that it used to work on Ubuntu version 11.04).

Please would you tell me where I should file this bug report instead? I have absolutely no idea how to proceed.

Thank you.

Changed in xorg-server (Ubuntu):
status: Opinion → Triaged
jimlovell777 (jimlovell777) wrote :

I'm having the same issue. My touchscreen is detected and shows up when checking lsusb, xinput_calibrator, xinput --list, and dmesg -- all with no errors that I can see. In tens of hours of searching, building kernels, patching modules/drivers, downloading drivers, tools and other distros nothing has worked with one exception. I tried the suggestion of elmarikon and eventually got single touch to work 10 minutes ago.

If I can help by providing logs or testing kernels, patches, I'm willing to. I'm desperate to get this touchscreen to work reliably and support multi-touch.

Thanks to elmarikon for getting it to work for the first time in months. I can't ever power off the machine now.

Ubuntu Version
    Wily 15.10

Kernel Version
    4.2.0-17-generic

xinput --list
    ↳ Quanta Computer OpticalTouchScreen id=12 [slave pointer (2)]

lsusb
    Bus 001 Device 005: ID 0408:3003 Quanta Computer, Inc.

lsmod
    hid 118784 7 hid_multitouch,usbhid,hid_logitech_dj,hid_logitech_hidpp

dmesg (most recent output after many attempts following elmarikon's "fix")
    input: Quanta Computer OpticalTouchScreen as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/0003:0408:3003.0007/input/input16
    hid-multitouch 0003:0408:3003.0007: input,hiddev0,hidraw4: USB HID v1.10 Mouse [Quanta Computer OpticalTouchScreen] on usb-0000:00:1a.0-1.6/input0
    hid-multitouch 0003:0408:3003.0007: usb_submit_urb(ctrl) failed: -1
    hid-multitouch 0003:0408:3003.0007: usb_submit_urb(ctrl) failed: -1

Paddy Landau (paddy-landau) wrote :

This appears to have been silently fixed as from the 16.04 HWE linux kernel.

I have tested this on:

 • 16.04 64-bit, kernel 4.8.0-45 installed with linux-generic-hwe-16.04
 • 16.10 using a Live CD
 • Today's 17.04 daily build using a Live CD

I suppose that this can be marked as solved. Pity it took so long :(

Paddy Landau, I am closing this report because as per https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/998546/comments/44 the bug has been fixed in the latest development version of Ubuntu.

Changed in xorg-server (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.