Xorg Crash with Scroll in KDE

Bug #981193 reported by ybdjkfd on 2012-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Description:
     Ubuntu 11.10
Release:
     11.10
(Running Kubuntu actually)

Xorg Version:
1.10.4

MAIN ISSUE:
     Relating to scrolling in Firefox, when I scroll a long page and activate the all "Present Windows" plugin in Kubuntu while it is scrolling, the Xorg server crashes.

NOTE:
     We have heard in some bug reports of Xorg crashes when scrolling in Firefox. I have been able to consistently reproduce this crash and hope it can be investigated as a new bug or offer further benefit to the other bugs nonetheless with different combinations of hardware and software.
     I therefore do not know exactly where the bug could be presented in easystoke, kwin, Xorg, Firefox, fglrx, or the mouse input causing some issue elsewhere in Xorg input. I have only been able to verify this bug now but it has occurred in the past with previous FGLRX versions including the ones in the Ubuntu repository. I am only able to report it now since I actually figured out how to reproduce it consistently.

RELEVANT METRICS:
* Kubuntu 11.10
* Firefox 11.0
* FGLRX driver versions is 12.3
* Input drivers/system in Kubuntu 11.10
(* Catalyst version 11.10)
(* Driver Package Version 8.902-111012a-127183C-ATI)
(* 2D Driver Version" 8.95.3)
(* RandR Version 1.3)
Logitech mouse G700 activates through easystroke the "Present Windows" plugin

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7.1
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic-pae 3.0.22
Uname: Linux 3.0.0-17-generic-pae i686
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Fri Apr 13 14:07:09 2012
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LANGUAGE=
SourcePackage: xorg
Symptom: display
Title: Xorg crash
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (181 days ago)

ybdjkfd (ybdjkfd) wrote :
affects: ubuntu → xorg (Ubuntu)
ybdjkfd (ybdjkfd) on 2012-04-14
summary: - Xorg Crash with Firefox Scroll ATI KDE
+ Xorg Crash with Scroll in KDE
ybdjkfd (ybdjkfd) on 2012-04-14
tags: added: easystroke
removed: firefox i386 kde kubuntu kwin
ybdjkfd (ybdjkfd) wrote :

I have determined some interaction with easystroke, a gesture recognition program is to blame here, not Firefox or ATI exactly. The program easystoke was used to map a side button on my mouse to Super+A, which activates the "Present Windows" effect in KDE/kwin.

Scrolling in Konqueor and hitting the gesture button on the mouse. Crash. It's not just Firefox nor Mozilla. (Thunderbird also crashed in this regard earlier).
Scrolling in the Desktop (cube effect) and hitting the gesture button on the mouse. Crash. It's not a Web page nor plugin.
Scrolling in the above scenarios and hitting Super+A on the keyboard itself. No crash. It's not "Present Windows" nor kwin in this regard.
Scrolling in the above scenarios and hitting the same button on the mouse without easystroke. No crash. Its not the mouse input in that regard.

So, what is the remapping of a mouse button to Super+A and scrolling at the same time in easystroke doing to Xorg or FGLRX?

ybdjkfd (ybdjkfd) wrote :

Seems like a bug was seen in xorg, https://bugs.freedesktop.org/show_bug.cgi?id=44003, I copied the above comment there and may have to close this one upon their update.

bugbot (bugbot) on 2012-04-19
tags: added: kubuntu
bugbot (bugbot) on 2012-04-19
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
ybdjkfd (ybdjkfd) wrote :
description: updated
ybdjkfd (ybdjkfd) wrote :

Now using Precise Pangolin with events not reproducing the error.

Xorg version: X.Org X Server 1.11.3
Fglrx versions: Inlcuded in Ubuntu as 8.960. AMD web site downloads 8.961.

ybdjkfd (ybdjkfd) wrote :

Appears this does not affect X.Org X Server 1.11.3 as the I cannot reproduce the issue here.

Changed in xorg-server (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.