Unable to set 1920x1080 resolution in Ubuntu 12.04 Beta2 as a VMWare Workstation 8 guest

Bug #969154 reported by totya on 2012-03-30
120
This bug affects 25 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

My host system is Win7 64bit. My notebook has 1920x1080 native resolutions. I’m running VMWare Workstation 8 for desktop virtualization. Today I’ve installed Ubuntu 12.04 Beta2 as a guest. I was unable to set 1920x1080 resolution on the guest side. The gnome-control-center display command offered me a lot of other resolutions, but 1920x1080.

I’ve also installed the vmware-tools, because I assumed the absence of that tool is the problem. However I’ve had to realize the problem still exist after a successful vmware-tools installation. (Yep, I did a reboot after the installation.)
I have to say my Ubuntu 11.10 works like a charm, so for that version the 1920x1080 not a problem at all.

If you need more information to fix this problem, I’m glade to help you.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Fri Mar 30 14:30:13 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120327.1)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

totya (totya) wrote :
totya (totya) wrote :

Here’s a screenshot about the absence of the 1920x1080 resolution. As you can see I’m unable to choose the mentioned resolution.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, does the "xrandr" command line let you use that resolution?

Changed in gnome-control-center (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
totya (totya) wrote :

I’m also unable the set 1920x1080 resolution trough the xrandr command. Here are the possibilities:

$ xrandr
Screen 0: minimum 1 x 1, current 1680 x 1050, maximum 8192 x 8192
Virtual1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   800x600 60.0 + 60.3
   2560x1600 60.0
   1920x1440 60.0
   1856x1392 60.0
   1792x1344 60.0
   1920x1200 59.9
   1600x1200 60.0
   1680x1050 60.0*
   1400x1050 60.0
   1280x1024 60.0
   1440x900 59.9
   1280x960 60.0
   1360x768 60.0
   1280x800 59.8
   1152x864 75.0
   1280x768 59.9
   1024x768 60.0
   640x480 59.9
Virtual2 disconnected (normal left inverted right x axis y axis)
Virtual3 disconnected (normal left inverted right x axis y axis)
Virtual4 disconnected (normal left inverted right x axis y axis)
Virtual5 disconnected (normal left inverted right x axis y axis)
Virtual6 disconnected (normal left inverted right x axis y axis)
Virtual7 disconnected (normal left inverted right x axis y axis)
Virtual8 disconnected (normal left inverted right x axis y axis)

Sebastien Bacher (seb128) wrote :

thanks, that makes it an xorg issue if xrandr has the same bug, reassigning there

affects: gnome-control-center (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Shiki (shiki) wrote :

You can, set the resolution. Using "cvt", and then defining a new mode, and then setting it. But. If you set the resolution (i.e.: force) with xrandr, the text gets unusable, huge. More info on this: http://superuser.com/questions/416133/linux-guest-under-vmware-literally-huge-fonts-in-some-applications-and-situati

I don't know if this is a bug in Xorg, or in VMWare.

Shiki (shiki) wrote :

Same problem in Arch Linux. No 1920x1080 output at all.
Xorg-server 1.12.1-1

So... VMWare or Xorg? Which one is the bad guy?

Eric R (erain1001) wrote :

I am using the final release of Ubuntu 12.04, 32-bit version. I used Display to connect my second monitor. It correctly identified my second display as a Visio 22" M220VA. It displays true 1080p (1920x1080) resolution. But when I try to select this resolution for my montior, it is not an available option, although I can scroll up into a blank area when I suppose other resolutions should be listed. I try to select one of the available lower resolutions and I instead get some out of range error, or something like that. I know nothing about VMWare or Xorg. This is just a standard installation of 12.04 LTS. I was able to use this second monitor under 11.10. I have connected to this second monitor through a VGA analog cable.

Shiki (shiki) wrote :

Eric, press the "this bug affects me" button at the top. I think it's a similar cause, so that would make someone look into the code. (Seriously, this is a really easy bug to fix, but you need to know the code base. Which I don't know, and I have no idea where to start. So.. please, dear Ubuntu developers. Fix this.)

Karan Batra (karanganesha04) wrote :

A workaround: don't focus on getting the 1920x1080 entry show up in the menu. Unmaximize the vmware window, with display properties opened. Then on resizing your window, first note that the resolution is auto-adjusted to a smaller resolution. Next, maximize the window and it should autoset it to 1920x1080. This worked for me, so try it out.

RedjV (redjflcontrib) wrote :

I also encounter the bug, with VMWare Player 4.0.4 and new install of Ubuntu 12.04 64Bit (up to date - 23/07/2012)

Yurif (yurif) wrote :

I can confirm this bug. I have it on Ubuntu 12.04 and Mint Maya. I can also confirm the workaround from above. For me it was enough to simply switch in my VMware display settings to "autofit guest". As soon as I maximize I am in a real 1920x1080 resolution (in the display settings in Linux it also says 1920x1080 but it is not possible to safe this as default - or at least it doesn't work - or apply it).

As I really don't like the "autofit guest" feature I hope this will be patched. Any information on a better workaround would also be appreciated.

Simon Rodan (simon-rodan) wrote :

 Karan Batra's workaround didn't work for me (VMWare Player 4.0.4 and new install of Ubuntu 12.04 64Bit). What did was using the Xconf settings editor (Aplication Menu->Settings->Settings editor), setting the resolution by hand and then using Settings Display (the newly created resolution appears at the top of the list) to set the resolution.

Simon Rodan (simon-rodan) wrote :

Addendum to #15: I forgot to mention that I also had to reinstall VMware tools.

Yurif (yurif) wrote :

I also was able to also achieve to add 1920x1080 permanently in Mint by editing the x.org configuration. Apparently there is no such thing like a Xconf settings editor (or at least I haven't found anything) in Mint so Simon's way isn't working. But what did was following this tutorial http://community.linuxmint.com/tutorial/view/877 only with the command "cvt 1920 1080" and than the modeline generated by it. I also had the problem that after "sudo service mdm stop" everything (also the command line) blacked out completely, another Ctrl+Alt+F1 brought the command line back for me.

Still a nasty bug which really should get addressed...

intel (dts-dreamer) wrote :

Hi to all :)
I have temp fix for that.
The long story short is:
I just make configured xorg.conf file and copy it to /etc/X11. And of course RESTART! :)
Now i have native 1080p without more issues/errors, but resolution is permanently locked to 1080p/60Hz
If this is ok for you, here is the configured xorg.conf in the attachment.
I know that is a temp fix, not proper fix, but ...
This is the world of Linux :)

Pls someone to test the fix and confirm :)

Jesse Jarrell (hitechwizard) wrote :

I was having the same problem with resolution being limited to 1600x1200. Turns out that in the VM settings I had "Specify monitor settings" with one monitor specified and "Maximum Resolution of any one monitor" set to 1600x1200, which is the largest resolution listed. Once I set it to "Use host setting for monitors" (can only be changed with VM powered off) and restarted with the VM maximized it set itself to 1920x1080. I don't think this is an issue with xorg but with VMWare Workstation 8.

security vulnerability: no → yes
security vulnerability: yes → no

Also effects Ubuntu 12.04 LTS (32 bit) on VMPlayer version 5.0.0.
I can confirm karanganesha04's workaround worked for me.

Tobias Beer (beertobias) wrote :

@karanganesha04 & @chris-m-solomon:

Are you sure that this does actually set the resolution and not only stretches whatever resolution is actually set to cover the entire screen? ...at least this is what happens for me when I try your method.

As for the xorg.conf fix: I had no luck with that as neither it does exist on my machine nor was I able to create one properly.

The attachment "Temp fix for 1080p res vmware ubuntu guest that missing" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Shiki (shiki) wrote :

Jesus Canonical. Just give us a Xorg dev for 15 minutes so he can fix the problem.
(We can't possibly dig through every line since this regression popped up. Even diffing xorg versions would be a tremendous work.)

Tobias Beer (beertobias) wrote :

@dts-dreamer & @crichton

Just to confirm, creating an xorg.conf as attached by the #patch from intel (dts-dreamer) worked for me.

I don't know if any (other virtualized) hardware is (negatively) affected by simply using this xorg.conf ...but setting 1920x1080 is now available under display settings and works.

Thanks, Tobias.

totya (totya) wrote :

Initially I was the person who reported this bug. So I would like to confirm xorg.conf which attached by intel (dts-dreamer) works for me as a workaround. Now I can use 1920x1080 resolution in my VMware Workstation 9 with Ubuntu 12.10.

Thanks for the workaround!

totya

Tobias Beer (beertobias) wrote :

"Never change a running system."

Well, I dared to upgrade Kubuntu from 12.04 to 12.1 and here's what happened:

a) The resolution 1920x1080 is still there thanks to the xorg.conf by intel (dts-dreamer) and can still be selected and set in the display settings.

b) However, whenever I restart, the resolution is put back to 800x600 and I have to manually set it each time.

This might not be directly related to this bug. But if someone had an idea / fix for this or something pointing me in the right direction, please share.

Thanks, Tobias.

Shiki (shiki) wrote :

@Totya and @dts-dreamer:
Note that the xorg.conf only works in Kubuntu and Ubuntu. In Xubuntu it crashes XFCE.
So the bug is still there, but the workaround works in some Ubuntu-flavors.

Still, Canonical should patch the issue.
We are almost at 13.04 and the issue is STILL in Ubuntu.

Shiki (shiki) wrote :

Reported the bug on the official Xorg bugtracker:
https://bugs.freedesktop.org/show_bug.cgi?id=62907

Alexey Borzenkov (snaury) wrote :

I've been looking into this for a couple of evenings now, patching xserver-xorg-video-vmware to find out where and why 1920x1080 mode is disappearning. Turns out I've been looking in the wrong place, since 1920x1080 is simply never there. Digging where these modes are really coming from I found a builtin mode list is in the kernel, see:

http://lxr.free-electrons.com/source/drivers/gpu/drm/vmwgfx/vmwgfx_kms.c

It's interesting that even latest Linux 3.10 doesn't have 1920x1080 in there! Could someone push for this extremely common mode to be included in the kernel?

Alexey Borzenkov (snaury) wrote :

Hmm, or maybe it's not entirely it. I tried downloading current kernel source (apt-get source linux-image-`uname -r`), patching the desired mode in:

diff -druN vmwgfx-orig/vmwgfx_kms.c vmwgfx-patched/vmwgfx_kms.c
--- vmwgfx-orig/vmwgfx_kms.c 2013-08-27 00:54:42.000000000 +0400
+++ vmwgfx-patched/vmwgfx_kms.c 2013-08-27 00:29:38.000000000 +0400
@@ -1774,6 +1774,10 @@
  { DRM_MODE("1856x1392", DRM_MODE_TYPE_DRIVER, 218250, 1856, 1952,
      2176, 2528, 0, 1392, 1393, 1396, 1439, 0,
      DRM_MODE_FLAG_NHSYNC | DRM_MODE_FLAG_PVSYNC) },
+ /* 1920x1080@60Hz */
+ { DRM_MODE("1920x1080", DRM_MODE_TYPE_DRIVER, 173000, 1920, 2048,
+ 2248, 2576, 0, 1080, 1083, 1088, 1120, 0,
+ DRM_MODE_FLAG_NHSYNC | DRM_MODE_FLAG_PVSYNC) },
  /* 1920x1200@60Hz */
  { DRM_MODE("1920x1200", DRM_MODE_TYPE_DRIVER, 193250, 1920, 2056,
      2256, 2592, 0, 1200, 1203, 1209, 1245, 0,

Then building and installing it:

$ make -C /lib/modules/`uname -r`/build INSTALL_MOD_DIR=updates
$ sudo make -C /lib/modules/`uname -r`/build INSTALL_MOD_DIR=updates modules_install

After reboot I can verify that my patched module is loaded:

$ modinfo vmwgfx | grep filename
filename: /lib/modules/3.2.0-52-generic/updates/vmwgfx.ko

However xrandr still doesn't show 1920x1080 in the list of modes, and I don't see it probed in Xorg.0.log. Weird... :-/

Alexey Borzenkov (snaury) wrote :

Ah, no, it actually works!! :) I just needed to do update-initramfs, since it's probably loaded earlier than I thought at first. :)

totya, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg-server REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
totya (totya) wrote :

Now I use Ubuntu 13.10 on a VMware Workstation 9, and it works perfectly. It hasn't an issue anymore. You can close the bug report.

totya, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/969154/comments/33 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.