[regression] Can't change refresh rate in Displays

Bug #958424 reported by Darxus on 2012-03-18
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Unassigned
gnome-control-center
Fix Released
Low
Baltix
Undecided
Unassigned
gnome-control-center (Ubuntu)
Wishlist
Unassigned
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

First thing I noticed when booting Precise was the screen flickering. Yes, I'm still using a CRT. I don't see any way to make the flickering go away by setting the refresh rate to something sane (for a CRT).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.3.90-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Sun Mar 18 05:45:08 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.2-0ubuntu2
 deja-dup 21.90-0ubuntu1
 gnome-bluetooth 3.2.2-0ubuntu2
 indicator-datetime 0.3.90-0ubuntu1

Darxus (darxus) wrote :
Darxus (darxus) wrote :

Looks like the problem is automatic monitor detection, not inability to manually configure refresh rate. Oneric does fine with auto-detection. It detects my monitor as a 'Viewsonic Corporation 20"'. Precise doesn't detect it. It's a Viewsonic G220fb.

Changed in gnome-control-center (Ubuntu):
status: New → Invalid
Ewald Koerner (ekoerner) wrote :

I just installed Beta 2 and my CRT flickered because the refresh rate was incorrect. Installation included the NVIDIA driver. Display settings showed that the monitor is unknown. I removed the NVIDIA driver. After reboot everything was fine, refresh rate was good and the monitor was recognized.

Daniel van Vugt (vanvugt) wrote :

Confirmed. The Displays control panel doesn't let you change the refresh rate.

If I open a terminal however and type "xrandr" I can see there are other refresh rates possible. It's just that the Gnome (3.x) Displays control panel doesn't let you change it any more.

Changed in gnome-control-center (Ubuntu):
status: Invalid → Confirmed
tags: added: regression-release
Daniel van Vugt (vanvugt) wrote :

Marking this as regression-release, because I'm sure it was possible in 11.04 (Gnome 2.x).

summary: - Can't change refresh rate in Displays
+ [regression] Can't change refresh rate in Displays
Eros (bayonettabona) wrote :

I confirm the bug.can't change refresh rate in nvidia panel

Sebastien Bacher (seb128) wrote :

that's an upstream design bug, we don't plan to distro patch that option over GNOME, the refresh rate is not revelant for most users especially in lcd days

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Won't Fix
Darxus (darxus) wrote :

The bug I opened for failed monitor detection was bug 958439.

Daniel van Vugt (vanvugt) wrote :

seb128: Unfortunately refresh rate is important for two reasons:

1. Intel (and other?) drivers offer low refresh rate options (around 40Hz) for saving power on laptops. In older Ubuntu releases I had the option of selecting this mode, but now in 12.04 I don't (despite the driver still supporting it).

2. Surprisingly many users still use CRTs (as I have learnt from triaging bugs). And many of them do so because they like having the option of using 100-120Hz modes that LCDs cannot do. However they can't easily use those modes if there is no control panel to enable them.

Changed in gnome-control-center (Ubuntu):
status: Won't Fix → Confirmed
Sebastien Bacher (seb128) wrote :

Daniel: I didn't know about 1. and I doubt many users do, those who are technical enough to know about this will also be able to use the xrandr command line, the others would just be confused by the option

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged

I've got this problem too, but in my case, I've got an LCD in which refresh rate should be set at 60hz. However, the OS reverts it to 75Hz at every reboot. I think it can be harmful for my LCD due to overheat and overload. I'd found out that in Xubuntu 12.04 the problem doesn't exist, so I installed it yesterday at this is true. Xubuntu works like a charm. But I like Ubuntu more, so I'm hoping someone knows how to fix it.

Steve Howe (stevehowe) wrote :

I have a flat screen LCD monitor and the refresh rate is set out of range. I have no idea what 12.04 thinks it's dealing with. Occasionally I get a visible screen for a second or so which after many such second-long flashes lets me change to resolution to 1024x768 which, though not nice (native 1280x1028) is readable and thence to 1280x960. I have just "upgraded" from 10.04 and found I can no longer set the refresh rate manually. Why is it that "upgrading" so often leads to loss of functionality?
Installing Mate restores all the functionality of 10.04 (including the world daylight indicator) and as a bonus removes Unity.
So I can now run my monitor at nice resolution and refresh rate.
Now all I have to do is find a way to keep the settings as default so I can actually see the screen when I log in. "Set as default" doesn't seem to work :-(
Time to look into xrandr I suppose.
If the problem is known as an upstream bug and it makes 12.04 almost unusable without Mate shouldn't it be fixed?

Darxus (darxus) wrote :

Steve, I originally opened this bug, and then realized my main problem was failure to properly detect my monitor: bug 958439. You may want to look in that direction. Monitors *should* be communicating their capabilities to the computer, and at that point it should be easy for the OS to determine an ideal refresh rate for any resolution. So you really shouldn't need to be able to manually specify a refresh rate. And I can see, given that it should be completely unnecessary, people wanting to remove the capability to make the interface slightly less complicated. But Daniel pointed out in comment #9 that there are reasons to have it.

Logan Rosen (logan) on 2012-09-29
Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center:
importance: Unknown → Low
status: Unknown → New
Changed in gnome-control-center:
status: New → Confirmed
Changed in mir:
status: New → Fix Released
importance: Undecided → Medium
Changed in xmir:
status: New → Fix Committed
Changed in xmir:
importance: Undecided → Medium
affects: xmir → xorg-server (Ubuntu)
tags: added: xmir
Daniel van Vugt (vanvugt) wrote :

No longer an xmir bug.

Changed in xorg-server (Ubuntu):
status: Fix Committed → Won't Fix
status: Won't Fix → Triaged
tags: removed: xmir
Changed in gnome-control-center:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.