Touchscreen does not work with unity-3d

Bug #949791 reported by burli on 2012-03-08
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Chase Douglas

Bug Description

I have a Viewsonic Viewpad 10 (Atom based) tablet running Precise 32 Bit. If I use Unity-2D the Touchscreen works as expected.

If I run Unity-3D I can tap once or twice. From that point I can just move the mouse pointer, but I can't click on anything.
---
.tmp.unity.support.test.0:

ApportVersion: 1.94.1-0ubuntu1
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: None
DistUpgraded: Fresh install
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: Device [1b35:2206]
   Subsystem: Device [1b35:2206]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120228.1)
MachineType: ViewSonic VPAD10
Package: xorg-server (not installed)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic-pae root=UUID=cd3301a7-4285-4500-8624-7216713d4362 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic-pae 3.2.9
Tags: precise ubuntu regression single-occurrence
Uname: Linux 3.2.0-18-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 11/15/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080016
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: VPAD10
dmi.board.vendor: ViewSonic
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: ViewSonic
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080016:bd11/15/2010:svnViewSonic:pnVPAD10:pvr1.0:rvnViewSonic:rnVPAD10:rvr1.0:cvnViewSonic:ct10:cvr1.0:
dmi.product.name: VPAD10
dmi.product.version: 1.0
dmi.sys.vendor: ViewSonic
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

burli (mb-embedit) on 2012-03-08
description: updated

apport information

tags: added: apport-collected precise regression single-occurrence ubuntu
description: updated
burli (mb-embedit) wrote : BootLog.gz

apport information

apport information

apport information

apport information

apport information

burli (mb-embedit) wrote : Lspci.txt

apport information

burli (mb-embedit) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in xorg-server (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
burli (mb-embedit) wrote :

I am currently trying Kubuntu-Active with the same problem. I can move the mouse cursor, I can activate some mouse over effects, but I can't click anything.

affects: xorg-server (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Triaged
mweyen (mweyen) wrote :

same here on an acer aspire 1825ptz convertible:
unity not working (if i try to move a window via touchscreen it immediately stops to react to any clicks, both mouse and touch clicks)
gnome-shell works ok so far

i can reproduce it to 100% and right after boot+login, so if anyone needs more info just say what's needed and i'll do my best to deliver it

fmo (fmo) wrote :

Hi,

I observe the exact same behaviour as mweyen on an ExoPC running a fresh install of Ubuntu 12.04 updated up to today

Chase Douglas (chasedouglas) wrote :

There have been some changes in utouch-grail that have resolved many issues. Please update to version 3.0.5-0ubuntu1 once it is available.

However, I do seem to have problems interacting with unity/compiz with a touchscreen. I can't drag windows around by touching the title bar, for example. I will try to look into this.

burli (mb-embedit) wrote :

libutouch-grail1 3.0.5-0ubuntu1 is installed, but did not change anything. But did not install utouch-grail-tools or utouch itself. Do I have to?

Chase Douglas (chasedouglas) wrote :

Hi burli,

No, the library is all you need.

The latest xserver-xorg-core 1.11.4-0ubuntu9 includes a fix for compiz touchscreen interactions. Now you can drag the window by using the title bar, and the Unity grab handles work again.

However, I still see an issue where compiz is not always releasing a pointer button grab. This is what is causing the hangs people see in this bug report. I'm continuing to debug it.

burli (mb-embedit) wrote :

Yeah, I have to revice my previous statement. There is a change in behaviour. I can use programs like Nautilus or Chromium now, but there is still an issue with the launcher, the panel and the desktop. I just can tap once, than it hangs like you described. I can solve this by changing the desktop

Chase Douglas (chasedouglas) wrote :

This is caused by bad input event mask checking and handling in the X server for touchscreen pointer emulation. The following patches fix the issue:

http://lists.x.org/archives/xorg-devel/2012-April/030265.html
http://lists.x.org/archives/xorg-devel/2012-April/030267.html
http://lists.x.org/archives/xorg-devel/2012-April/030266.html

affects: unity (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
milestone: none → ubuntu-12.04
status: Triaged → In Progress
status: In Progress → Fix Committed
Chase Douglas (chasedouglas) wrote :

Some more info on what was going on:

Nautilus, the file manager, is in charge of the desktop. This is how files on your desktop are managed. When it sees button press event, it grabs the device. When the button release event is seen, it ungrabs the device.

GTK is only selecting for events on master devices, but if it sees an event on a slave device it will interpret the event as though it came from a master device. The bugs in the X server were generating both master and slave button press events.

Slave and master events are delivered independently. The master button presses were being sent correctly to other windows that the user touched. The slave button presses were being sent only to Nautilus due to the X bug. This was causing nautilus to grab the master device, so all further events were being directed to it instead of to other windows.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.11.4-0ubuntu10

---------------
xorg-server (2:1.11.4-0ubuntu10) precise; urgency=low

  * Fix touchscreen pointer emulation (LP: #949791)
    - Add temporary patch 506_touchscreen_pointer_emulation_checks.patch
 -- Chase Douglas <email address hidden> Wed, 04 Apr 2012 16:53:33 -0700

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
mweyen (mweyen) wrote :

hi,

thx for the fix ... that makes things better ... but there are still issues left.
i can now move windows using the touchscreen but most of the time when i try to touch the clock/username/config thingies in the top right corner the same effect happens again -> no click/touch events visible.

If you need more information just say ... i'll be happy to provide it, but i have no idea what to provide.

Chase Douglas (chasedouglas) wrote :

Hi mweyen,

Please file a new bug report for the remaining issues you see.

Thanks!

Chase Douglas (chasedouglas) wrote :

mweyen, I forgot to add, please assign me when you've created the new bug.

Samuel Wolf (samuel-wolf) wrote :

Still have the problem with a up to date ubuntu 12.04 on a WeTab.

beccon (beccon) wrote :

Are there any PPAs to with the patched xorg?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers