Ubuntu

Xorg crashed with SIGABRT in __libc_message "double free or corruption (out)" from DeleteInputDeviceRequest

Reported by Matthias Klose on 2012-02-16
170
This bug affects 22 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Canonical X.org
Precise
High
Canonical X.org

Bug Description

this happens since the machine was updated from 20120210 to the current development release. Usually when switching workspaces, X crashes, and I'm presented with a the login manager screen.

#3 0x00007fea2c84f8e6 in malloc_printerr (action=3, str=0x7fea2c94d3d0 "double free or corruption (out)", ptr=<optimized out>) at malloc.c:5007
        buf = "00007fea2f46bd70"
        cp = <optimized out>
#4 0x00007fea25cc17ad in SynapticsUnInit (drv=<optimized out>, pInfo=0x7fea2f47d570, flags=<optimized out>) at ../../src/synaptics.c:820
        priv = 0x7fea2f487b20
#5 0x00007fea2e6d6bb9 in DeleteInputDeviceRequest (pDev=0x7fea2f4881e0) at ../../../../hw/xfree86/common/xf86Xinput.c:1012
        pInfo = 0x7fea2f47d570
        drv = 0x7fea2f46b720
        isMaster = 0
#6 0x00007fea2e6e3271 in remove_device (dev=0x7fea2f4881e0, backend=0x7fea2e7d4f1e "udev") at ../../config/config.c:84
No locals.
#7 remove_devices (backend=0x7fea2e7d4f1e "udev", config_info=0x7fea2f9fb3d0 "udev:/sys/devices/pci0000:00/0000:00:1d.2/usb7/7-2/7-2:1.2/input/input5/event5") at ../../config/config.c:96
        dev = 0x7fea2f4881e0
        next = 0x7fea2f4a7800
#8 0x00007fea2e6e3cfa in device_removed (device=<optimized out>) at ../../config/udev.c:227
        value = 0x7fea2f9fb3d0 "udev:/sys/devices/pci0000:00/0000:00:1d.2/usb7/7-2/7-2:1.2/input/input5/event5"
        syspath = <optimized out>

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-core 2:1.11.4-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
NonfreeKernelModules: nvidia wl
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 290.10 Wed Nov 16 17:39:29 PST 2011
 GCC version: gcc version 4.6.2 (Ubuntu/Linaro 4.6.2-14ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CrashCounter: 1
CurrentDmesg:
 [ 21.245943] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 27.384709] init: plymouth-upstart-bridge main process (761) killed by TERM signal
 [ 32.248103] eth0: no IPv6 routers present
Date: Thu Feb 16 15:36:28 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 3.2.0-15-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.2.0-16-generic, x86_64: installed
 nvidia-current, 290.10, 3.2.0-15-generic, x86_64: installed
 nvidia-current, 290.10, 3.2.0-16-generic, x86_64: installed
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 NVIDIA Corporation G84 [GeForce 8600M GT] [10de:0407] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Apple Inc. Device [106b:00a3]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64+mac (20120118)
JockeyStatus:
 kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:wl - Broadcom STA wireless driver (Proprietary, Enabled, In use) [auto-install]
 kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_173_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_current - nvidia_current (Proprietary, Enabled, Not in use)
MachineType: Apple Inc. MacBookPro4,1
ProcCmdline: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-16-generic root=UUID=c058c398-1709-4b98-bc87-c17cc7bc93c8 ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: nvidia-graphics-drivers
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/xorg/modules/input/synaptics_drv.so
Title: Xorg crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 02/09/08
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP41.88Z.00C1.B00.0802091544
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F42C89C8
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 2
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F42C89C8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP41.88Z.00C1.B00.0802091544:bd02/09/08:svnAppleInc.:pnMacBookPro4,1:pvr1.0:rvnAppleInc.:rnMac-F42C89C8:rvrPVT:cvnAppleInc.:ct2:cvrMac-F42C89C8:
dmi.product.name: MacBookPro4,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Matthias Klose (doko) wrote :
visibility: private → public

StacktraceTop:
 __libc_message (do_abort=2, fmt=0x7fea2c94d270 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=3, str=0x7fea2c94d3d0 "double free or corruption (out)", ptr=<optimized out>) at malloc.c:5007
 SynapticsUnInit (drv=<optimized out>, pInfo=0x7fea2f47d570, flags=<optimized out>) at ../../src/synaptics.c:820
 DeleteInputDeviceRequest (pDev=0x7fea2f4881e0) at ../../../../hw/xfree86/common/xf86Xinput.c:1012
 remove_device (dev=0x7fea2f4881e0, backend=0x7fea2e7d4f1e "udev") at ../../config/config.c:84

Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Medium
summary: - Xorg crashed with SIGABRT in raise()
+ Xorg crashed with SIGABRT in __libc_message()
tags: removed: need-amd64-retrace

just to avoid confusion. this machine was running eglibc-2.15 for some months without any issues.

Robert Hooker (sarvatt) on 2012-02-16
affects: nvidia-graphics-drivers (Ubuntu) → xorg-server (Ubuntu)
Matthias Klose (doko) wrote :

this crashes now several times a day for me

Changed in xorg-server (Ubuntu):
importance: Medium → High
milestone: none → ubuntu-12.04-beta-1
Bryce Harrington (bryce) wrote :

Does updating to xserver-xorg-input-synaptics 1.5.99~git20120220-0ubuntu3 help?

Changed in xorg-server (Ubuntu Precise):
status: New → Incomplete
Martin Pitt (pitti) on 2012-03-02
Changed in xorg-server (Ubuntu):
milestone: ubuntu-12.04-beta-1 → ubuntu-12.04-beta-2
Bob Bib (bobbib) wrote :

bryce,
I've got a duplicate bug #956642 using xserver-xorg-input-synaptics 1.5.99~git20120223-0ubuntu2

Changed in xorg-server (Ubuntu Precise):
status: Incomplete → Confirmed
tags: added: rls-mgr-p-tracking
Martin Pitt (pitti) on 2012-03-26
Changed in xorg-server (Ubuntu Precise):
assignee: nobody → Canonical X.org (canonical-x)
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
Colin D Bennett (colinb) wrote :

I hit this crash with a fresh install (i.e., not upgraded from prior release) 12.04 prerelease.

I added a few more duplicate Bugs.

I usually encounter this Bug when surfing the web although it happens randomly as well.

I crash back to the login screen.

I did a clean install of 12.04 yesterday. Bug is still present.

By the way.. I am not on a mac and have been running this PC for years with ubunto without problems

Bryce Harrington (bryce) wrote :

We're not sure the bugs marked as dupes of this bug are actually the same underlying issue as this bug report, however apport is stripping the cores and stacktraces from those bugs so it's impossible to say for sure. But of the dupes I looked at, we do already have similar reports filed.

Bryce Harrington (bryce) on 2012-04-02
summary: - Xorg crashed with SIGABRT in __libc_message()
+ Xorg crashed with SIGABRT "double free or corruption (out)" from
+ DeleteInputDeviceRequest
Changed in xorg-server (Ubuntu Precise):
status: Confirmed → Triaged

I added them as Duplicates because I am unable to pinpoint a culprit or to reproduce the bug at will.

If you need further logs etc. I will be happy to provide them.

Bryce Harrington (bryce) on 2012-04-03
summary: - Xorg crashed with SIGABRT "double free or corruption (out)" from
- DeleteInputDeviceRequest
+ Xorg crashed with SIGABRT in __libc_message "double free or corruption
+ (out)" from DeleteInputDeviceRequest
tags: added: bugpattern-needed
Bryce Harrington (bryce) on 2012-04-06
description: updated
Robert Hooker (sarvatt) wrote :

Matthias: are you still hitting this bug? It seems like the apport retracer is duplicating other bugs to this one even if they are unrelated so it would be good to close this one if not.

Robert Hooker (sarvatt) wrote :

Matthias: I am closing this because I know it was fixed when eglibc was uploaded not long after preventing the X crashes with nvidia, and unfortunately duplicates are amassing via apport bugs that aren't really duplocates. If anyone has a bug they are still hitting that is a duplicate of this please file a new bug and we'll look at it. Many apologies for the trouble!

Changed in xorg-server (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.