Xephyr assert failure: Xephyr: ../../../../include/privates.h:116: dixGetPrivateAddr: Assertion `key->initialized' failed.

Bug #821090 reported by Haggai Eran on 2011-08-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Debian)
Fix Released
Unknown
xorg-server (Ubuntu)
Medium
Bryce Harrington

Bug Description

Whenever I run Xephyr it crashes with the assertion error in the title.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: xserver-xephyr 2:1.10.2.902-1ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
Architecture: amd64
AssertionMessage: Xephyr: ../../../../include/privates.h:116: dixGetPrivateAddr: Assertion `key->initialized' failed.
BootLog:
 fsck from util-linux 2.19.1
 /dev/sda1: clean, 170090/351568 files, 927500/1404672 blocks
 Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unitydialog,unityshell]
CompositorRunning: None
Date: Thu Aug 4 22:21:28 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: virtualbox-guest, 4.0.10, 3.0.0-7-generic, x86_64: installed
ExecutablePath: /usr/bin/Xephyr
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110728)
Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize libusb: -99
MachineType: innotek GmbH VirtualBox
ProcCmdline: Xephyr :1
ProcEnviron:
 SHELL=/bin/bash
 LANG=he_IL.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-7-generic root=UUID=26a58786-168f-4d15-9589-dc51f21d4463 ro quiet splash vt.handoff=7
Renderer: Software
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
 ?? ()
 ?? ()
Title: Xephyr assert failure: Xephyr: ../../../../include/privates.h:116: dixGetPrivateAddr: Assertion `key->initialized' failed.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
peripherals:
 /desktop/gnome/peripherals/mouse:
   cursor_theme = DMZ-White
version.compiz: compiz 1:0.9.5.0-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11~1-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11~1-0ubuntu4
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Haggai Eran (haggai-eran) wrote :

StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
 ?? ()
 ?? ()

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Bryce Harrington (bryce) wrote :

I'm not able to reproduce this bug on my oneiric box, and unfortunately the stacktrace that was automatically included lacks most of the symbols.

Please collect a full backtrace manually using gdb - see http://wiki.ubuntu.com/X/Backtracing for directions (skip down past all the apport directions for the stuff relating to gdb).

Changed in xorg-server (Ubuntu):
status: New → Incomplete
visibility: private → public
Bryce Harrington (bryce) wrote :

Fixed by 221_dixsetprivate_assertion_fix.patch.

Don't worry about gathering the backtrace, this should fix it.

Changed in xorg-server (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
status: Incomplete → In Progress
Changed in xorg-server (Debian):
status: Unknown → Fix Released
Bryce Harrington (bryce) wrote :

Fix is included in the upstream git tree that will be rolled out in oneiric as version 2:1.10.4-1ubuntu1

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.10.4-1ubuntu1

---------------
xorg-server (2:1.10.4-1ubuntu1) oneiric; urgency=low

  [ Christopher James Halse Rogers ]
  * Drop i8xx-disablement patch. 2.6.39 and later kernels contain a patch
    which alledgedly fixes the cache-incoherency problems. (LP: #817814)

  [ Ricardo Salveti de Araujo ]
  * debian/patches/112_armel-pvr-drv.patch:
    - Include support for the pvr driver available on OMAP 4 (LP: #828494)

  [ Timo Aaltonen ]
  * Merge from Debian unstable.
    - Fixes Xephyr assert failure in dixGetPrivateAddr (LP: #821090)
  * debian/rules: Modify the patch stampdir creation.
  * Update patch 500_xi2.1.patch to apply.
  * Refresh patches.
  * debian/rules: Add PATH for the xvfb-run check, otherwise Xvfb is not found.
  * debian/rules: Shift the xvfb-run test to be run later, to ensure that the
    binaries are installed.

  [ Bryce Harrington ]
  * debian/rules: Add check target invoking xvfb-run to test that it works
  * debian/control: Add build dependency on xauth, required by xvfb-run

  [ Chase Douglas ]
  * Add fixes for touch grab handling, courtesy of Carlos Garnacho
    - 505_Xi_ensure_replayed_touch_events_have_devices.patch
    - 506_Xi_ensure_touch_events_update_currentTime.patch
    - 507_dix_Ensure_touch_events_are_delivered_to_next_client.patch

xorg-server (2:1.10.4-1) unstable; urgency=low

  [ Timo Aaltonen ]
  * New upstream release.

xorg-server (2:1.10.3-1) unstable; urgency=medium

  [ Cyril Brulebois ]
  * New upstream release (with just a version bump).
  * Remove the Replaces: xdmx from xdmx-tools, that was before lenny.
  * Add a Breaks: libgl1-mesa-dri-no-multiarch, to handle upgrades from
    squeeze-backports (without multiarch) to wheezy (with multiarch).
  * Set urgency to “medium” to speed things up. Migration to testing is
    a prerequisite for squeeze backports.

  [ Julien Cristau ]
  * Merge packaging changes lost from the 1.7 (squeeze) branch:
    + Add Breaks on drivers abandoned between lenny and squeeze. This helps
      apt decide to remove them instead of removing all of X. Thanks, David
      Kalnischkies!
    + Set default xkb rules to evdev on linux, to work around a wrong default in
      configure.ac and an Xorg issue where it reverts to the default on reset.
      Thanks to Bastian Blank for the report.
 -- Timo Aaltonen <email address hidden> Fri, 09 Sep 2011 14:13:07 +0300

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.