xf86PostMotionEvent resets cursor to upper left

Bug #806256 reported by mitchcyber on 2011-07-06
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Chase Douglas
Natty
Undecided
Unassigned

Bug Description

When a wacom tablet is used in X, pressing a button on the tablet causes the mouse cursor to be warped to the top left of the screen.

Regression potential: Moderate. The patch is small (and by our resident input hacker), but touches the a codepath that all Absolute pointer events go through. Regressions should be easy to spot, however.

Original report follows:
occurs when pressing buttons on a wacom tablet. I am told this only occurs on ubuntu so it is not a problem with the wacom package

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-input-all 1:7.6+4ubuntu3.1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDmesg:
 [ 26.610051] eth1: no IPv6 routers present
 [ 32.106956] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro,commit=0
 [ 66.210094] CE: hpet increased min_delta_ns to 20113 nsec
Date: Tue Jul 5 19:44:05 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 0c) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:022f]
   Subsystem: Dell Device [1028:022f]
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
MachineType: Dell Inc. Inspiron 1525
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=30027e9a-aaf3-435a-ba2f-0a7f2a63f1ab ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/16/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A16
dmi.board.name: 0U990C
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA16:bd10/16/2008:svnDellInc.:pnInspiron1525:pvr:rvnDellInc.:rn0U990C:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Inspiron 1525
dmi.sys.vendor: Dell Inc.
version.compiz: compiz N/A
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

mitchcyber (aboutblank77) wrote :
Bryce Harrington (bryce) wrote :

Who told you it occurs only on ubuntu?

affects: xorg (Ubuntu) → xf86-input-wacom (Ubuntu)
Changed in xf86-input-wacom (Ubuntu):
status: New → Incomplete
mitchcyber (aboutblank77) wrote :

http://sourceforge.net/mailarchive/message.php?msg_id=27604784

"looking at the code, first_valuator is always 3 when sending pad event
(wcmCommon.c:748). If the server resets the pointer, that indicates a bug in
the server. However, it doesn't happen to me on 1.10.2 and I can't find any
patches that would have fixed this bug since 1.10.1. I wonder if that's a
Ubuntu-specific X server bug?

The driver code is correct though."

and also

"As another data point, I cannot confirm the jump under Arch Linux
after having downgraded xorg-server to 1.10.1. It's looking more like
an Ubuntu-specific bug."

bugbot (bugbot) on 2011-07-06
tags: added: xubuntu
Timo Aaltonen (tjaalton) wrote :

Confirmed here with Intuos 4L. I can try bisecting our xserver patches to see which one causes it.

affects: xf86-input-wacom (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Incomplete → Confirmed
importance: Undecided → High
Timo Aaltonen (tjaalton) wrote :

note that my oneiric desktop has the cursor on the upper left corner when the xserver starts (with just the mouse attached), possibly related to this.

Timo Aaltonen (tjaalton) wrote :

Bisected the ubuntu patches, and just disabling the multitouch patches (500->) made the cursor jumping stop, though the side-effect was that only the top left corner of the wacom tablet area was usable, but that's probably due to building against multitouch enabled libxi?

Moving over to Chase, maybe you can figure out the cause?

Changed in xorg-server (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → Chase Douglas (chasedouglas)
status: Confirmed → Triaged
Chase Douglas (chasedouglas) wrote :

Please test the xserver-xorg-core package for oneiric in ppa:utouch-team/unstable. I just pushed it, so it will need a bit to build and publish. The version is: 1.10.2.902-1ubuntu2~utouch1.

Thanks!

Changed in xorg-server (Ubuntu):
status: Triaged → In Progress
Timo Aaltonen (tjaalton) wrote :

I can confirm that the xserver version from the ppa works!

Chase Douglas (chasedouglas) wrote :

I've pushed the patch to the packaging branch. It will be released in the next xorg-server upload.

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.10.2.902-1ubuntu2

---------------
xorg-server (2:1.10.2.902-1ubuntu2) oneiric; urgency=low

  [ Bryce Harrington ]
  * rules: patch needs to depend on stampdir, else it doesn't get created,
    and 'debian/rules patch' malfunctions.

  [ Chase Douglas ]
  * Fix event handling when neither X nor Y coordinates are set (LP: #806256)
    - Added 504_fix_no_coords.patch

  [ Christopher James Halse Rogers ]
  * rules: Add both /usr/lib/xorg/extra-modules and
    /usr/lib/$MULTIARCH/xorg/extra-modules for extra modules.
    Fixes GLX for the proprietary drivers after a mesa upgrade (LP: #807209)
 -- Christopher James Halse Rogers <email address hidden> Fri, 08 Jul 2011 13:16:59 +1000

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released

Confirming working fix for released xorg-server 2:1.10.2.902-1ubuntu3 on Intuos4L.

Will this be fixed for 11.04 too?

SteveZalek (zaleksf) wrote :

Same issue here...

I have a Wacom Bamboo Craft Pen & Touch running on Natty 11.04_x64 , xorg-server 2:1.10.1-1ubuntu1.1 with the default setup and all current Natty updates.

Pressing any of the four pad buttons causes the cursor to jump to the upper left corner of the screen.

Hope this helps. I'm also interested in seeing this fix backported to Natty/11.04.

Keep up the good work!

description: updated
Angel Atondo (angel-sheehan80) wrote :

For some reason in linux mint 11 katya i dont have that problem, only in both ubuntu and kubuntu 11.04 why? :(

Changed in xorg-server (Ubuntu Natty):
status: New → Confirmed
Angel Atondo (angel-sheehan80) wrote :

Just added the ppa:utouch-team/unstable and upgrading to the 2:1.10.2-1ubuntu1.2~utouch1 version the problem with my wacom intuos 4 medium is gone !

Angel Atondo (angel-sheehan80) wrote :

Ohh and i did the upgrade in Ubuntu 11.04 Natty, i forgot to mention the distro :)

Hello mitchcyber, or anyone else affected,

Accepted xorg-server into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xorg-server (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Syhra (syhra) wrote :

I spent multiple hours the last 2 days trying to figure out what setting I was missing to get these stupid buttons to work. Then I found this bug report. Successful for me with CTH661 and Ubuntu Natty. Initially I thought it had messed up my pressure control in Gimp, but then I found I had it disabled there for some reason. All is functional and good. Thanks for the good work.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.10.1-1ubuntu1.2

---------------
xorg-server (2:1.10.1-1ubuntu1.2) natty-proposed; urgency=low

  * debian/patchs/504_fix_no_coords.patch:
    - Fix event handling when neither X nor Y coordinates are set (LP: #806256)
 -- Christopher James Halse Rogers <email address hidden> Tue, 26 Jul 2011 17:07:41 +1000

Changed in xorg-server (Ubuntu Natty):
status: Fix Committed → Fix Released

Same problem here with oneiric.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers