Ubuntu

Odd Pointer Behavior After Recent Xserver SRU in Natty

Reported by dart on 2011-06-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Critical
Chris Halse Rogers
Natty
Critical
Unassigned
Oneiric
Critical
Chris Halse Rogers

Bug Description

Xerver SRU for natty (xorg-server -2:1.10.1-1ubuntu1.1) created some problems leading erratic pointer behavior, drop in accuracy etc. Downgrading to stock xorg-xserver-core solves the problem.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-core 2:1.10.1-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
NonfreeKernelModules: wl fglrx
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,obs,move,mousepoll,wall,vpswitch,snap,resize,imgpng,place,grid,commands,regex,unitymtgrabhandles,session,animation,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
Date: Thu Jun 2 03:50:19 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic-pae, i686: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic, i686: installed
 fglrx, 8.840, 2.6.38-8-generic-pae, i686: installed
 fglrx, 8.840, 2.6.38-8-generic, i686: installed
GraphicsCard:
 ATI Technologies Inc M96 [Mobility Radeon HD 4650] [1002:9480] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0447]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
JockeyStatus:
 kmod:wl - Broadcom STA wireless driver (Proprietary, Enabled, In use) [auto-install]
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: Dell Inc. Inspiron N5010
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 LANG=en_IN
 LC_MESSAGES=en_IN.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic-pae root=UUID=37837b5d-0c42-4bb9-b077-a89bb668a4c8 ro quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic-pae root=UUID=37837b5d-0c42-4bb9-b077-a89bb668a4c8 ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg-server
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/19/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0FCVWR
dmi.board.vendor: Dell Inc.
dmi.board.version: A09
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A09
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd10/19/2010:svnDellInc.:pnInspironN5010:pvrA09:rvnDellInc.:rn0FCVWR:rvrA09:cvnDellInc.:ct8:cvrA09:
dmi.product.name: Inspiron N5010
dmi.product.version: A09
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.fglrx-installer: fglrx-installer N/A
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

dart (dart-v85) wrote :
dart (dart-v85) wrote :
summary: - Odd Pinter Behavior After Recent Xerver SRU in Natty
+ Odd Pinter Behavior After Recent Xserver SRU in Natty
summary: - Odd Pinter Behavior After Recent Xserver SRU in Natty
+ Odd Pointer Behavior After Recent Xserver SRU in Natty
Changed in xorg-server (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Chase Douglas (chasedouglas)
dart (dart-v85) wrote :
Chase Douglas (chasedouglas) wrote :

dart,

I tried playing back the recording, but it did not appear to have any issues. Can you upgrade back to the latest xorg-server-core package and follow the steps at the end of https://wiki.ubuntu.com/Multitouch/Testing/uTouchEvEmu#Debugging to play back the recording on your computer?

If you see the issue with your recording, then there's some difference between our two machines. If you don't see the issue with your recording, then that may mean you are sometimes getting the right data from the device, and sometimes you aren't (batteries dying if it's a wireless mouse?).

Thanks!

Changed in xorg-server (Ubuntu Oneiric):
status: New → Incomplete
Changed in xorg-server (Ubuntu Oneiric):
assignee: Chase Douglas (chasedouglas) → Chris Halse Rogers (raof)
Changed in xorg-server (Ubuntu Natty):
importance: Undecided → Critical
milestone: none → natty-updates
dart (dart-v85) wrote :

Chase,

I followed your instructions. I still get the odd pointer behavior. This is kind of hard for me to explain. With the playback I did not notice any issue. But with the latest updated xorg, the pointer movement always *feels* odd. By feeling I mean that I cannot notice it by just looking at pointer movement on the screen but it always feels erratic and less accurate. Sorry for being ambiguous.

Also, it seems this odd behavior is not noticeable in a fresh session but only starts after a few minutes' uptime. I tested this behavior with two different optical mouse and still the same behavior.

Can this affect gaming? I play Urban Terror on my system and it is most noticeable there. Moving the player around with mouse in the game feels more erratic than working on the desktop with files etc.

All these issues on my system go away as soon as I downgrade to stock xorg version. The odd feeling + mouse movement in the game and on the desktop, everything comes back to normal.

Sorry I am not able to provide any accurate info.

Chris Halse Rogers (raof) wrote :

Thank you for that. I've looked at the patch in question (503_fix_masked_transformed_valuators), and it looks plausible that there's a change in behaviour, although I don't see why it would only manifest after a few minutes' uptime.

It appears that we should revert that patch pending further investigation.

Changed in xorg-server (Ubuntu Natty):
status: New → Confirmed
Chris Halse Rogers (raof) wrote :

Could you please check if the Xserver package in https://edge.launchpad.net/~raof/+archive/aubergine fixes the mouse behaviour for you? I've reverted the patch most likely to be the problem in that package.

Having looked at it further, though, I don't see how you can actually be hitting the codepath changed in the patch.

dart (dart-v85) wrote :

Chris,

I installed xorg from your PPA. The first time I tested, I did not notice any difference in PPA version and SRU version. But then another time, when using natty-updates, the mouse sensitivity increased greatly. So I installed PPA version and the sensitivity came back to normal.

This is really really confusing and random. Now I am totally lost between these three versions of xorg trying them again and again. Is there a way to measure mouse sensitivity and other input info from command line or some other tool? I used 'xinput get-feedbacks' command to get some info but it shows same output in all three versions of xorg. Sorry for being a pain.

Chase Douglas (chasedouglas) wrote :

dart,

You wrote:

"I installed xorg from your PPA. The first time I tested, I did not notice any difference in PPA version and SRU version."

Does this mean that you saw the bug in the PPA version as well, or that at the time you did *not* see the bug in either the PPA or the SRU versions?

Thanks!

dart (dart-v85) wrote :

Chase,

This --> or that at the time you did *not* see the bug in either the PPA or the SRU versions?

I tried once again. From the stock xorg version, I upgraded to Xorg SRU. The sensitivity increased. Then I installed PPA version, sensitivity came back to normal. Why this has not happened the very first time and why this has happened this time and earlier, I have no clue. Its seems to be random. Not sure how can I help. Can't we record exact mouse sensitivity in numbers? Also, I have gone crazy in observing pointer behavior again and again in different xorg versions. Right now I use the stock xorg version without any problems.

Also, I tried different things like changing usb ports, disabling touchpad completely when using usb mouse, different optical mouse and even changing the mouse pad to see if there is some other problem in hardware side, but the sensitivity problem creeps in. Wish I could help more : (

Chris Halse Rogers (raof) wrote :

I'm now a bit confused as to what the actual problem you're seeing is. Is it:
*) Erratic mouse behaviour:
 +) pointer moving when not moving the mouse?
 +) pointer moving in an incorrect direction when moving the mouse?
 +) pointer not moving at a constant rate when moving the mouse at a constant speed?
 +) Something else?
*) Altered mouse sensitivity:
 +) Higher sensitivity - pointer moves in the direction expected, but moves further than expected
 +) Altered acceleration behaviour - pointer takes longer/shorter to get to “full speed” when moving the mouse?

Are there any other changes when switching between the xserver-xorg-core versions? Do you have two monitors connected?

In any case, as far as I can tell the codepath the patch changes will only be hit by a driver sending an absolute pointer event, which as far as I can tell none of your devices (and certainly not your mouse) will do. So I remain a bit perplexed!

dart (dart-v85) wrote :

Sorry for creating this confusion as I was unable to describe the issue properly. I should have been to the point. This is what I have been experiencing:

*) Altered mouse sensitivity:
 +) Altered acceleration behaviour - pointer takes *longer/shorter* to get to “full speed” when moving the mouse (This is the exact thing which is happening.)

No there are not any other changes and no multi monitors setup. I have recorded the device.prop and device.record files yesterday when I suddenly started facing the problem. I will upload them here. As much as I want to know what is the problem, I hate wasting time and efforts of developers. If this problem is not reproduced or cannot be further investigated, please go ahead and maybe we can see later if some other users experience the same problems or similar bugs are reported. Also if some further testing is required I will do it.

dart (dart-v85) wrote :
Chase Douglas (chasedouglas) wrote :

Ahhh! Thanks Chris and dart for clearly stating that it's the acceleration that's wrong. This code path may interfere with the acceleration, but I would guess that if anything this patch would restore acceleration to what it should be.

dart, does the new xorg-server feel "wrong", or just "different" than the previous version? Would increasing/decreasing the acceleration in the mouse preferences resolve the issue?

dart (dart-v85) wrote :

No nothing wrong...Its just different as the pointer have this acceleration issue. I tried reducing the acceleration.

By default the xinput feedback for the mouse is:

accelNum is 2
accelDenom is 1
threshold is 4

I reduced acceleration, now the output is:

accelNum is 1
accelDenom is 1
threshold is 4

Reducing acceleration by just one point helped as pointer behavior is now better. But when I increase it back to 2-1-4, it again starts to feel same as before. Also, I don't know if 1-1-4 feels better just because I reduced the acceleration or the problem is really solved. Its really hard to closely observe the pointer for any change in behavior as it just feels if something is wrong or not. But yes, 1-1-4 feels alot better than 2-1-4 anytime on xorg from SRU.

Chase Douglas (chasedouglas) wrote :

Ok, based on this latest information I'm going to mark this bug as "invalid" because the patch added as part of the SRU should be making things more correct, and the difference appears to be handled appropriately by modifying the acceleration scheme parameters.

I will also note that the acceleration and sensitivity is greatly affected by the precision of the mouse, and that the X input handling is not automatically scaled to take this into account. For example, the default acceleration and sensitivity is too high on a high precision mouse like the Apple Magic Mouse, while it is perfectly reasonable for other mice.

Please feel free to reopen the bug report if you believe this is not the appropriate outcome.

Thanks all!

Changed in xorg-server (Ubuntu Oneiric):
status: Incomplete → Invalid
Changed in xorg-server (Ubuntu Natty):
status: Confirmed → Invalid
To post a comment you must log in.