switching to current logged in user freezes gdm

Bug #78470 reported by chantra on 2007-01-08
62
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gdm
Unknown
Medium
gdm (Baltix)
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gdm

on feisty with gdm 2.17.4-0ubuntu1 gdm freezes when user X is already logged, user X switch user and log in as user X again.
The freezes appears when gdm pop up the usual (you are already logged in as X, to you want to continue)

How to reproduce:
1. login as user X
2. system->Quit->Switch user
3. login in as user X again
4. a pop up start to appear and gdm freezes using 100% CPU

attach, a tar.gz of gdm strace while locking up. Summary from strace:
sort gdm-strace.txt | uniq -c
  28523 ioctl(3, FIONREAD, [0]) = 0
    111 poll([{fd=3, events=POLLIN}], 1, 0) = 0
  28522 poll([{fd=3, events=POLLIN}, {fd=3, events=POLLIN|POLLPRI}, {fd=7, events=POLLIN|POLLPRI, revents=POLLNVAL}], 3, 0) = 1

chantra (chantra) wrote :
iKs (iks279) wrote :

I can confirm this bug.

In fact nothing freezes and hitting "Enter" can make things come back to normal (except you cant go back to your session, I suppose you can log in as a different user..).
In fact the window that appear doesnt have anything written on it (but moving the mouse we can see sort of a field).

Changed in gdm:
status: Unconfirmed → Confirmed
chantra (chantra) wrote :

yep, pressing enter log you in.
tab-enter will bring you back to your previous session

but still, gdm takes100% CPU :s

Sebastien Bacher (seb128) wrote :

That is known upstream, they wrote a note about it:

"- Now all GDM GUI's are run as the gdm user. This change ensures
  that all GDM GUI's can talk to the at-spi-registryd that is
  running. This change involved making the forked slave talk
  to the the GDM daemon so that the dialogs can be displayed.
  The response from the dialog can be returned to the slave.
  There are reports that this bug triggers GDK bug #376315 on
  Linux when a11y is turned off. This will need to be fixed
  before the next GDM stable release. Workaround is to turn
  on a11y until this bug is fixed. (Leena Gunda and Srirama
  Sharma)"

Changed in gdm:
assignee: nobody → desktop-bugs
importance: Undecided → High
Changed in gdm:
status: Unknown → Unconfirmed
Andrew Conkling (andrewski) wrote :

Does anyone have desktop effects installed? I just noticed this behavior, but disabling desktop effects on the first logged-in user made the difference. (They were always disabled on the second user.)

theLawman (billieboy) wrote :

I have experienced this bug too. I have disabled desktop effects but I still have the problem. I did not have this problem on Edgy.

chantra (chantra) wrote :

From what I remember, I did not have desktop-effects enabled.
I won't have internet at home before a while so I won't be able to test out if updates changed the behaviour.

Mark (twistedtexan) wrote :

The same thing happens when coming out of screen saver. Select switch user, from "user two" to "user one" and the deep freeze. Black screen with mouse pointer.

Andrew Conkling (andrewski) wrote :

Bug #95926 is about desktop effects. Looks like a compiz problem. Anyone else here running compiz/beryl?

chantra (chantra) wrote :

I can confirm that WITHOUT compiz nor beryl, it now works perfect (if login as same user, I am automatically redirected to the previous session, older behaviour warnd be that a session was already running, but I could open a new one if I confirmed).

Running compiz, it crashes.

Sebastien Bacher (seb128) wrote :

what videocard and driver do you use?

chantra (chantra) wrote :

using nvidia GeForce Go 7300:
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 110M / GeForce Go 7300 (rev a1)
and nvidia driver from the repository

tactus (tactusetc) wrote :

Can confirm system freezes on switching from user a to user b and then logging out user b. It doesn't happen all the time thought, but system doesn't respond on keyboard or mouse so I am forced to do a hard reboot. I am not running Compiz/Beryl.

$ lspci | grep Display
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller (rev 03)

$ uname -a
Linux dellbox 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

(X)ubuntu 7.04 final

dennis1200 (dennis-fiser) wrote :

I have a similar problem, running Feisty. I don't run compiz/beryl, don't have ATI or NVIDIA. I have:
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

I have two user accounts on this computer. When logging out of the other one, the system freezes (background visible), 100% CPU, and I need the power button to shut off. This seems to be a fairly serious issue. Anything I can do to help? Debug info? Just tell me how.

Mobaladje (emo-dav) wrote :

I have the same bug on my Acer 2003 WLMI with the 7.04 Ubuntu. I am enable to switch between 2 users.
Very very very annoying bug.

Freecron (freecron) wrote :

I installed xubuntu 7.04 a couple of days ago and I've developed the same problem as Tactus, dennis1200 and Mobaladje: system freezes on switching from user a to user b and then logging out user b . It worked fine initially but the problem seems to have occured the last couple of times.

$ lspci | grep Display
01:00.1 Display controller: ATI Technologies Inc RV350 AR [Radeon 9600] (Secondary)

$ uname -a
Linux Main-PC 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

Changed in gdm:
status: Confirmed → Triaged
Giles Weaver (gweaver) wrote :

I can confirm the same bug, whether running with or without Compiz.

unggnu (unggnu) wrote :

I seems that this bug has been fixed in Gutsy.

Pedro Villavicencio (pedro) wrote :

May someone else try to confirm that the bug is fixed in Gutsy? chantra does it works for you with Gutsy? You can grab a CD Image from here: http://www.ubuntu.com/testing/ thanks.

Jon-o Addleman (jaddle) wrote :

I'm using gutsy and it doesn't appear fixed to me... Though this might be a slightly different problem:

Log in as A, just like normal.
Switch user, log in as B
Log out B.

It should then go back to the A login, asking for the password, but instead the machine locks up hard, with no cursor visible. The screen is mostly black, but with white stippled squares, about half of which are blinking. Looks like some video corruption in a text mode. I have to power-off to get it to do anything.

This is on a thinkpad x60s, with the intel xorg driver. No desktop effects (they stopped working entirely a while ago... not sure why - I just get "desktop effects could not be enabled" when I try to turn them on, and a "No GLXFBConfig..." error in xsession-errors)

unggnu (unggnu) wrote :

@Jon-o Addlerman
This has nothing to do with gdm, it is a known new Intel driver bug #127101.

Alexi Helligar (alexih) wrote :

I can confirm that this occurs in Gutsy.

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)

$ uname -r
Linux <computername> 2.6.22-13-generic #1 SMP Thu Oct 4 17:18:44 GMT 2007 i686 GNU/Linux

I have noticed it with Desktop Effects turned off and more regularly with Desktop Effects turned on.

Alexi Helligar (alexih) wrote :

In addition to the previous, it looks like a problem with X and Fast User Switching since the screen will go black but the system still responds to keystrokes. Pressing Ctrl+Alt+Backspace will end the session, and GDM sound effects can be heard. Quickly pressing the Power button on the PC will cleanly shutdown the PC showing text mode. Occasionally, it has been possible to get back to a login screen by pressing Ctrl+Alt+Backspace repeatedly.

Yann Rouillard (yann-pleiades) wrote :

I am able to reproduce a similar bug on gutsy:

1. System->Quit->Switch User
2. I relogin as myself
3. System->Quit->Switch User
Then black screen and I can't do anything more.

If I log on this computer from another one through ssh. I can see that gdm is stuck waiting for the new X process.
I straced the whole process and X freezes soon after ioctl on /dev/nvidia0 and /dev/nvidiactl, I can't even kill it.

I switched from proprietary nvidia driver to the opensource nv driver and the bug disappeared so I think this bug is driver-related.

I was unable to reproduce it on another computer using the X savage driver.

exactt (giesbert) wrote :

here on latest gutsy. when fast user switching to user B and then back to A the screen goes white. i can't do anything else then shutting down the computer via on/off button. using nvidia graphics with restricted drivers and desktop effects enabled...

Timo (timohirt) wrote :

I can confirm this bug. I am using gutsy, nvidia graphics with restricted drivers and compiz enabled.

Steps to reproduce:

1. Login as user A
2. System->Quit->Switch User
3. Login as user B
4. System->Quit->Switch User
5. Relogin an user A

The screen goes white and get inresponsive. I click System->Quit->Switch User what takes about 2 minutes and relogin as user A and I can work as expected without the white screen but 3d effects.

ananth1984 (lambu-ananth) wrote :

I confirm this bug too, i get the white screen of death when i logout from a second account while leaving the first one logged out. I can login back to the first account by blindly typing the password of the account.

People here have suggested pressing Ctrl+Alt+Backspace to restart the GUI Shell, but the alternative i suggest is pressing ALT+S at the white screen which will reload only the Login screen and thus you will not lose any work from the account which is locked.

Cheers!

Giles Weaver (gweaver) wrote :

I have the switch user white screen problem as described by exactt as well, but I wouldn't call it the white screen of death.
I recently discovered that if I type in the correct password and hit return I am logged back in to user A's session, so the problem is just that the screensaver login box (and black background) aren't being drawn.

I guess that people are seeing either white screens or black screens dependant on their video hardware, but the bug is quite possibly the same. I had this problem in 7.04 as well. I think, but I can't be certain that both 7.04 and 7.10 developed this problem some time after installation, possibly after I fiddled with some graphics settings.

Matt 6:27 (goffice) wrote :

I can confirm Giles Weaver's note above - by typing correct password after receiving the "white screen of death", I am logged back into user A session.

Giles Weaver (gweaver) wrote :

This bug still occurs under Ubuntu 8.04:(

Id2ndR (id2ndr) wrote :

For those who have the white screen bug, look at #160264

I am seeing this as well in Jaunty. Remember guys about the "affects me" status at the top :)

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: gdm 2.20.10-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Changed in gdm:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

could somebody try if that's still an issue with the gdm rewrite in karmic?

Changed in gdm (Ubuntu):
status: Triaged → Incomplete
Pedro Villavicencio (pedro) wrote :

any news about this? did you tried with karmic?

DougL (dlarue) wrote :

still get it with the Kubuntu Karmic RC1( ati 200M laptop ) after an kubuntu 9.04 upgrade but also from a liveCD. There's no xorg.conf by default and it does it so I created a simple one and still get it with both "ati" and "radeon" xorg drivers. But, it does not happen I used "vesa"

I've also tried a bunch of individual things like vga=791 in grub boot, and each of the items in the following xorg.conf file individually and as a group. FYI, turning off AIGLX reduced idling CPU usage from about 40% down to the single digits.

Section "Device"
 Identifier "Configured Video Device"
 #Driver "radeon"
 #Driver "vesa"
 Driver "ati"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

Section "Extensions"
 Option "Composite" "0" # disable
EndSection

Section "Module"
 Load "glx"
EndSection

Section "ServerFlags"
 Option "AIGLX" "off"
 Option "blank time" "0"
EndSection

Section "DRI"
 Mode 0666
EndSection

Sebastien Bacher (seb128) wrote :

it's an xorg issue since it happens only with some video drivers

affects: gdm (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Hi chantra,

Thanks for including the attached files. Could you also include your /var/log/Xorg.0.log (or Xorg.0.log.old) from after reproducing the issue?

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in xorg-server (Ubuntu):
status: New → Incomplete

Bryce, I think you got the wrong person here. No /Chantra/ at this address.

Bryce Harrington wrote:
> Hi chantra,
>
>
> Thanks for including the attached files. Could you also include your /var/log/Xorg.0.log (or Xorg.0.log.old) from after reproducing the issue?
>
> [This is an automated message. Apologies if it has reached you
> inappropriately; please just reply to this message indicating so.]
>
>
> ** Tags added: needs-xorglog
>
> ** Changed in: xorg-server (Ubuntu)
> Status: New => Incomplete
>
>

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 78470

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report.

Also gdm in Baltix marked Invalid as per comment from GNOME bug team about this not being a gdm issue.

Changed in gdm (Baltix):
status: New → Incomplete
sergio (opuesto) on 2010-01-12
Changed in gdm (Baltix):
status: Incomplete → Confirmed
Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed

sergio, please refrain from changing the bug status from Incomplete. The requested information has not been obtained and may have changed between Ubuntu versions. Until we get this, it needs to stay Incomplete. You can provide it yourself in Karmic if you are having this problem by following the instructions in my last post. Thank you

Changed in gdm (Baltix):
status: Confirmed → Incomplete
Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
sergio (opuesto) on 2010-01-14
Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed
Changed in gdm (Baltix):
status: Incomplete → Fix Committed
Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Committed

sergio, Are you a developer or MOTU? If not, I would really suggest that you do not change status at all, as you obviously don't know what you're doing. Fix Committed is for updates that are FIXED but awaiting upload to the main Ubuntu repos. This will be returned to Incomplete and the Launchpad team will be notified of your misuse of the Launchpad tracker. Thank you.

Changed in gdm (Baltix):
status: Fix Committed → Incomplete
Changed in xorg-server (Ubuntu):
status: Fix Committed → Incomplete

This bug report is being closed as the required information has not been obtained, as described in the previous comments. If this information can be provided, please do so and reopen this bug report. Thank you.

Changed in xorg-server (Ubuntu):
importance: High → Undecided
status: Incomplete → Invalid
Changed in gdm (Baltix):
status: Incomplete → Invalid
Changed in gdm:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.