everything on screen is garbled apart from the top bar (2 monitors, different resolutions, unity, natty)

Bug #776978 reported by Sabin Iacob on 2011-05-04
78
This bug affects 13 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Unassigned

Bug Description

I'm not the original author of the question, but I've got the exact same problem (Acer Aspire One, 1280x720 + 1440x900 external); this is the main thing that keeps me on Lucid (it's the gf's laptop I am experimenting with)

Hello,

I'm working with a portable computer, with another screen attached to the vga port. I work with both screens.

I updated Ubuntu desktop from 10.10 to 11.04. After the update, both screens were corrupted, excepted the upper bar. When I've disconnected the external monitor and rebooted, everything worked file. Each time I tried to reconnect the external monitor, both screens were unreadable, excepted (sometimes) the upper bar and the new launchbar at the left of the screen.

If i "shake" the mouse on the screen, some fields are redrawn and become visible.

I've then installed 11.04 from scratch (reformat and reinstall). The problem is the same.

The screen on the portable computer is 1400x1050, and the external screen is 1680(?) x 1050

[Just for completeness, my home directory is on another partition. So if something about displays were written to that directory by ubuntu 10.10 (and is now incompatible with 11.04), I don't know were it is, and don't know how to remove it.

Sabin Iacob (iacobs) wrote :

information that was requested on the question (several others are available at https://answers.launchpad.net/ubuntu/+source/xorg/+question/154729):

  *-display:0
       description: VGA compatible controller
       product: Mobile 945GME Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:16 memory:58280000-582fffff ioport:60f0(size=8) memory:40000000-4fffffff memory:58300000-5833ffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:58200000-5827ffff
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"

bugbot (bugbot) on 2011-05-04
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Marc Tommasi (marc-tommasi) wrote :

Same problem on a DELL E4200.
I was also unable to switch on an external display of 1920x1200 (and switch off laptop screeen). I finally succeed in removing monitors.xml in .config, and restart xorg. I suspect the bug is more related to compiz than xorg.
(I've also try to add an output of correct resolution in the general setting of compiz, tab display settings, ... not sure whether this has changed something)

PCI (sysfs)
  *-display:0
       description: VGA compatible controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:45 memory:f6c00000-f6ffffff memory:e0000000-efffffff ioport:ef98(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f6b00000-f6bfffff
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"

mxjensen (mxjensen) wrote :

Same problem after installing 11.04 on Lenovo U160. As soon as i plug in the HDMI cable (or VGA) everything goes black. Mouse pointer visible on external display, and sometimes also the top bar. Nothing is clickable though...

aproposnix (rimez) wrote :

Same here on the an Acer Aspire TimelineX 3820tg (ATI Radeon HD 5650 *switchable*). I may have te revert back to 10.10 where it worked fine.

mxjensen (mxjensen) wrote :

In case it has some significance. When booting with the external monitor connected via HDMI I can get the login screen to show on the external monitor, though the resolution is very low. After login, the monitor turns black showing only the mouse pointer (the resolution seems right after login judging by the look of the mouse pointer).
In some cases, the login screen doesn't show, but the background shows up and is covered with the correct wallpaper in what seems to be the correct resolution. This however, is not very amusing, when the ability to log in is missing.

aproposnix (rimez) wrote :

Just an observation... In my dual boot environment (Windows7 and Ubuntu) the longer I stay in Ubuntu without switching Windows the worse and more frequent my video issues happen. Once I log into windows, even if just for a minute, when I boot back into Ubuntu, I am then able to add a monitor without problem. It also seems to help with the other issues I have such as crashing on sleep mode.

rogmorri (frontporsche) wrote :

Similar problem here. Acer Timelinex laptop, 4820T ZQ1B with Intel HD graphics.

If I boot without the second monitor plugged in, then after logging in plug in the monitor, it works. (albeit without any advanced graphics support).

[~]
[~] sudo lshw -C display
[sudo] password:
  *-display
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 18
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:42 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:3050(size=8)
[~]
[~] cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
[~]
[~] dmesg | grep -i aspire
[ 0.000000] DMI: Acer Aspire 4820T/ZQ1B, BIOS V1.17 07/05/2010
[~]

Marc Tommasi (marc-tommasi) wrote :

Just a comment.
When I plug an external display and the screen has some black parts or is totally black, I switch to the console and kill the compiz process. Then the screen is refreshed and I can continue to work...

Marc

_aseith (x-root) wrote :

To all who upgraded to Natty and experiencing a blank screen with an external display: Go to one of the Console sessions (e.g. ctrl+alt+f1), then rename the ~/.config/monitors.xml file. This resets the Gnome's Monitor settings and should give you a working Unity / Gnome Deskop on both displays. You can then try to configure you Monitor settings again.

However, the thing I'm experiencing here is, that when I try to disable the notebook display to work on the external display (via VGA) only, the notebook display goes off and the external display goes blank. And that's it. I have to restart X to get back to GDM.

Running on an Acer Aspire TimelineX 4820TG, using Intel graphics only (ATI disabled via switcheroo).

Regards

Alex

mxjensen (mxjensen) wrote :

I have found a workaround that enables me to use the external display at work. It works if I plug it in after I log in to Ubuntu classic with no effects. If it is plugged in during startup, the screen on the laptop will be blank and only the wallpaper is shown on the external display. I can perform the login, but only because I know how to do it (the login dialog is not visible). After that the desktop is shown on the external monitor, but everything I try to open wil not show, because it starts on the laptop screen and I will have to rightclick it on the taskbar to be able to move it to the external display.
I have had no luck, when trying to use the workaround logging in to Unity.
Can anyone tell me, when this issue will be fixed?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2011-10-18
tags: added: natty
Bryce Harrington (bryce) wrote :

Hey iacobs,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete

This problem is gone for me in oneiric, so I will unsubscribe. On another note, I do have a problem when undocking with a locked screen, the unlock dialog do not appear... but that is not relevant here.

On 11/09/2011 05:04 AM, Bryce Harrington wrote:
> Hey iacobs,
>
>
> You filed this bug report against natty, but I see it's still open and
> doesn't appear to have much activity recently. So, now that oneiric
> is released and stable, this may be a good point for you to upgrade
> and re-test if this issue is still present there.

I did some testing, there is a band aid in oneiric but it's not "fixed":
display-properties won't let me set up the monitors the way I need them,
instead forcing me to put them on top of each other (highly awkward to
use if they are _next to each other_ on my desk)

> If it's solved in the new release and you think it's worth backporting
> the fix, please indicate that. Or if having the fix in the new release
> is good enough, feel free to close out the bug (or let us know and we'll
> close it.)
>
> If it's not solved, leave the bug report open. I can't promise we'll
> get to it (we get way more bugs filed than we can usually get to), but
> your testing and feedback can help out if and when we do.

I'm not sure what to do; there is a solution, but I feel it's inadequate
as it doesn't address the underlying problem, which is compiz using a
single texture for the whole desktop (tiling the desktop to fit the
video texture size or using a separated texture on each monitor are the
two most obvious solutions to someone like me, who doesn't know anything
about graphics programming)

Marc Tommasi (marc-tommasi) wrote :

After upgrading to oneiric, I experienced another problem. Everything works fine with an old flat monitor with res 1280x1024.
On a large monitor (1920x1200, IIyama) the screen is flickering/flashing. There was many messages in Xorg.0.log like that:
[ 24055.092] (WW) intel(0): Page flip failed: Device or resource busy
[ 24055.092] (WW) intel(0): flip queue failed: Device or resource busy

so I've disabled page flipping in /etc/X11/xorg.conf

Section "Device"
        Identifier "Configured Video Device"
        Option "TripleBuffer" "false"
EndSection

(following bug #850628)
Performance is a little bit affected but it works.
Marc.

Marc Tommasi (marc-tommasi) wrote :

Argh... My previous comment was *not true*. The problem is more intricate and the option TripleBuffer has no effect. Under certain combination of suspending to RAM and using a docking station, the external screen is flickering/flashing. Unfortunately, It is difficult to reproduce in a deterministic way.

Marc.

Bryce Harrington (bryce) on 2011-11-19
Changed in xorg-server (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
importance: Medium → High
Bryce Harrington (bryce) wrote :

@Sabin, ok thanks. I agree it's a band aid. We've got a tracking bug report for the proper fix, bug #830949: "[Intel N10 Graphics] Need Compiz' "Copy to Texture" plugin so can display on multi-head layouts bigger than the max GL texture size". I'll go ahead and close this one out as fixed, since the underlying issue is just a dupe of that one.

@Marc, it's starting to sound like your issue may be a distinct bug. Please open a new bug report if you don't mind. 'ubuntu-bug xorg'. It would be really helpful if you could do it by reproducing on Precise first and filing the bug from there. If you don't want to install Ubuntu Precise, it should be sufficient to boot a Live USB session, configure the monitors, and see if it is working properly now. You can get the current Live USB desktop image at http://cdimage.ubuntu.com/daily-live/current/ and create a USB boot drive using usb-creator.

Changed in xorg-server (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Related blueprints