Limited set of resolutions available in xrandr after switching external monitor

Bug #756675 reported by Jonathan Keeling on 2011-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Normally, after booting, when I connect to an external monitor (thinkvision L2250p wide), I can access the full range of resolutions. However, if I connect to another external monitor, or data projector, and then reconnect to the first monitor, the range of resolutions available is reduced.

I can manually add the resolution with:

xrandr --newmode "big" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
xrandr --addmode VGA1 big

Rebooting restores the full set of resolutions.
The output of xrandr, ddcprobe and get-edid|parse-edid are attached.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-30.59-generic 2.6.32.29+drm33.13
Uname: Linux 2.6.32-30-generic i686
Architecture: i386
Date: Sun Apr 10 17:33:07 2011
DkmsStatus:
 blcr, 0.8.2, 2.6.32-29-generic, i686: installed
 blcr, 0.8.2, 2.6.32-30-generic, i686: installed
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: LENOVO 2801CTO
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-30-generic root=UUID=a5aebcfb-c96a-4000-9792-ee07a9eab970 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 09/17/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6HET24WW (1.09 )
dmi.board.name: 2801CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6HET24WW(1.09):bd09/17/2009:svnLENOVO:pn2801CTO:pvrThinkPadT400s:rvnLENOVO:rn2801CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2801CTO
dmi.product.version: ThinkPad T400s
dmi.sys.vendor: LENOVO
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-30-generic

Jonathan Keeling (jmjk2) wrote :
Jonathan Keeling (jmjk2) wrote :
Jonathan Keeling (jmjk2) wrote :
bugbot (bugbot) on 2011-04-11
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi Jonathan,

Would you mind re-testing this against Oneiric? You can get a Live ISO image from cdimage.ubuntu.com that should be sufficient for testing against.

Changed in xorg-server (Ubuntu):
status: New → Incomplete

On Sat, 2011-11-19 at 00:42 +0000, Bryce Harrington wrote:
> Hi Jonathan,
>
> Would you mind re-testing this against Oneiric? You can get a Live ISO
> image from cdimage.ubuntu.com that should be sufficient for testing
> against.

With apologies for the delay, I have now tested this using the "Try
Ubuntu" option from the CD, and it appears to be fixed.

Best wishes,
Jonathan Keeling
--
Lecturer in Theoretical Condensed Matter Physics and EPSRC CAF
SUPA, School of Physics and Astronomy, University of St Andrews
http://www.st-andrews.ac.uk/~jmjk

Bryce Harrington (bryce) wrote :

Thanks for testing and confirming it as fixed.

Changed in xorg-server (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.