Xorg assert failure: *** glibc detected *** /usr/bin/X: corrupted double-linked list: 0x08da5930 ***

Bug #716251 reported by hcmeyer
394
This bug affects 32 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

logging into xfce desktop after logging out of unity desktop

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-core 2:1.9.99.901+git20110131.be3be758-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3
Uname: Linux 2.6.38-2-generic i686
Architecture: i386
AssertionMessage: *** glibc detected *** /usr/bin/X: corrupted double-linked list: 0x08da5930 ***
CrashCounter: 1
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64: AP///////wAiZOkDt2wAAAMUAQOAFg14CoyFl1tTjicYUFQAAAABAQEBAQEBAQEBAQEBAQEBLBUAMEFYUCBdI5UI3n0AAAAZAAAA/gAAAAAAAAAAAAAAAAAAAAAA/ABIU0QxMDFQRlcyCiAgAAAAEAAKICAgICAgICAgICAgAOE=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed Feb 9 23:45:56 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
ExecutablePath: /usr/bin/Xorg
GraphicsCard:
 Subsystem: QUANTA Computer Inc Device [152d:0834]
   Subsystem: QUANTA Computer Inc Device [152d:0834]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101204)
MachineType: Intel Intel powered classmate PC
ProcCmdline: /usr/bin/X :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-dsjSeE/database -nolisten tcp vt7
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic root=UUID=21509f82-b140-4652-a0af-4a216a82f9ac ro quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic root=UUID=21509f82-b140-4652-a0af-4a216a82f9ac ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: xorg-server
StacktraceTop:
 __kernel_vsyscall ()
 raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 abort () at abort.c:92
 __libc_message (do_abort=2, fmt=0xfce07c "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (action=<value optimized out>, str=<value optimized out>, ptr=0x8da5930) at malloc.c:6283
Title: Xorg assert failure: *** glibc detected *** /usr/bin/X: corrupted double-linked list: 0x08da5930 ***
UserGroups:

dmi.bios.date: 03/26/2010
dmi.bios.vendor: Phoenix
dmi.bios.version: SPPNV10A.86A.0026.2010.0326.0001
dmi.board.name: Intel powered classmate PC
dmi.board.vendor: QCI
dmi.board.version: SP PV
dmi.chassis.type: 10
dmi.chassis.vendor: Intel
dmi.chassis.version: SP PV
dmi.modalias: dmi:bvnPhoenix:bvrSPPNV10A.86A.0026.2010.0326.0001:bd03/26/2010:svnIntel:pnIntelpoweredclassmatePC:pvrSPPV:rvnQCI:rnIntelpoweredclassmatePC:rvrSPPV:cvnIntel:ct10:cvrSPPV:
dmi.product.name: Intel powered classmate PC
dmi.product.version: SP PV
dmi.sys.vendor: Intel
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu10
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2+git20110124.fadee040-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu4

Revision history for this message
hcmeyer (hcmeyer) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 __kernel_vsyscall ()
 *__GI_raise (sig=6)
 *__GI_abort () at abort.c:59

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Bryce Harrington (bryce)
visibility: private → public
Revision history for this message
Bryce Harrington (bryce) wrote :

Are you able to reproduce this bug every time or some time that you log out and in?

Changed in xorg-server (Ubuntu):
status: New → Incomplete
Revision history for this message
Mark Cariaga (mzc) wrote : Re: [Bug 716251] Re: Xorg assert failure: *** glibc detected *** /usr/bin/X: corrupted double-linked list: 0x08da5930 ***
Download full text (3.9 KiB)

I cannot replicate the bug. It's probably fixed with the recent changes.
On Feb 14, 2011 11:51 PM, "Bryce Harrington" <email address hidden>
wrote:
> Are you able to reproduce this bug every time or some time that you log
> out and in?
>
> ** Changed in: xorg-server (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (716436).
> https://bugs.launchpad.net/bugs/716251
>
> Title:
> Xorg assert failure: *** glibc detected *** /usr/bin/X: corrupted
> double-linked list: 0x08da5930 ***
>
> Status in “xorg-server” package in Ubuntu:
> Incomplete
>
> Bug description:
> logging into xfce desktop after logging out of unity desktop
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: xserver-xorg-core 2:1.9.99.901+git20110131.be3be758-0ubuntu3
> ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3
> Uname: Linux 2.6.38-2-generic i686
> Architecture: i386
> AssertionMessage: *** glibc detected *** /usr/bin/X: corrupted
double-linked list: 0x08da5930 ***
> CrashCounter: 1
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1024x600
> edid-base64:
AP///////wAiZOkDt2wAAAMUAQOAFg14CoyFl1tTjicYUFQAAAABAQEBAQEBAQEBAQEBAQEBLBUAMEFYUCBdI5UI3n0AAAAZAAAA/gAAAAAAAAAAAAAAAAAAAAAA/ABIU0QxMDFQRlcyCiAgAAAAEAAKICAgICAgICAgICAgAOE=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: Off
> modes:
> edid-base64:
> Date: Wed Feb 9 23:45:56 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> ExecutablePath: /usr/bin/Xorg
> GraphicsCard:
> Subsystem: QUANTA Computer Inc Device [152d:0834]
> Subsystem: QUANTA Computer Inc Device [152d:0834]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101204)
> MachineType: Intel Intel powered classmate PC
> ProcCmdline: /usr/bin/X :0 -nr -verbose -auth
/var/run/gdm/auth-for-gdm-dsjSeE/database -nolisten tcp vt7
> ProcEnviron:
> LANG=en_US.UTF-8
> PATH=(custom, no user)
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic
root=UUID=21509f82-b140-4652-a0af-4a216a82f9ac ro quiet splash vt.handoff=7
> ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic
root=UUID=21509f82-b140-4652-a0af-4a216a82f9ac ro quiet splash vt.handoff=7
> Signal: 6
> SourcePackage: xorg-server
> StacktraceTop:
> __kernel_vsyscall ()
> raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
> abort () at abort.c:92
> __libc_message (do_abort=2, fmt=0xfce07c "*** glibc detected *** %s: %s:
0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
> malloc_printerr (action=<value optimized out>, str=<value optimized out>,
ptr=0x8da5930) at malloc.c:6283
> Title: Xorg assert failure: *** glibc detected *** /usr/bin/X: corrupted
double-linked list: 0x08da5930 ***
> UserGroups:
>
> dmi.bios.date: 03/26/2010
> dmi.bios.vendor: Phoenix
> dmi.bios.version: SPPNV10A.86A.0026.2010.0326.0001
> dmi.board.name: Intel powered classmate PC
> dmi.board.vendor: QCI
> dmi.board.version: SP PV
> dmi.chassis.type: 10
> dmi.chassis.vendor: Intel
> dmi.chassis.version: SP PV
> dmi.modalias:
dmi:bvnPhoenix:bvrSPPNV10A.86A.0026.2010.0326.0001:bd03/26/2010:svnIntel:p...

Read more...

Revision history for this message
bolek (bolek-lolek) wrote :

Not always but very continuosly

El feb 15, 2011 1:51 a.m., "Bryce Harrington" <email address hidden>
escribió:

Are you able to reproduce this bug every time or some time that you log
out and in?

** Changed in: xorg-server (Ubuntu)
      Status: New => Incomplete

--
You received this bug notification because you are a direct subscriber
of a duplicate bug (7166...
 Incomplete

Bug description:
logging into xfce desktop after logging out of unity desktop

ProblemType: Cra...

Revision history for this message
bolek (bolek-lolek) wrote :

Ok i will try to reproduce and make some more information ty anyway, you
guys make great job :)

El feb 15, 2011 2:02 a.m., "erick sanchez" <email address hidden> escribió:

Not always but very continuosly

El feb 15, 2011 1:51 a.m., "Bryce Harrington" <email address hidden>
escribió:

>
> Are you able to reproduce this bug every time or some time that you log
> out and in?
>
> ** Ch...

>
>
> --
> You received this bug notification because you are a direct subscriber
of a duplicate bug (7166...
 Incomplete

>
>
> Bug description:
> logging into xfce desktop after logging out of unity desktop
>
ProblemType: Cra...

Revision history for this message
Oded Arbel (oded-geek) wrote :

I'm not sure if its the same problem, but while I can't reproduce my original problem (X unresponsive after resume), I now get the crash reported in bug #719310 every time I log out.

tags: added: bugpattern-needed
Revision history for this message
Bryce Harrington (bryce) wrote :

While the error message differs, this might be a dupe of or related to bug #711422

If you are able to reliably reproduce this crash, please install the following PPA and run it for a day or so:

https://edge.launchpad.net/~raof/+archive/aubergine

This PPA adds a reference check to avoid a similar invalid memory situation, and so might solve this bug as well. Please report back whether it fixes your issue or not.

If you have NOT been able to reliably reproduce the crash recently (within the last day or so), you don't need to install the PPA, and don't need to comment here.

Changed in xorg-server (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Revision history for this message
MoLE (moleonthehill) wrote :

I'm able to reliably reproduce this bug on my system. Do you still want testing with the PPA above? According to lp, there is a later version in the natty main repo published yesterday, which I am currently using.

Revision history for this message
mattviator (viamptor) wrote :
Download full text (4.2 KiB)

If the bugs abscent from the newer verion in the repos then we are all set. Why can't I see the newer version is it I need to add a diff repo?

-- Sent from my Palm Pre
On Feb 20, 2011 8:41 PM, MoLE &lt;<email address hidden>&gt; wrote:

I'm able to reliably reproduce this bug on my system. Do you still want

testing with the PPA above? According to lp, there is a later version

in the natty main repo published yesterday, which I am currently using.

--

You received this bug notification because you are a direct subscriber

of a duplicate bug (722402).

https://bugs.launchpad.net/bugs/716251

Title:

  Xorg assert failure: *** glibc detected *** /usr/bin/X: corrupted

  double-linked list: 0x08da5930 ***

Status in “xorg-server” package in Ubuntu:

  Incomplete

Bug description:

  logging into xfce desktop after logging out of unity desktop

  ProblemType: Crash

  DistroRelease: Ubuntu 11.04

  Package: xserver-xorg-core 2:1.9.99.901+git20110131.be3be758-0ubuntu3

  ProcVersionSignature: Ubuntu 2.6.38-2.29-generic 2.6.38-rc3

  Uname: Linux 2.6.38-2-generic i686

  Architecture: i386

  AssertionMessage: *** glibc detected *** /usr/bin/X: corrupted double-linked list: 0x08da5930 ***

  CrashCounter: 1

  DRM.card0.LVDS.1:

   status: connected

   enabled: enabled

   dpms: On

   modes: 1024x600

   edid-base64: AP///////wAiZOkDt2wAAAMUAQOAFg14CoyFl1tTjicYUFQAAAABAQEBAQEBAQEBAQEBAQEBLBUAMEFYUCBdI5UI3n0AAAAZAAAA/gAAAAAAAAAAAAAAAAAAAAAA/ABIU0QxMDFQRlcyCiAgAAAAEAAKICAgICAgICAgICAgAOE=

  DRM.card0.VGA.1:

   status: disconnected

   enabled: disabled

   dpms: Off

   modes:

   edid-base64:

  Date: Wed Feb 9 23:45:56 2011

  DistUpgraded: Fresh install

  DistroCodename: natty

  DistroVariant: ubuntu

  ExecutablePath: /usr/bin/Xorg

  GraphicsCard:

   Subsystem: QUANTA Computer Inc Device [152d:0834]

     Subsystem: QUANTA Computer Inc Device [152d:0834]

  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101204)

  MachineType: Intel Intel powered classmate PC

  ProcCmdline: /usr/bin/X :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-dsjSeE/database -nolisten tcp vt7

  ProcEnviron:

   LANG=en_US.UTF-8

   PATH=(custom, no user)

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic root=UUID=21509f82-b140-4652-a0af-4a216a82f9ac ro quiet splash vt.handoff=7

  ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-2-generic root=UUID=21509f82-b140-4652-a0af-4a216a82f9ac ro quiet splash vt.handoff=7

  Signal: 6

  SourcePackage: xorg-server

  StacktraceTop:

   __kernel_vsyscall ()

   raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64

   abort () at abort.c:92

   __libc_message (do_abort=2, fmt=0xfce07c "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189

   malloc_printerr (action=&lt;value optimized out&gt;, str=&lt;value optimized out&gt;, ptr=0x8da5930) at malloc.c:6283

  Title: Xorg assert failure: *** glibc detected *** /usr/bin/X: corrupted double-linked list: 0x08da5930 ***

  UserGroups:

  dmi.bios.date: 03/26/2010

  dmi.bios.vendor: Phoenix

  dmi.bios.version: SPPNV10A.86A.0026.2010.0326.0001

  dmi.board.name: Intel powe...

Read more...

Revision history for this message
MoLE (moleonthehill) wrote :

Sadly the latest version which I am running still has the bug. I was merely asking if testing the PPA noted above was still required.

mole@tm800-500gb:~$ apt-cache policy xserver-xorg-core
xserver-xorg-core:
  Installed: 2:1.9.99.901+git20110131.be3be758-0ubuntu6
  Candidate: 2:1.9.99.901+git20110131.be3be758-0ubuntu6
  Version table:
 *** 2:1.9.99.901+git20110131.be3be758-0ubuntu6 0
        500 http://mirror.anl.gov/pub/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

Changed in xorg-server (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
assignee: Chris Halse Rogers (raof) → nobody
Revision history for this message
Chris Halse Rogers (raof) wrote :

This should be fixed in xserver-xorg-core 2:1.9.99.902-2ubuntu1. If you still see this problem with the new xserver, please re-open this bug.

Changed in xorg-server (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers