Regression: Brightness up restarts X in Edgy with Asus V6J

Bug #68391 reported by Jyrki Pulliainen on 2006-10-26
4
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: acpi-support

Pressing brightness up hotkey (fn+f6) restarts X. This didn't happen in Dapper, the brightness hotkey was correctly working there. No setup changes (like BIOS) was done before updating. This also happens if Edgy is installed from a clean install.

Below events from acpid.log (when pressing fn+f6)
[Thu Oct 26 16:27:59 2006] received event "video LCDD 00000086 00000000"
[Thu Oct 26 16:27:59 2006] notifying client 4487[108:108]
[Thu Oct 26 16:27:59 2006] completed event "video LCDD 00000086 00000000"

Also, brightness down (fn+f5) doesn't generate events.

Apparently asus_acpi is not loaded correctly.

The output of `lsmod | grep acpi`

sony_acpi 6412 0
pcc_acpi 14080 0
dev_acpi 12292 0
asus_acpi 17688 0

Nothing is using asus_acpi, how could this be fixed?

Output of /proc/acpi/asus/info

Asus Laptop ACPI Extras Driver 0.30
Model reference : M2E
SFUN value : 0x18f7
DSDT length : 34937
DSDT checksum : 159
DSDT revision : 1
OEM id : V6J00
OEM table id : V6J00005
OEM revision : 0x5
ASL comp vendor id : INTL
ASL comp revision : 0x2002026

Which is false, since the model is V6J.

J. Pulliainen, I have the same information under Dapper, nevertheless, brightness hotkeys works fine on my laptop (a V6J-X001P) :
$ lsmod | grep acpi
sony_acpi 5580 0
pcc_acpi 12416 0
dev_acpi 11236 0
asus_acpi 11476 0
acpi_sbs 20172 0
battery 9988 5 acpi_sbs
ac 5220 1 acpi_sbs
i2c_acpi_ec 5120 1 acpi_sbs
i2c_core 22848 2 i2c_acpi_ec,nvidia

$ cat /proc/acpi/asus/info
Asus Laptop ACPI Extras Driver 0.29
Model reference : M2E
SFUN value : 0x18f7
DSDT length : 33893
DSDT checksum : 26
DSDT revision : 1
OEM id : V6J00
OEM table id : V6J00005
OEM revision : 0x5
ASL comp vendor id : INTL
ASL comp revision : 0x2002026

This is the logs written in the /var/log/acpi when pressing the brightness up hotkey:
[Wed Nov 1 14:17:56 2006] received event "hotkey ATKD 0000001b 00000000"
[Wed Nov 1 14:17:56 2006] notifying client 4781[108:108]
[Wed Nov 1 14:17:56 2006] completed event "hotkey ATKD 0000001b 00000000"

and when pressing the brightness down:
[Wed Nov 1 14:19:10 2006] received event "hotkey ATKD 0000002a 00000000"
[Wed Nov 1 14:19:10 2006] notifying client 4781[108:108]
[Wed Nov 1 14:19:10 2006] completed event "hotkey ATKD 0000002a 00000000"

Thanks for your reply,

the brightness worked under Dapper, so that's why I'm now confused with the Edgy behaviour.

Additional information with the Dapper on the V6J:
- the event sent when pressing the brightness up is 0000001f instead of 00000086 as reported in the bug,

- the event sent when pressing the brightness down is 0000002e.

Could this issue come from the hardware or from a misunderstanding of events from the acpi driver?

Could it possible that the ACPI hardware differs from a V6J model to another V6J one (V6J-X001P, V6J-X007P, and so on) ? Indeed, the information from the /proc/acpi/asus/info in my computer differs slightly with the one provided by J. Pulliainen.

I've done revert back to Dapper once (during beta) and the brightness up key worked fine. Now that I installed Edgy, it started to do the restarting X.

The codes from the ACPI I've gathered by pressing the Brightness Up -key in TTY1 and copying the output to the log here. I've also double checked with Dapper that the value for some reason is indeed different. For some reason, Edgy reports it as LCDD as it should be ATKD. Also, the numeric acpi code (as Miguel Moquillon reports) differs.

To clarify previous comment: I've made the revert to Dapper from Edgy beta, the one now installed is the released version, upgraded from dapper. I've also tested a clean install with Beta (this shouldn't, however, make this bug less severe)

This evening, I installed on another disk the Ubuntu Edgy.
After testing it, I don't have any problem reported with it: the brightness up and down keys work fine (the touchpad lock also).
The only things that work badly as they are in Dapper are the suspend and the hibernate functions (with hotkeys or with softwares). As with Dapper, in my notebook, the external screen switch doesn't work.

However I noticed the events recieved for brightness up and down in Edgy are differents from the ones in Dapper:
00000029 instead of 0000002e in Dapper when pressing the brightness down key,
0000001a instead of 0000001f in Dapper when pressing brightness up key.

I forgot one thing: perhaps it is the X configuration that cause theses troubles.
This is as attachment file my xorg.conf file.

Download full text (3.7 KiB)

It seems the attachment of the xorg.conf didn't work. So I post it here (without comments):

Section "ServerLayout"
    Identifier "Layout"
    Screen "Screen" 0 0
    InputDevice "Keyboard"
    InputDevice "Mouse"
    InputDevice "Touchpad" "AlwaysCore"
EndSection

Section "Files"

 # path to defoma fonts
    FontPath "/usr/share/X11/fonts/misc"
    FontPath "/usr/share/X11/fonts/cyrillic"
    FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/Type1"
    FontPath "/usr/share/X11/fonts/100dpi"
    FontPath "/usr/share/X11/fonts/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
# Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"
EndSection

Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER" "enable"
EndSection

Section "InputDevice"
    Identifier "Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "fr"
    Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
    Identifier "Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
    Identifier "Touchpad"
    Driver "synaptics"
    Option "Protocol" "auto-dev"
    Option "LeftEdge" "1700"
    Option "RightEdge" "5300"
    Option "TopEdge" "1700"
    Option "BottomEdge" "4200"
    Option "FingerLow" "25"
    Option "FingerHigh" "30"
    Option "MaxTapTime" "180"
    Option "MaxTapMove" "220"
    Option "VertScrollDelta" "100"
    Option "MinSpeed" "0.12"
    Option "MaxSpeed" "0.20"
    Option "AccelFactor" "0.0015"
    Option "SHMConfig" "on"
    Option "Device" "/dev/input/event1"
EndSection

Section "Monitor"
    Identifier "Monitor"
    HorizSync 28.0 - 70.0
    VertRefresh 43.0 - 60.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "NVIDIA GeForce 7400"
    Driver "nvidia"
    Option "NoLogo"
    Option "RenderAccel" "true"
    Option "RandRRotation" "true"
    Option "AllowGLXWithComposite" "true"
    Option "backingstore" "true"
EndSection

Section "Screen"
    Identifier "Screen"
    Device "NVIDIA GeForce 7400"
    Monitor "Monitor"
    DefaultDepth 24
    SubSection "Display"
        Depth 1
        Modes "1400x1050" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth 4
        Modes "1400...

Read more...

We had somehow different X.org and I tried yours. X works, but the brightness up still crashes it. Also, I don't get the same acpi codes as you.

Seems, that there indeed is some hardware difference between these two machines, but I still don't understand why Edgy behaves like it does.

Now the behaviour has changed. Pressing brightness up restarts the whole machine. And it restarts it controlled (as if I'd called reboot), not like crashing down.

I sent the laptop to Asus for repair and they changed the motherboard. Now, the brightness works ok.

Rejecting, since a hardware issue afterall

Changed in acpi-support:
status: Unconfirmed → Rejected

This behaviour is confirmed now. Another V6J user ('Visik7' on Ubuntu wiki) found out that bios 303 causes the dsdt code to change. Change causes the Brightness up to restart X. I can confirm this behavior with bios version 303.

Changed in acpi-support:
status: Rejected → Confirmed
Matthew Garrett (mjg59) on 2007-08-31
Changed in acpi-support:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers