xserver-xephyr: Couldn't find keyboard driver evdev

Bug #659793 reported by Oliver Breuer on 2010-10-13
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xorg-server (Debian)
New
Unknown
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xserver-xephyr

When starting Xephyr with the following command line:

Xephyr :5 -ac -screen 1280x1024 -mouse evdev,,device=/dev/input/by-id/usb-04d9_0499-event-mouse -keybd evdev,,device=/dev/input/by-id/usb-Logitech_Logitech_USB_Keyboard-event-kbd,xkbrules=xorg,xkbmodel=evdev,xkblayout=de,xkbvariant=nodeadkeys,xkboptions="lv3:ralt_switch,compose:caps" -dpi 100

The following messages are printed on the console:

[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
Kbd option key (compose:caps) of value ((null)) not assigned!
Couldn't find pointer driver evdev
Couldn't find keyboard driver evdev

The keyboard and mouse are not working.

When downgrading xserver-xephyr to version 2:1.7.6-2ubuntu7, the error messages about evdev don't appear and keyboard and mouse work as expected.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: xserver-xephyr 2:1.9.0-0ubuntu7
Architecture: amd64
ExecutablePath: /usr/bin/Xephyr
SourcePackage: xorg-server

ppc123 (ppc123) wrote :

I'm also facing the same problem.
Couldn't find pointer/keyboard driver evdev.

DistroRelease: Ubuntu 10.10
Package: 2:1.9.0-0ubuntu7.3
Architecture: i686

ppc123 (ppc123) wrote :

I tried Xephyr in Ubuntu 10.04, and every things work...
It seems to be problem of Ubuntu 10.10.

Neyder (neyder) wrote :

same in natty, how can i report it? or fix it??

ppc123 (ppc123) wrote :

Get and install the package "xserver-xephyr_1.7.6-2ubuntu7.6_i386.deb" instead, and everything will be fine.
(That's the version of Xephyr in Lucid)

jap1968 (jap1968) wrote :

Same problem here.
I am trying to setup a multiseat computer using LightDM and following this guide:
http://netpatia.blogspot.com/2009/06/multiseat-in-ubuntu-904.html

Tried with ephyr instead of evdev, but I am not able to launch Xephyr.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
ferux@mail.ru (ferux) on 2012-07-24
tags: added: precise
Changed in xorg-server (Debian):
status: Unknown → New

Oliver Breuer, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg-server REPLACE-WITH-BUG-NUMBER

Please note, given you already have done this in a prior release, performing this on a release prior to Trusty would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xorg-server (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Tom Fields (udzelem) wrote :

Hi, I am not Oliver Breuer, but this bug is definitely still there in package:

xserver-xorg Version: 1:7.7+1ubuntu7
(xserver-xorg-core Version: 2:1.14.5-1ubuntu2)
(xserver-xephyr Version: 2:1.14.5-1ubuntu2)

The package autoconfiguration does somehow not work and omits the evdev functionality for the kdrive xserver contained in this Ubuntu package (likely also in the Debian package).

However, when manually compiling with ./configure --enable-kdrive --enable-kdrive-evdev --enable-kdrive-mouse --enable-kdrive-kbd, the compiled Xephyr binary (hw/kdrive/ephyr/Xephyr or build-main/hw/kdrive/ephyr/Xephyr in the build tree) does work as expected with evdev enabled.

Therefore, the workaround for people who want the xorg-server (xserver-xephyr binary package) with support for evdev enabled, I recommend compiling manually with the above mentioned configure options manually added to debian/rules.
(It seems compiling with DEB_BUILD_OPTIONS=--enable-kdrive-evdev etc. is not supported).

For a quick fix under Ubuntu Saucy (with newest Xserver from saucy-updates repository enabled) or Ubuntu Trusty alpha, I included a patch.

The package can be compiled the Debian way:

mkdir -p ~/src/xorg-server-evdev-patch
cd ~/src/xorg-server-evdev-patch
wget #(URL to patch)
apt-get source xorg-server
cd xorg-server-1.14.5 #(or the corresponding package version)
patch -p1 < ../xorg-server-1.14.5-patch-kdrive-evdev
(optional: change package version in debian/changelog not to have the package replaced during later upgrades)
dpkg-buildpackage -uc -us -b
sudo dpkg -i ../xserver-xephyr_1.14.5-1ubuntu2_amd64.deb ../xserver-common_1.14.5-1ubuntu2_all.deb

If someone understands the build system used in xorg-server package better than me, please feel free to fix the bug in the build system's configure script (autodetection does not work, it seems).

The attachment "PATCH: Enable evdev support for kdrive-based X-server in Ubuntu package xorg-server" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Richard Hansen (rhansen) on 2014-02-14
tags: added: multiseat
Richard Hansen (rhansen) on 2014-02-15
Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed
Richard Hansen (rhansen) wrote :

Are the --enable-kdrive-mouse and --enable-kdrive-kbd arguments necessary? They seem unrelated to the specific symptomps originally reported, and according to <https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=646686#12> they may have issues. From that bug comment:

On Wed 2013-03-27T14:20:34+0100 Geert Uytterhoeven <email address hidden> wrote:
> - I did not enable kdrive-kbd, as it's completely broken.
> Since it no longer fills in KdKeyboardInfo.minScanCode and
> KdKeyboardInfo.maxScanCode, any keypress causes messages like:
>
> driver Linux console keyboard wanted to post scancode x outside of [0, 0]!
>
> - kdrive-mouse still works (e.g. "-mouse ps2", or "-mouse mouse" for
> protocol probing, which takes some time), but the recommended way
> these days is kbd-evdev, using the following (ugly) command line
> parameters:
>
> -keybd evdev,,device=/dev/input/event0
> -mouse evdev,,device=/dev/input/event1

It seems like just adding --enable-kdrive-evdev would be sufficient and safer, no?

Tom Fields (udzelem) wrote :

Richard,

yes, the way I see it, you are right.

hede (michael-heide) wrote :

Ubuntu 14.04 and this Bug is still active.
Simply adding the Patch above and recompiling via dpkg-buildpackage works, no need to manually running configure.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.