Ubuntu

Xorg crash when viewing a large PNG file in firefox

Reported by David Pottage on 2010-07-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xorg

When viewing this PNG file in firefox:

http://www.lightbluetouchpaper.org/wp-content/uploads/2010/07/pspvc2.png
Or the page it is linked from:
http://www.lightbluetouchpaper.org/2010/07/28/passwords-in-the-wild-part-ii-failures-in-the-market/
(Which appears to have the same image embedded but not scaled) firefox triggers an X-server crash.

I don't get the crash if I run firefox in safe mode, or use Google Chrome instead.

I still get the crash if I run firefox with the "--no-xshm" option enabled.

These lines appear in dmesg after the crash:

[ 555.673428] [drm:i915_gem_do_execbuffer] *ERROR* Failed to pin buffer 66 of 72, total 116989952 bytes: -28
[ 555.673433] [drm:i915_gem_do_execbuffer] *ERROR* 1279 objects [71 pinned], 526462976 object bytes [56389632 pinned], 56389632/234881024 gtt bytes

I have attached my /var/log/Xorg.0.log and /var/log/gdm/:0.log files

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-24.38-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Fri Jul 30 10:01:26 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
MachineType: Dell Inc. Vostro 3500
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic root=UUID=b98c93f6-0b16-4aa4-b7fc-06d37625057e ro vga=792 splash quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
Title: Xorg crash
dmi.bios.date: 02/10/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A01
dmi.board.name: 0G2R51
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA01:bd02/10/2010:svnDellInc.:pnVostro3500:pvrNotSpecified:rvnDellInc.:rn0G2R51:rvrA00:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Vostro 3500
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-24-generic

Bryce Harrington (bryce) on 2010-08-03
Changed in xorg (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-08-04
affects: xorg (Ubuntu) → xorg-server (Ubuntu)

I tried to reproduce this bug on my x86_64 based desktop machine (Intel G45 graphics), and it did not happen.

Hello,

We have three computers here having this problem. They all are:

(dmidecode)
System Information
        Manufacturer: LENOVO
        Product Name: 3269A7G
        Version: ThinkCentre M90p
        Serial Number: xxxxx
        UUID: xxxx

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.1 LTS
Release: 10.04
Codename: lucid

uname -a
Linux xxx 2.6.32-25-generic-pae #45-Ubuntu SMP Sat Oct 16 21:01:33 UTC 2010 i686 GNU/Linux

(lspci -vvv -s 00:02.0)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
 Subsystem: Lenovo Device 3059
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 30
 Region 0: Memory at fe000000 (64-bit, non-prefetchable) [size=4M]
 Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at f0b0 [size=8]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+
  Address: fee0a00c Data: 41a1
 Capabilities: [d0] Power Management version 2
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [a4] PCIe advanced features <?>
 Kernel driver in use: i915
 Kernel modules: i915

dpkg -l | grep intel
ii intel-gpu-tools 1.0.2+git20100324-0ubuntu1 tools for debugging the Intel graphics driver
ii libdrm-intel1 2.4.18-1ubuntu3 Userspace interface to intel-specific kernel DRM services -- run
ii whois 5.0.0ubuntu3 an intelligent whois client
ii xserver-xorg-video-intel 2:2.9.1-3ubuntu5 X.Org X server -- Intel i8xx, i9xx display driver

dmesg | grep -i drm
[ 0.000000] Linux version 2.6.32-25-generic-pae (buildd@palmer) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #45-Ubuntu SMP Sat Oct 16 21:01:33 UTC 2010 (Ubuntu 2.6.32-25.45-generic-pae 2.6.32.21+drm33.7)
[ 15.248561] [drm] Initialized drm 1.1.0 20060810
[ 15.291729] [drm] MTRR allocation failed. Graphics performance may suffer.
[ 15.291774] [drm] set up 127M of stolen space
[ 15.588276] fb0: inteldrmfb frame buffer device
[ 15.588318] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0

What happens:
When we open any huge image (either jpeg, png) in Firefox, X crashes. The only lines we have in dmesg are:
[drm:i915_gem_do_execbuffer] *ERROR* Failed to pin buffer 1 of 2, total 93585408 bytes: -28
[drm:i915_gem_do_execbuffer] *ERROR* 932 objects [6 pinned], 262848512 object bytes [23990272 pinned], 23990272/134217728 gtt bytes

There's no other message before nor after those lines. After that, X recovers, and we're on the login screen.

This bug can be reproduced on our workstations.

Maybe it's a i686 bug - we cannot check that, we only have i686 computers here.

Any input would be great.

Thank you!

C.

aefaradien (sen-aefaradien) wrote :

Agreed, this seems to be a duplicate of #528432

David Pottage, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xorg-server REPLACE-WITH-BUG-NUMBER

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xorg-server (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

I no longer have access to the computer where I saw the crash (It was a work PC, and I have changed jobs).

I cannot reproduce this bug on a recent version of Ubunutu, so I is probably fixed, and can be closed here.

David Pottage, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/611619/comments/8 regarding you no longer have the original hardware, and it's not reproducible on your new hardware. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.