[SRU] X server segfaults when using XTest (xvfb)

Bug #607071 reported by Nathaniel Smith on 2010-07-19
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
parti-all (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

There is a bug in at least xorg-server 1.7.6 (as shipped in Lucid) where certain uses of XTest cause a null pointer dereference and the server crashes.

XTest probably isn't used much in general, but this causes very serious problems for 'xpra' -- basically it is unusable in Lucid (at least for me) because the X server keeps crashing under it. I would not be surprised if x11vnc had a similar problem.

(NB, I am the upstream for xpra.)

This bug has been fixed in upstream X.org, and I bisected the fix to this commit:
  http://cgit.freedesktop.org/xorg/xserver/commit/?id=af170a4ab76d33254dd4e54a33bb410fa1624739

This bug-fix commit has also been backported to the 1.7 stable tree, and is included in xorg-server 1.7.7:
  http://cgit.freedesktop.org/xorg/xserver/commit/?id=ad48184752970541aa153bf2961a2d7da1a910b5
and I have confirmed that xpra works with 1.7.7.

Please upgrade to 1.7.7, or apply this patch to your 1.7.6.

(This has been reported several times as a bug in xpra, see: http://code.google.com/p/partiwm/issues/detail?id=20)

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xvfb 2:1.7.6-2ubuntu7.2
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic i686
Architecture: i386
Date: Sun Jul 18 22:22:12 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/zsh
SourcePackage: xorg-server

Nathaniel Smith (njs) wrote :
Bryce Harrington (bryce) on 2010-07-19
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Todd Vierling (duh) wrote :

The backported patch applies cleanly to xorg-server 2:1.7.6-2ubuntu7.2, affects the single function ProcXTestFakeInput(), works as described, and should be included in proposed 7.3 if possible.

I have attached an isolated diff for inclusion into the proposed package.

+ * Applied patch from upstream git to prevent crash of Xvfb under xpra:
+ https://bugs.launchpad.net/ubuntu/+source/parti-all/+bug/607071
+
+ -- Todd Vierling <email address hidden> Mon, 19 Jul 2010 17:55:31 -0400

Changed in parti-all (Ubuntu):
status: New → Opinion
tags: added: patch
chrisisbd (chris-isbd) wrote :

Could this be related to a problem I'm having with the command xte in 10.04?

I use xbindkeys + xte to make the fourth button on my Logitech mouse work as a double click of button 1, I have the following in .xbindkeysrc:-

"/usr/bin/xte 'mouseup 9' 'mouseclick 1' 'mouseclick 1' &"
b:9

I.e. when I hit button 9 (which is the fourth button) the xte command above is executed. This works prefectly in 9.04 and 9.10 but just does nothing at all in 10.04. Since xte uses the XTest facility I was wondering if the bug is connected?

Todd Vierling (duh) wrote :

chrisisbd: You could install the xorg-server packages from my PPA to find out:

https://launchpad.net/~duh/+archive/lucid-xpra-fix

If those packages do not fix it, I recommend installing ppa-purge (it will show up as a new package in aptitude the first time you add a PPA to your system) and using that to roll xorg-* packages back to the official ones.

Todd Vierling (duh) wrote :

The fixed xvfb (only) has been put into my generic PPA: ppa:duh/duh

https://launchpad.net/~duh/+archive/duh

This version builds only the fixed xvfb package, allowing use of the normal lucid-updates xorg-server packages otherwise. The separate ppa:duh/lucid-xpra-fix PPA is now deleted.

Todd Vierling (duh) wrote :

-2ubuntu7.4 was released with a different upstream path relating to captive mouse pointers, and this patch addresses a *crash*. Could we please see this make it into -2ubuntu7.5?

Bryce Harrington (bryce) on 2010-11-26
summary: - X server segfaults when using XTest
+ X server segfaults when using XTest (xvfb)
Changed in parti-all (Ubuntu Lucid):
status: New → Opinion
Changed in xorg-server (Ubuntu Lucid):
status: New → In Progress
Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Changed in parti-all (Ubuntu):
status: Opinion → Invalid
Changed in parti-all (Ubuntu Lucid):
status: Opinion → Invalid
Marc Deslauriers (mdeslaur) wrote :

SRU request:

Impact: certain uses of XTest cause a null pointer dereference, rendering xpra unusable in Lucid.

This is fixed in the newer xorg-server version in Maverick. I've prepared an SRU for lucid that adds the trivial upstream fix that corrects the issue. See attached debdiff.

summary: - X server segfaults when using XTest (xvfb)
+ [SRU] X server segfaults when using XTest (xvfb)
Bryce Harrington (bryce) wrote :

+1 for SRU

Accepted xorg-server into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xorg-server (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Any testers?

Todd Vierling (duh) wrote :

I was using -2ubuntu7.5 all day today while snowed in, with Eclipse on top of xpra. Can't get much more stressful testing than that. :)

Martin Pitt (pitti) on 2011-01-11
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.7.6-2ubuntu7.5

---------------
xorg-server (2:1.7.6-2ubuntu7.5) lucid-proposed; urgency=low

  * debian/patches/203_fix-xtest-lp607071.patch: fix segfault with certain
    uses of XTest because of null pointer dereference. (LP: #607071)
 -- Marc Deslauriers <email address hidden> Mon, 06 Dec 2010 09:38:40 -0500

Changed in xorg-server (Ubuntu Lucid):
status: Fix Committed → Fix Released

Hello Customer

But what should you do if you can not afford the unique luxurious watches for all these wear?
What you see - is what you get!

-----
I just received my PN-20 (Panerai Luminor GMT Automatic), and I have to say I'm really impressed. I have ordered from quite a few replica sites in the past, and I always ended up sending the watch back disappointed. I hope this makes it into your customer comments section. I would recommend this site to anyone. Very prompt delivery, great prices and wonderful quality.
Thanks for the fast response. You guys are great!
                     Tony Acevedo
-----

Click here ---> http://moung.ru

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers