mouse stuck jumping between screens

Bug #570151 reported by koshcu on 2010-04-26
166
This bug affects 30 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

This url pretty much has the exact description of the problem I have http://forums.gentoo.org/viewtopic-t-818488-start-0.html and their solution was to downgrade to xserver 1.6 but I don't see how to do that with ubuntu.

I have two 8800GTS video cards and two monitors on each card. With Xinerama enabled and moving the mouse between screens the mouse will get stuck. At that point Xorg will increase in memory usage very quickly it looks like a hundred megs every couple seconds. I can go to another machine and kill Xorg then it will restart and I can use the system again but this is very frustrating. This setup has been working fine for a long time now but it seems that Xinerama is xorg 1.7 is just kind of broken.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg-core 2:1.7.6-2ubuntu7
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Apr 26 07:06:11 2010
DkmsStatus:
 nvidia-current, 195.36.15, 2.6.31-20-generic, x86_64: installed
 nvidia-current, 195.36.15, 2.6.32-21-generic, x86_64: installed
ExecutablePath: /usr/bin/Xorg
Lsusb:
 Bus 002 Device 073: ID 1532:0101 Razer USA, Ltd Copperhead Mouse
 Bus 002 Device 093: ID 045e:00db Microsoft Corp. Natural Ergonomic Keyboard 4000 V1.0
 Bus 002 Device 002: ID 0557:8021 ATEN International Co., Ltd
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Tyan Computer Corporation MCP55
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=d907ccb1-3f8e-4f38-9ebe-7bec483ed266 ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: xorg-server
Xrandr:
 Error: command ['xrandr', '--verbose'] failed with exit code 1: Xlib: extension "RANDR" missing on display ":0.0".
 RandR extension missing
dmi.bios.date: 04/04/2008
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 2.05.2915
dmi.board.name: S2915
dmi.board.vendor: Tyan Computer Corporation
dmi.board.version: REFERENCE
dmi.chassis.type: 17
dmi.chassis.vendor: NVIDIA
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr2.05.2915:bd04/04/2008:svnTyanComputerCorporation:pnMCP55:pvrREFERENCE:rvnTyanComputerCorporation:rnS2915:rvrREFERENCE:cvnNVIDIA:ct17:cvr:
dmi.product.name: MCP55
dmi.product.version: REFERENCE
dmi.sys.vendor: Tyan Computer Corporation
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-21-generic

koshcu (kosh-aesaeion) wrote :
Bryce Harrington (bryce) on 2010-04-27
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Alejandro Cuervo (a-cuervo) wrote :

Same bug here.

I have 3 Monitors on an Nvidia NVS 450 video card. The three worked perfect in 9.10 using Xinerama.
Just upgraded to 10.04 and mouse pointer gets stuck (flickering) between monitors becoming unusable.
Xorg CPU usage skyrockets and I have to kill it.

Alejandro Cuervo (a-cuervo) wrote :

Seems to be an issue with the "leftOf" directive in xorg.conf and Xinerama

A temp workaround is to use only "RightOf" directives

I just redid my xorg.conf with only "RightOf" directives, re-arranged my monitors physically to match that of the new xorg.conf and it is

working fine

koshcu (kosh-aesaeion) wrote :

All my screens are set as RightOf and I still have this bug so RightOf is not a universal solution.

Alejandro Cuervo (a-cuervo) wrote :

The TEMP workaround also requires the 'screens' to be in order.

INCORRECT:
Section "ServerLayout"
    Identifier "Layout0"
    Screen 2 "Screen2" 0 0
    Screen 1 "Screen1" RightOf "Screen2"
    Screen 0 "Screen0" RightOf "Screen1"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "1"
EndSection

CORRECT:
Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    Screen 1 "Screen1" RightOf "Screen0"
    Screen 2 "Screen2" RightOf "Screen1"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "1"
EndSection

This is not optimal nor final solution, just a temp workarround.

koshcu (kosh-aesaeion) wrote :

If you look at my attached Xorg.conf my setup is

Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Screen0" 0 0
    Screen 1 "Screen1" RightOf "Screen0"
    Screen 2 "Screen2" RightOf "Screen1"
    Screen 3 "Screen3" RightOf "Screen2"
    Option "Clone" "off"
EndSection

with Xinerama set elsewhere and that still has the problem. All in order, all RightOf so that workaround won't work for everyone. Wish I knew why though.

Chris Halse Rogers (raof) wrote :

Xinerama in general seems to be having problems in Lucid, which is perhaps not *too* surprising as it's been deprecated upstream for some time.

Bug #572113 and bug #572192 are similar bugs in Xinerama, and I think the upstream bug https://bugs.freedesktop.org/show_bug.cgi?id=25166 is likely to be related.

koshcu (kosh-aesaeion) wrote :

Hmm I did not know that xinerama was deprecated. So what do they suggest be used? Eyefinity is only for ati cards and not ready on linux yet. RandR did not get gpu object support so that does not work with multiple video cards either. Xinerama seems to be the only technology we have right now and it has worked for a long time.

koshcu (kosh-aesaeion) wrote :

I don't think my bug is a duplicate. If you look at my xorg.conf you will see that all the displays are in order. So there should be no issue with a signed number or not dealing with negatives like the other bug.

If this was the same bug then the RightOf workaround would work and it doesn't for me.

I seem to be getting the same end result where the pointer is getting stuck between screens but from what I can read the cause is not the same.

Alberto Milone (albertomilone) wrote :

Agreed, I don't it's a duplicate.

Alberto Milone (albertomilone) wrote :

I meant to say "I don't think it's a duplicate"

James Robinson (ubuntu-james) wrote :

Any progress on this:

I've just fixed bug 591104 and now this is killing me.

Who deprecated Xinerama without replacing it? Having now got 4 monitors working properly, apart from this bug, I can't possibly imagine why anyone would want to be limited to just 2.

Brian Walker (bfuzze) wrote :

I've been dealing with this since I switched to 10.04 a couple months ago. It happens regularly (every 2-3 days), but I don't know exactly how to reproduce. I can confirm that using rightOf with screens in the correct order does not reolve the problem.

My xorg.conf:
Section "ServerLayout"
# Removed Option "Xinerama" "0"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    Screen 1 "Screen1" RightOf "Screen0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "1"
EndSection

Any news on when this will be fixed or a workaround?

Daniel P. Brown (danbrown) wrote :

This issue has been plaguing my triple-headed setup as well, keeping me from adding a 32" HDTV as a fourth monitor for a combination of multiple-network monitoring, better media capability, and bragging rights.

One thing I noticed: while trying out a few Playstation emulators, one caused my primary display to resize to 640x480, and it couldn't be resized without rebooting the machine. However, the entire time it was set to that resolution, the system was stable --- for the first time since going to 10.04+GNOME (and, indeed, Ubuntu in general --- I'm a relatively-new convert from Mandriva+KDE with regard to desktop).

For posterity, my current xorg.conf is attached. (Subject to change multiple times weekly, mind you, as I continue to attempt to find a resolution. ;-P)

Things of note:

    1.) The mouse will hang at least once per day, seemingly at random, and sometimes multiple times per day.
    2.) The mouse will *ONLY* hang between screens zero (0) and one (1). There has never been an issue with the other screen seam.
    3.) Screen 0 is on an nVidia GeForce 8400 GS, while Screen 1 and Screen 2 are on an nVidia GeForce 9400 GT.
    4.) Again, while Screen 0 was at 640x480, there was no issues for > 14 days. Coincidence?

Alejandro Cuervo (a-cuervo) wrote :

Is this what everyone here is experiencing?

http://www.youtube.com/watch?v=r7BVdLMCJ9E

Daniel P. Brown (danbrown) wrote :

Exact same thing here. Mine was between the first and second displays. Was yours as well? Also, with mine, I can still move the mouse vertically (despite its continued "blinking" between displays), but there is no response from anything else whatsoever.

Alejandro Cuervo (a-cuervo) wrote :

@Daniel, on the video it was between screen two and three, but it also happens to me between the first and the second.

I can also move the mouse vertically, but everything else is dead not even Ctrl-Alt-Backspace works.

Hopefully this bug can gather enough people for some expert to look into it.

I have been with linux since 6.10, and extremely happy with it. Then, I did not have multiple monitors, I added my second monitor at around 8.04 and everything worked beautifully with twinview.
Since 9.04 I added my third monitor and had to switch from twinview to Xinerama, everything worked perfect until 9.10.
Now in 10.04 this bug has hampered my productivity a lot. Going back to fewer monitors is not an option, once you go double or triple, is impossible to go back.
I wish multiple monitor support (3+) gets a lot of attention soon. I cant believe, linux, being the workstation grade OS it is, has such a wimpy multi-monitor support. We can't possibly be the only ones needing 3+ monitors support.

Daniel P. Brown (danbrown) wrote :

Today it happened three times in under an hour. The first two between displays one and two, the third - for the first time ever for me - between two and three. The only difference on the third occurrence was that I was attempting to play a Flash video (SWF) in VLC. I'm sure it's completely irrelevant, but since it happened (as I pressed Play) simultaneously with the first freeze between the second and third displays, it may be worth mentioning.

Well, after the last crash, I'm fed up. The loss of work is nearly rivaling the decrease in productivity I'll have if this keeps crashing versus giving up a display.... but I'm trying one final thing: KDE.

This evening I converted from Ubuntu to a bastardized version of Kubuntu (I just overlayed KDE, leaving everything else - including GDM - in place). I'm unsure it will be any better, but at the very least, the triple-head display worked right off the bat. And for me, coming from Mandr(ake|iva) after the better part of a decade, where it didn't work at all, I'm already impressed.

I'll give it a week and come back with my findings. If it repeats, I'll drop GDM in favor of KDM. If it doesn't, it may at least narrow it down to something in the upper-level DM layer.

Daniel P. Brown (danbrown) wrote :

As promised, an update:

For the first time in months, I was able to get through a full week without a single crash. Unfortunately, the week was instead plagued with slower response times (whereas GNOME's response to things like swapping windows would take <1ms, KDE would sometimes take as long as ~3s to redraw, focus, and control). It's also overloaded, by default, with so much "eye candy" that bogs the system down. Trimming out what I consider useless - as a developer who spends time in a formula CLI > GUI - improved the experience a bit, but it still has some work needed to get it where I want it. This week was minimal in that regard, as I wanted to give a good, full account on a setup as close to the apt-get default install as possible. So, just to close with a quick summary of pros vs. cons:

PROS:
    * No crashes or freezes during seven-day test window --- improvement from >=1 crash per 24 hours.
    * Very, very easy to install, thanks to apt.
    * Easy enough to switch back to GNOME at will.
    * NO CRASHES, NO LOSS OF WORK! WOO-HOO!!!!

CONS:
    * Bloated, heavy, slow, and a bit juvenile in appearance.
        (NOTE: Until switching to Ubuntu from Mandriva, I had always preferred KDE.)
    * Relatively slow response times to input from control devices.
    * Need to re-familiarize myself with keystroke combinations in KDE vs. GNOME.
    * Not a fan of the new menus and navigation structure.
    * Too much "eye candy" for my personal preference.
    * Memory utilization notably higher in KDE, even during extended idle periods.
    * A few times, applications drawing to center screen left a "whiteboard" - where you drag other windows over and it leaves their foreground on top of the screen on the "whiteboard" area - until the processes were killed or died.
    * For whatever reason, ~/Desktop doesn't display on the GUI desktop as icons.
    * Window and widget edge detection doesn't always seem to calculate properly with relation to the physical aspect and available space of the screen.
    * Window swapping would sometimes cause a window not selected to gain focus.
    * Clicking borders of some windows to try to gain focus caused them to minimize to the center. (Perhaps a "feature"?)

That's about it for now. In a bit of a rush to get out to finish some high-priority stuff before the US holiday weekend here, so my apologies if these notes appear a little skewed. Any questions you have about my experience, send them to (danbrown AT php DOT net) and I'll try to answer them.

Lee-Ping Wang (officer-ping) wrote :

I also have a four-monitor setup with two graphics cards. I'm also experiencing the mouse pointer getting stuck + flickering problem after upgrading to Lucid. I use absolute screen positioning (since my four monitors have different sizes), and I have taken care to put the screens in order from top left to bottom right. I thought this fixed the problem since I didn't crash for a few days, but the problem just showed up again.

If xinerama is deprecated as many people are saying, then there needs to be another solution for multiple video cards / multiple monitor setups; I have been using Ubuntu since Dapper and this has never been a problem until the recent upgrade.

My xorg.conf is attached. Thank you!

Lee-Ping Wang (officer-ping) wrote :

Alejandro: I wanted to watch your Youtube video but it was "private". Is there some way I can view it to confirm that we're both experiencing the same bug? Thank you!

Alejandro Cuervo (a-cuervo) wrote :

@Lee-Ping Wang. I just changed the youtube video to "public" again. You may watch it now.

Lee-Ping Wang (officer-ping) wrote :

@Alejandro Cuervo, this is exactly what happens to me. I have four monitors arranged in an L-shape (see below):

1
2 3 4

I've seen the mouse get stuck in between screens 2 and 3, and screens 3 and 4.

dan_linder (dan-linder) wrote :

If it helps any, I too am getting this and I've been using "gcore" to generate a core file from the Xorg process.

I have two nVidia G-series video cards:
 * GeForce 9400 GT - this drives "screen 1" (middle)
 * GeForce 8600 GT - this drives "screen 0" and "screen 2" (left and right)

My xorg.conf section that defines this:
Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    Screen 1 "Screen1" RightOf "Screen0"
    Screen 2 "Screen2" RightOf "Screen1"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "1"
EndSection

In my case, it locks up at the border between screens about evenly so I don't think it's strictly a Screen0:Screen1 border issue...

I'm running a fully updated Ubuntu 10.04, and I'm able to install any developer tools to assist in debugging and/or dumping the core file data.

DanL

Chris Miller (chrisamiller) wrote :

Exact same problem here. I'm using one card and two monitors, with a single monitor rotated 90 degrees (a configuration that isn't possible using TwinView). I see the stuck mouse and lock-up probably once a day. Xorg file attached, and I'm more than willing to help test patches or provide traces.

Jared Bunting (jared-bunting) wrote :

Just to add my 2 cents - I run 4 monitors, nvidia drivers (2 8600 GT cards) with Xinerama. This happens to me too. I've noticed it tends to happen exclusively when certain apps are loading (Firefox being a prime example) and I try to move the mouse between screens.

Lee-Ping Wang (officer-ping) wrote :

To echo Jared's experiences, the problem always shows up as I move the mouse between screens when a program is loading. Firefox is an example, as is Evolution and GaussView (a computational chemistry 3D viewer).

Ben Kietzman (ben-kietzman) wrote :

This is happening to me as well. I am running Ubuntu 10,10 and have two monitors utilizing Xinerama. The primary is running Intel and the secondary is a Tritton USB SVGA Adapter. It typically freezes between one to three times a day. I use Ctrl-Alt-SysRq with S+U+B to restart.

Daniel P. Brown (danbrown) wrote :

I had tried KDE, different configurations with GNOME, and upgrading from 10.04 to 10.10. The best resolution was the upgrade, but that introduced a new issue. However, now I'm running a fully-functional, non-crashing GNOME over Xinerama with absolutely no problems moving between my three monitors. No guarantees it'll work for you, but I put up the .deb's with a known-working copy of the NVIDIA driver for my setup (possibly applicable to yours as well). You can read a short post on it and download the packages from here:

    http://links.parasane.net/enxr

I had entitled the post "Skype and Google Earth Causes X To Crash On Ubuntu 10.10" because that was the issue of the day.... but to my pleasant surprise, it also fixed the freezing issue. No more SSH'ing into the box to "sudo kill -9 `ps -ef | grep /usr/bin/X | grep -v grep | awk {'print $2'}`" and no more lost work and grunts of frustration.

Here's hoping it works for some other folks out there, too.

Alejandro Cuervo (a-cuervo) wrote :

@ Daniel

Could you please explain or tell what was patched in the xorg_crash_fix_debs_and_NVIDIA_driver_x86_64.tar.bz2 that you provide?

Mike McLemore (mtm-king) wrote :

Same problem - two monitors - NVIDIA GeForce 8300 and GeForce 8400 GE. Very frustrating. Anyone been brave enough to try Daniel P. Brown's (thanks Dan Brown) fix?

markus (sroccaro) wrote :

Same problem:
- Two monitors
- NVIDIA GeForce 8600 GT
- Bought a new GeForce 9500 GT from Best Buy and installed it - same problem
- Installed a NVIDIA GeForce 8500 GT - same problem
- Installed NVIDIA-Linux-x86_64-260.19.29.run from nvidia - same problem
- I'm also running skype and google chrome

- This has been happening more frequently recently; almost once a day.
   skype is a recent installation.

Daniel P. Brown (danbrown) wrote :

Just an update: since patching and installing the package I mentioned earlier, I've had zero issues. In fact, I've actually noticed more stability with Flash and some better graphics acceleration for some animations, as well as fixes for other issues I had here. For example, trying to watch YouTube or other FLV/tube-style videos in full-screen mode would only show at a size of about 30% of the screen, while the remainder of the screen would flash in bright, annoying colors.

@Alejandro: Sorry, I hadn't noticed your question from before. It was a typo in a variable name from the original package. I learned later on that the upstream had already discovered it and fixed it, but it wasn't yet making its way down the pipe to us. I don't recall the name of the file I patched off the top of my head, but if you'd like to know, just zip me a message and I'll go back to the code and get it for you, no problem.

Daniel P. Brown (danbrown) wrote :

@Alejandro: Yup, sure is. Would've been nice if you'd sent that to me several weeks ago! ;-P

Alejandro Cuervo (a-cuervo) wrote :

@ Daniel P: Sorry but I think there is some confusion.

The typo bug in http://cgit.freedesktop.org/xorg/xserver/commit/?id=78f94f19aab66a1e5331df0ce29f36e310b4195d has already been patched and a fix committed in Ubuntu (see Bug #650539)

It has been already delivered via maverick-proposed. And I have it already installed it.

However I am still getting the mouse stuck between screens (This Bug)

So Daniel, you must have done something else or have simply been lucky, because fixing the typo bug does NOT fix this bug.

Alejandro Cuervo (a-cuervo) wrote :

I am not to familiar with "Launchpad" so I'll just ask it here:

Does anybody know how to get this people involved?
I think they would be able to help up alot with this bug

Chris Halse Rogers https://launchpad.net/~raof
Alberto Milone https://launchpad.net/~albertomilone
Bryce Harrington https://launchpad.net/~bryce

Daniel P. Brown (danbrown) wrote :

@Alejandro: The confusion is my fault, in not keeping which was which organized in my brain while replying. Sorry, when I posted it on OIDK, it was because - though I had gotten the mouse issue fixed - Skype would crash.

I patched other things as I found them, but the typo was causing it to crash with Skype and some other programs. The typo had nothing to do with the mouse being stuck, I think that was one of the math issues. The biggest problem is that I didn't take notes. Honestly, as selfish as it sounds, I just wanted to fix my own system. I was so completely fed up with it freezing on me at least once every day, and none of the other distros seemed to do what I needed and work stably with my triple-head setup. I even contemplated either dropping one monitor or switching to Windows until a fix was made. I had never done it with the intent to put the fixes out in public, but it worked on two other machines with my employees, so I put it up. If others use it and it works, great. If not, here's hoping an official fix is somewhere around the corner soon.

markus (sroccaro) wrote :

Forgot to mention was using the:
"Separate X screen" configuration without Xinerama.
And this was also occurring to me.

After endless frustrations I blindly trusted post #29 and it doesn't happed anymore.

Alejandro Cuervo (a-cuervo) wrote :

This is still present in 10.10 and 11.04.

Has anyone found a solution?

unfortunately post #29 is not a solution, not because is not trusted, but because no explanation is given on what was patched.
Also the patched packages and NVIDIA drivers provided in post #29 used are getting outdated.

Pithikos (manossef) wrote :

Same problem here. Happened to me on both Ubuntu Lucid and now even on Natty. I have uploaded a video here with the issue: http://www.youtube.com/watch?v=pacgICWaA7k

I don't use xinerama. I use the seperate x servers option:
Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 1280 0
    Screen 1 "Screen1" LeftOf "Screen0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
EndSection

My graphic card is nVidia 8800GT and I run Ubuntu 64bit. This has happened while I was upgrading my Lucid distro to Maverick(probably firefox and maybe other apps were open, though no skype or google earth as mentioned in some cases). It generally happens at random points. In the video it happens while I load a game and move my cursor from the right monitor to the left. Hitting CTRL+ALT+F1 or any other combination does nothing. The whole system freezes and a shutdown from thebutton on the case is needed.

Superkuh (superkuh) wrote :

This happens to me every few days too. I'm on Ubuntu Lucid 64bit with a Geforce 8400 GS with recommended proprietary drivers running two monitors. My keyboard inputs do not respond when this freeze happens. I tried the 'RightOf' change as suggested in a few comments but upon continuation of crashes I restored the old config.

Dolph Mathews (dolph) wrote :

Running Xinerama on 10.04.3 with triple monitors across two GPU's... I can reproduce this bug on demand within seconds of a fresh boot by simply dragging a selection box on the desktop up and down the seam between either pair of monitors (0 & 1 or 1 & 2).

During normal workday use, this bug renders my entire system unresponsive several times per day.

Richard Hansen (rhansen) wrote :

I am also experiencing this bug on natty, but I am NOT using Xinerama. At least two other reporters are also not using Xinerama, so I am changing the title.

summary: - mouse stuck between screens with xinerama
+ mouse stuck jumping between screens
Peter Jakobi (jakobi) wrote :

I'm not entirely certain if this was the actual fix to this multi-head issue for me
(nvidia, twinview, 2nd head on the right rotated and panning, nvidia propritary driver, lucid),
as this was a quite a while ago.

However the most significant changes I did back then, was switching to the
xorg-edgers-ppa and ubuntu-x-swat-x-updates ppas and updating *all* apps.

I'm currently using:
xserver-xorg-core 2:1.8.2+git20100705+server-1.8
nvidia-current 290.10-0ubuntu1~lucid~xup1

HTH
Peter

Hugh Whinfrey (hrw-h) wrote :

My system has 2 graphics cards and 3 screens. The cursor gets stuck between screens (either pair) several times a day. It only started happening after I upgraded to Lucid. It is beyond annoying to have to reboot the system several times a day. I don't know what they did, but I can't believe that the Ubuntu product is prepared to screw all it's users with multiple screen systems like this - hello - this deserves a "critical" status and a fix pronto. It renders the system so dysfunctional that there is no point in investing any more of my time in this fork of Linux. And I liked Ubuntu and was recommending it to folks. That's not possible any more.

The problem can be reduced by not loitering with your mouse at the divide between screens. But the minute you do - bam! Your system halts. It is unacceptable that this bug has no evident priority attached to it.

I'm also running another system with 2 cards and 5 screens. It's still on 9.10 and works fine. There is no way it is going to be upgraded until this bug is fixed.

After trying to no avail to fix this critical issue for 3 versions I had to
abandon Ubuntu.
I fresh installed the latest LMDE AND the problem disappeared.
UBUNTU 11.10 can't even handle two screens gracefully much less three

AX
sent from mobile

dan_linder (dan-linder) wrote :

On Tue, Jan 31, 2012 at 07:18, Hugh Whinfrey <email address hidden> wrote:
> My system has 2 graphics cards and 3 screens. The cursor gets stuck
> between screens (either pair) several times a day. It only started
> happening after I upgraded to Lucid. It is beyond annoying to have to
> reboot the system several times a day. I don't know what they did, but I
...
> I'm also running another system with 2 cards and 5 screens. It's still
> on 9.10 and works fine. There is no way it is going to be upgraded until
> this bug is fixed.

For what it's worth, I too was having this same bug bite me multiple
times per day on my primary workstation. My setup is fairly common
(dual head NVidia), but I found two things that caused the frequency
of the bug to occur:
 * Using VMWare workstation in full-screen (single monitor)
 * Using "Synergy" (http://synergy-foss.org/)
If I kept my VMWare screens less than full-screen, and didn't use
Synergy at all, I found my rate of "stuck mouse" problems went down to
about 2/day (down from 8+/day - almost hourly).

The fix that was mentioned in post #36:
    https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/570151/comments/36
...was ultimately the resolution for me.

This patch was added to the Maverick (10.10) release of Ubuntu, so I'd
suggest you try upgrading your system since you stated you're on
Oneric (9.10).

If you're not comfortable with that upgrade, you might be able to
upgrade just the X11 components and see if that resolves your issue.
But that upgrade might introduce different bugs and then you're in a
bad spot.

As always, backup your system before doing either upgrade route.

Dan

--
***************** ************* *********** ******* ***** *** **
"Quis custodiet ipsos custodes?"
    (Who can watch the watchmen?)
    -- from the Satires of Juvenal
"I do not fear computers, I fear the lack of them."
    -- Isaac Asimov (Author)
** *** ***** ******* *********** ************* *****************

Richard Hansen (rhansen) wrote :

@dan-linder: I'm running Natty and I'm having the problem so I doubt upgrading to Maverick will help.

Richard Hansen (rhansen) wrote :

I installed the packages from the xorg-edgers PPA (<https://launchpad.net/~xorg-edgers/+archive/ppa>) on my Natty system a little over a week ago. I haven't seen the problem since. I believe the version of xorg-server in the PPA is very similar to the version in Oneiric, so it's quite possible the bug is fixed in Oneiric.

Can someone test Oneiric and report back?

Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
dan_linder (dan-linder) wrote :

I've been running Oneiric since December use it as primary workstation
weekdays, two NVidia cards driving three screens and I haven't had the
"stuck" mouse issue. (Though I had applied the PPA version on my
previous workstation so the problem has been a distant memory for me
for quite a while...)

I'll try to re-configure Synergy this weekend, Synergy was the program
that seemed to hang my system the most.

Dan

On Thu, Feb 9, 2012 at 09:23, a7x <email address hidden> wrote:
> I installed the packages from the xorg-edgers PPA
> (<https://launchpad.net/~xorg-edgers/+archive/ppa>) on my Natty system a
> little over a week ago.  I haven't seen the problem since.  I believe
> the version of xorg-server in the PPA is very similar to the version in
> Oneiric, so it's quite possible the bug is fixed in Oneiric.
>
> Can someone test Oneiric and report back?
>
> ** Changed in: xorg-server (Ubuntu)
>       Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/570151
>
> Title:
>  mouse stuck jumping between screens
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/570151/+subscriptions

--
***************** ************* *********** ******* ***** *** **
"Quis custodiet ipsos custodes?"
    (Who can watch the watchmen?)
    -- from the Satires of Juvenal
"I do not fear computers, I fear the lack of them."
    -- Isaac Asimov (Author)
** *** ***** ******* *********** ************* *****************

Bill Hallahan (bill-hallahan) wrote :

I also have repeatedly encountered this issue where the cursor gets stuck rapidly and repeatedly bouncing between my second and third monitor. I am running Ubuntu Linux 10.04 32-bit with the latest updates and the latest driver for my two NVidia GeForce GT430 graphics cards. I am running three monitors. When I first experienced this bug, my mouse and keyboard did not auto-detect the appropriate driver, now they do, and the bug still occurs.

This happens on average about once a week. I have had it happen three times in a day. I have never gone more than 3 weeks without this happening. I have lost work because of this. It's extremely annoying - and the issue is apparently

This is a serious issue as the only exit strategy I have found is to reboot the system. The system is effectively hung, even if technically it's not a hang. I can telnet into my system to reboot it, although one time I couldn't even do that!

I have found not tenable solution above. For one thing, I am running 32-bit Linux, so Dan Brown's solution wouldn't be satisfactory even if it was trusted software.

I have synergy installed, but it is not running.

Other people where I work are also experiencing this bug.

Ronaldo Chan (loloski-b) wrote :

Yes, I was affected with this bug two, can someone confirm is this has been fixed on oneiric ?, this happen to us frequently and sadly no one from ubuntu giving love from this bug.

My Setup:

Onboard:
Integrated Graphics Chipset: Intel(R) 965G (VGA)
PCI Dual head (one VGA and one DVI):
NVIDIA GPU GeForce 6600 (NV43) at PCI:1:0:0 (GPU-0)

Three monitors of 3 different sizes (what I could scrounge up at work)

Left Monitor is using the onboard Intel
Middle Monitor is using the VGA on the GeForce
Right Monitor is using the DVI with a VGA converter on the GeForce

Section "ServerLayout"
        Identifier "Manual Config"
        Screen 0 "Screen-Optiquest" 1280 0
        Screen 1 "Screen-ViewSonic" 2960 180
        Screen 2 "Screen-Acer" 0 60
        InputDevice "Mouse0" "CorePointer"
        InputDevice "Keyboard0" "CoreKeyboard"
        Option "Xinerama" "true"
EndSection

The reason for my crazy layout:
I want only the middle monitor to have the panel/toolbar, which is why I'm using Xinerama and Screen 0 is my middle monitor.
I'm not using Twinview, because my resolutions are different on each monitor.

I have found that the mouse getting stuck usually happens when I am waiting for a Window to render. This is mostly when a program is running in Wine or if I am waiting for Firefox to load a video or a flash based picture gallery AND when I move my mouse across screens. If I wait until the window is fully rendered to move my mouse, the mouse does not get stuck. I hope this helps.

I wish this issue would get the attention it needs. 54 comments, 24 (known) people affected, a Google search turns up many other forum posts with the same unresolved issue, multiple affected OSes, absolutely no workaround...this list goes on. This is a very frustrating issue. The reason for having multiple monitors is because it helps us be more productive. It defeats the purpose of being productive when my system locks up 2, 3, 4+ times a day, losing all my unsaved changes, killing any running processes, and having to wait for my system to reboot...just my 2 cents.

Richard Hansen (rhansen) wrote :

@Dan Schaefer: Which version of Ubuntu are you running? I'm running Natty and haven't had this problem since I upgraded to a version of xorg-server similar to the version used in Oneiric (from the xorg-edgers PPA).

@a7x: I guess I forgot that important piece of information. I'm reluctant to upgrade because I've spent so much time configuring 10.04 that I don't want to spend the time to configure the upgrade if it inevitably breaks. Here are my versions.

OS: Ubuntu 10.04 LTS i686
Kernel (currently): 2.6.32-40-generic-pae
xserver-xorg: 1:7.5+5ubunutu1.1
xserver-xorg-core: 2:1.7.6-2ubuntu7.10

Let me know if you would like more info.

FWIW, I haven't seen the issue in a couple days. This is after I installed a Windows XP VM, and now I run my "used to be wine" app as a Windows app in the VM instead. The app is Navicat. Not sure if the issue is because of Navicat or Wine.

This just happened last night to my Lucid 64 ATI, dual monitor system for the 1st time. And it happened again a few minutes ago.

Given that this system has been running Lucid with these two monitors for nearly a couple years without this problem, I vote for a very, very recent update.

Looking at Synaptic | File | History says the only suspicious looking update (on the 13th) is a new linux image, 2.6.32-41. The rest of the updates look like programs that would not be involved in low level stuff.

Since this problem pretty much freezes the system, does anyone know of a better way to recover than the big red button? (By way of ssh, that is.)

dan_linder (dan-linder) wrote :

When it was happening to me, I believe an alternative was to login via SSH
and kill the X11 desktop session (including the display driver). In my
case it was usually quicker to login and just issue a reboot command.

FWIW, after getting the latest NVidia video driver for my three-screen
system and not running "synergy", I haven't had the issue in a long time.
 But, I'm pretty aggressive about keeping updated - I switched to 12.04-x64
about two weeks after release, previous releases were similar.

Dan

On Mon, Jun 18, 2012 at 12:59 AM, Alex Robinson
<email address hidden>wrote:

> This just happened last night to my Lucid 64 ATI, dual monitor system
> for the 1st time. And it happened again a few minutes ago.
>
> Given that this system has been running Lucid with these two monitors
> for nearly a couple years without this problem, I vote for a very, very
> recent update.
>
> Looking at Synaptic | File | History says the only suspicious looking
> update (on the 13th) is a new linux image, 2.6.32-41. The rest of the
> updates look like programs that would not be involved in low level
> stuff.
>
> Since this problem pretty much freezes the system, does anyone know of a
> better way to recover than the big red button? (By way of ssh, that is.)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/570151
>
> Title:
> mouse stuck jumping between screens
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/570151/+subscriptions
>

--
***************** ************* *********** ******* ***** *** **
"Quis custodiet ipsos custodes?"
    (Who can watch the watchmen?)
    -- from the Satires of Juvenal
"I do not fear computers, I fear the lack of them."
    -- Isaac Asimov (Author)
** *** ***** ******* *********** ************* *****************

Gl Solaria (glsolaria) wrote :

I have this problem happening on a number of multi-screen machines with subtly different hardware (some i386, some amd64). Most are running with at least 3 monitors and have 2 nvidia cards but one has matrox cards. I am running some machines on 10.04.4 but some are running 10.04.2 and I am using the proprietary graphics card drivers with various versions of the drivers. All multi-screen machines have encountered the problem at some stage in the last few months.

The problem happens intermittently but, when it does, I sometimes cannot establish a remote ssh session to kill the out of control Xorg. Mostly the machine needs a hard reboot to regain control. Unfortunately, because of other proprietary software I am running, upgrading beyond 10.04 is not an option.

I did an investigation and tracked the problem down to a known freedesktop.org bug (https://bugs.freedesktop.org/show_bug.cgi?id=24986). I downloaded the Ubuntu source for xorg-server (1.7.6-2ubuntu7.11 which is associated with the latest 10.04.4 updates) and noticed that 2 of the 3 patches were not applied. I suspect the patch https://bugs.freedesktop.org/attachment.cgi?id=33908 fixes this problem. So I patched the source and applied the other Xinerama patch associated with the bug that was also missing (https://bugs.freedesktop.org/attachment.cgi?id=33939). Since applying the patches, I have not been able to reproduce the problem even on the one machine that could reliably produce the bug before applying the patches.

I have created a PPA based on the xorg-server 1.7.6-2ubuntu7.11 for 10.04.4 and simply applied the 2 missing patches from https://bugs.freedesktop.org/show_bug.cgi?id=24986. If anyone is interested, it can be found on https://launchpad.net/~glsolaria/+archive/ppa .

Since 10.04 is still LTS, and this problem is known to require a hard reboot to regain control of the machine, is there any chance these patches can be applied to 10.04? If you look at the patch https://bugs.freedesktop.org/attachment.cgi?id=33908, it gives a good description of the problem. Based on my naive reading of the patch, this bug can happen on any multi-monitor 10.04 system when the mouse pointer is moved across screens but it may be subject to a race condition thereby explaining the intermittent nature of this problem.

I'm glad someone finally found a *possible* solution to this, for a lack of a better word, annoying issue. This is especially annoying when having to ssh into the machine to 1) shutdown 2 VMs running, 2) attempt to kill any programs that may cause issues if crashed and 3) finally reboot the machine.

Let's get this fixed!!! ...please. I look forward to the implemented solution.

donquixote (lemon-head-bw) wrote :

I have this with _two_ monitors, instead of three.
The pointer jumps between the two, and the entire system becomes unresponsive. I can't do any Ctrl+Alt+1 or Ctrl+Alt+Del or similar, I have to hard-reboot.

Andrew Kohlsmith (akohlsmith) wrote :

A similar issue is happening with 12.10 x86-64 and the nVidia 304.43 driver (installed from Ubuntu packages):

My setup:
two GeForce 8400GS PCIex16 cards. The first card (PCI ID 3:0:0) has two Samsung SyncMaster 2343s connected. They are set up as a vertical TwinView. The second card (PCI ID 4:0:0) has a single Dell monitor attached. Xinerama is NOT enabled.

The monitors are arranged in a "backward" L. The two Samsungs are on the right as Screen 0, stacked vertically, and the Dell is on the left as Screen 1.

I can move the mouse between the two Samsungs without issue, and I can move from the Samsungs to the Dell. However once I am on the Dell, I cannot move back to the Samsungs. As I move the mouse to the right to get back to the Samsungs the mouse will "wrap" to the left side of the Dell instead of to the left side of the Samsungs. It will do this every time I approach the right side of the Dell.

If I swap the order of the monitors in xorg.conf so that the Dell is on the right side of the Samsungs instead of the left, then the issue occurs on the Samsung monitors; when I approach the right side of the Samsung monitors, the mouse wraps to the left side of the Samsung monitors instead of going to the left side of the Dell monitor.

This occurs with any dm (tried, lightdm, gdm, kdm and lxdm), and occurs at the login screen as well. It's entirely reproducible.

nvidia-current 304.51.really.304.43-0ubuntu1
xorg 1:7.7+1ubuntu4
xserver-xorg 1:7.7+1ubuntu4
xserver-xorg-core 2:1.13.0-0ubuntu6

Section "ServerLayout"
    Identifier "Layout0"

# the Samsung monitors on the right, the Dell on the left:
    Screen 0 "Screen0" 1280 0
    Screen 1 "Screen1" 0 0

# to move the Dell to the right of the Samsung monitors, use the following:
# Screen 0 "Screen0" 0
# Screen 1 "Screen1" 2048 0

    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "true"
    Option "TwinViewOrientation" "Below"
    Option "TwinViewXineramaInfoOrder" "CRT-0, CRT-1"
    Option "nvidiaXineramaInfoOrder" "CRT-1"
    Option "metamodes" "CRT-0: nvidia-auto-select, CRT-1: nvidia-auto-select"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device "Device1"
    Monitor "Monitor1"
    DefaultDepth 24
    Option "TwinView" "false"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

Andrew Kohlsmith (akohlsmith) wrote :

I should add that the only way to get the mouse back on the other monitors is to restart the DM. I have tried using xdotool to move between the screens but while the mouse x/y changes as commanded, the mouse stays stuck on the wrong screen.

Andrew Kohlsmith (akohlsmith) wrote :

I have also tried a dozen varieties of absolute offsets, LeftOf, RightOf, screen ordering and so on... it's very consistently wrong. :-)

I want to note that I have not experienced this issue in awhile. That could be because of one or all of these things:
1) The problem has been solved in the software (unlikely)
2) I have not been using a Virtual Machine (could be tied to #3)
3) I have noticed that my memory usage is relatively low lately (with both actually memory and cache added together). This tells me that it may have been a memory issue making something crash due to the lack of available memory.

Richard Hansen (rhansen) wrote :

@andrew: I may be wrong, but I think you are experiencing a different bug. Does your mouse cursor behave like the video in comment #15?

Nobody has reported seeing this bug since Oneiric, and it went away for me when I upgraded my Natty X server to the version used in Oneiric. So, I believe this bug was fixed in Oneiric. If you are experiencing this exact same bug, that's unfortunate and surprising news.

Andrew Kohlsmith (akohlsmith) wrote :

My particular occurrence of this bug has nothing to do with virtual machines, it seems to be an X server or nVidia driver issue, since it even occurs at the login screen, and with any dm (lxdm, gdm, lightdm, kdm...). My mouse does not bounce between the two screens as in the videos, it "wraps around" the screen instead of going back over to the screen it came from.

The reason I think this is a similar bug is because it seems to be related to the nVidia driver, a multihead setup and problems going between screens. My particular machine has 24GB of RAM but I don't see any unusual memory usage when the mouse gets "stuck" in the screen.

Richard Hansen (rhansen) wrote :

@andrew: I'm certain you are experiencing a different bug -- you should open a new bug report. This bug is not limited to nVidia (at least two people here have ATI/AMD video cards, myself included), wrapping around was never a symptom, and this bug was fixed in Oneiric.

Changed in xorg-server (Ubuntu):
status: Incomplete → Fix Released
Richard Hansen (rhansen) wrote :

Since nobody has reported seeing this bug since Oneiric, and now that Natty has reached end-of-life, I'm closing this as fixed.

I beg to differ on the "fixed in Oneiric". I am seeing the issue in Precise Penguin on another machine of mine. Although the behavior is not exactly the same, it is very similar.

The Precise Penguin machine is setup with a Windows XP Virtual Machine using Virtualbox and also has dual monitors. The issue occurs when multiple programs are open, namely Powerpoint and GoToMeeting. It almost always occurs when the user moves a window from one monitor to the next. The mouse blinks rapidly, but is not "stuck". However, it is very difficult to see and control. When this issue occurs, Xorg is spiked.

To resolve the issue, I use a remote desktop client from another computer to access the Virtual Machine (Windows XP). I close all programs she has open. I don't have any issues seeing or controlling the mouse from the remote session. Once I have closed all programs, she is able to see and control the mouse as normal. I have her shut down and restart both the VM and the physical box.

Given the issues I am seeing, I would not consider this fixed in Oneric.

I also want to add to comment #71. The only program running on the physical Ubuntu machine IS VirtualBox.

Richard Hansen (rhansen) wrote :

@Dan: I believe you are experiencing a different but similar bug -- please open a new bug report. (Even if it is the same bug, it is likely caused by a regression and should thus have a new bug report. But either way, this bug is marked as fixed and will therefore be ignored by Ubuntu developers. So no matter what, your best chance of getting the issue resolved is to open a new bug report.)

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.