Ubuntu

graphics corruption opening windows with glx 1.4 (ok with glx 1.2)

Reported by Paul Coleman on 2010-04-18
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: xorg

The first updates after beta 2 caused graphics corruption when redrawing screen.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
Architecture: amd64
Date: Sun Apr 18 08:07:05 2010
DkmsStatus: virtualbox-ose, 3.1.6, 2.6.32-21-generic, x86_64: installed
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Alpha amd64 (20091017)
Lsusb:
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic root=UUID=72165f7a-d46d-4c38-8c0b-ab0c5aa873aa ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 04/25/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: RS480-M
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd04/25/2006:svn:pn:pvr:rvn:rnRS480-M:rvr:cvn:ct3:cvr:
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-21-generic

Paul Coleman (pdcoleman) wrote :
Paul Coleman (pdcoleman) wrote :

Start kernel with nomodeset and graphics corruption stops but then no video in totem except for full screen.

Paul Coleman (pdcoleman) wrote :

Each time there is corruption dmesg has this entry.
[ 3635.792517] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation -12!

Bryce Harrington (bryce) on 2010-04-19
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) on 2010-04-20
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

I notice you have virtualbox-ose installed, which brings in its own video drivers. Can you try again with that removed?

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Paul Coleman (pdcoleman) wrote :

Removing virtualbox-ose did not help. Downgrading to GLX version: 1.2 appears to fix it.

Bryce Harrington (bryce) on 2010-04-22
summary: - graphics corruption opening windows
+ graphics corruption opening windows with glx 1.4 (ok with glx 1.2)
Bryce Harrington (bryce) wrote :

Well, I think this helps justify the decision to revert the glx 1.4 changes. Seems it's just not stable enough. But this decision is going to be covered on another bug report.

Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Bryce Harrington (bryce) on 2010-04-23
affects: xserver-xorg-video-ati (Ubuntu) → xorg-server (Ubuntu)
Bryce Harrington (bryce) on 2010-04-23
Changed in xorg-server (Ubuntu Lucid):
status: Triaged → Fix Committed
Robert Hooker (sarvatt) wrote :

xorg-server (2:1.7.6-2ubuntu7) lucid; urgency=low

  * Drop 117_fix_crash_with_createglyphset.patch
    - Dupe of patch 110
  * Drop 03_fedora_glx_versioning.diff, 04_fedora_glx14-swrast.diff
    - These patches were brought in by Debian to provide glx 1.4 support
      which Fedora backported from xserver 1.8, however testing in
      Ubuntu showed they caused a crash when closing Clutter apps (#550218),
      and graphics corruption when opening windows. Dropping these patches
      returns us to GLX 1.2, which has been found to be stable; Debian has
      also dropped these two patches.
      (Fixes #565903).
  * Drop 114_dri2_make_sure_x_drawable_exists.patch
    - This was an early attempt by upstream which fixed the aforementioned
      Clutter crash, but which introduced a memory leak.
      (Fixes #565981)

Date: Thu, 22 Apr 2010 17:24:38 -0700
Changed-By: Bryce Harrington <bryce at ubuntu.com>

Changed in xorg-server (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers