video playback problem on external monitor

Bug #55646 reported by Mark Van den Borre on 2006-08-08
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xserver-xorg

If video (gstreamer, xine,...) playback on a laptop's external monitor is an important ubuntu use case, the following is an important bug.

On my 2005 iBook G4 (relevant lspci info below) and presumably quite a few other laptops, it would have been impossible for someone not intimately familiar with xorg internals to find out how to do video playback on an external monitor. A novice could never solve this problem.

* Xv overlay is needed for smooth video playback.
* Xv overlay can only be applied to one monitor at a time.
* The default Dapper xorg.conf gives the xv overlay to the the internal monitor.
* The default result was a black rectangle instead of video playback on the external monitor, but smooth playback on the internal monitor.

My stopgap solution:
* Install xvattr from universe.
* Move the xv overlay to the external monitor:
  $ xvattr -a XV_SWITCHCRT -v 1

I now have video playback working on the external monitor, and a black rectangle on the internal one.

The relevant lspci info for my iBook G4:
0000:00:10.0 VGA compatible controller: ATI Technologies Inc M9+ 5C63 [Radeon Mobility 9200 (AGP)] (rev 01)
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 PCI

John Steele Scott (toojays) wrote :

I can confirm the bug report and the workaround.

Changed in xorg:
status: Unconfirmed → Confirmed

Confirmed on ibm thinkpad T41
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 [Mobility FireGL 9000] (rev 02)

piccobello (piccobello) wrote :

Confirmed on a thinkpad X31, Kubuntu Gutsy:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY

ii xorg 1:7.2-5ubuntu13 X.Org X Window System
 ii xserver-xorg 1:7.2-5ubuntu13 the X.Org X server
 ii xserver-xorg-core 2:1.3.0.0.dfsg-12ubuntu8 X.Org X server -- core server
 ii xserver-xorg-video-all 1:7.2-5ubuntu13 the X.Org X server -- output driver metapackage
 ii xserver-xorg-video-ati 1:6.7.195-1ubuntu2 X.Org X server -- ATI display driver

but for me the suggested workaround gives an error, I have to use instead:

$ xvattr -a XV_CRTC -v 1

With Edgy, the external monitor would always work, and movies would show on both screens.
With Gutsy, it only works if I start X after plugging it in.

piccobello (piccobello) wrote :

more precisely:
-it used to work with Dapper;
-the driver in xorg.conf is ati, but radeon is loaded. From /var/log/Xorg.0.log:

(II) ATI: ATI driver wrapper (version 6.7.195) for chipsets: mach64, rage128, radeon
(II) Primary Device is: PCI 01:00:0
(II) Loading sub module "radeon"
(II) LoadModule: "radeon"
(II) Loading /usr/lib/xorg/modules/drivers//radeon_drv.so
(II) Module radeon: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 4.3.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 1.2

Timo Aaltonen (tjaalton) wrote :

Xv only works for one screen at a time.

Changed in xorg:
importance: Undecided → Low
piccobello (piccobello) wrote :

> Xv only works for one screen at a time

ok, but I did have video playback on both screen
in Dapper. Maybe it just means that I did not use
Xv at the time?

Flametrees (flametrees) wrote :

Piccobello,

Thank you. I'm a Linux NooB, and have installed ubuntu on my IBM Thinkpad T41 out of frustration with Vista where I was unable to get the External VGA port to work (it worked fine on Windows XP). My intention is to use the laptop as a HTPC, plugged directly into the TV via VGA cable & AMP plugged into the headphone jack.

I am using my Wireless LAN at home to access movies & music via a Windows PC located in another room.

I was able to clone my display with ubuntu simply by ensuring the TV is plugged into the Laptop's VGA port prior to booting the Laptop. The issue that I had was that Video playback would only play on the Laptop screen, with the LCD TV just showing a black box instead of video playback.

I have seen in a number of posts a suggested workaround (as discussed here) to type the following:

xvattr -a XV_SWITCHCRT -v 1

However doing so gave me the following errors:
andrew@andrew-laptop:~$ xvattr -a XV_SWITCHCRTC -v -1
Found Xv 2.2
X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 140 (XVideo)
  Minor opcode of failed request: 13 ()
  Serial number of failed request: 11
  Current serial number in output stream: 12

By typing xvattr -a XV_CRTC -v -1

My problem is solved. Admittedly (again as discussed above) the Laptop screen goes blank, but this doesn't bother me; as the intention is to watch Movies & TV Shows on the LCD TV. When finished, I just type:

 xvattr -a XV_CRTC -v 1

...to get the display back to the Laptop.

Thanks again.

Regards,
Andrew

Nikolaus Filus (nfilus) wrote :

I'm referencing to http://brainstorm.ubuntu.com/idea/206/ Improve dual-screen function

+ Please higher up the Importance
+ Please include xvattr in default install
+ Please integrate xvattr -a XV_CRTC into displayconfig (or whatever)

Blondielocks (ollie-shotton) wrote :

I need help:

Quote Flametrees:

"By typing xvattr -a XV_CRTC -v -1

My problem is solved. Admittedly (again as discussed above) the Laptop screen goes blank, but this doesn't bother me; as the intention is to watch Movies & TV Shows on the LCD TV. When finished, I just type:

 xvattr -a XV_CRTC -v 1"

I received the same error message when I tried:

 xvattr -a XV_SWITCHCRT -v 1

but for me the alternative:

xvattr -a XV_CRTC -v -1

 does not work either. Terminal says:

Found Xv 2.2 XV_CRTC set to -1

 but still shows videos on internal and not external monitor.

Any ideas?

Ollie

Blondielocks (ollie-shotton) wrote :

Just to confirm, I am using Ubuntu 9.04 (Jaunty Jackalope). Does this make any difference?

Ollie

Blondielocks (ollie-shotton) wrote :

Ok, I have sorted it. For me I had to do the commands the other way round:

xvattr -a XV_CRTC -v 1 switches to external monitor

while

xvattr -a XV_CRTC -v -1 switches to internal monitor

Thanks for your help Flametrees

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Mark,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 55646

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 55646 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/55646

Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
Mark Van den Borre (markvdb) wrote :

Alas, I don't have access to the original iBook G4 hardware anymore. My understanding of the current xorg stack is too limited to judge if this kind of user experience issue still exists on 10.04 or newer Ubuntu versions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions