Does not support Linux PCI domains

Bug #54880 reported by Ben Collins on 2006-08-02
8
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Unassigned

Bug Description

The topic of PCI domains seems to be recocurring on the xorg lists. Saw lots of discussion, lots of patches, and lots of procrastinating.

I have an OpenPower IBM PPC-64 server provided to Canonical/myself that needs PCI domain support.

I'm attaching a patch that I used. It's generic support, which means this also will fix sparc64 PCI domain issues aswell (in fact, the source of the patch shows that they tested it with an UltraSPARC E250).

Please provide this in edgy. Would be really nice if it were possible to provide in dapper, but not important.

Ben Collins (ben-collins) wrote :
Changed in xorg-server:
importance: Untriaged → High
status: Unconfirmed → Confirmed
Rodrigo Novo (rodarvus) wrote :

Ben,

I've uploaded a new version of xorg-server with a (different, hopefully more compreensive) patch for pci domains.

Could you please check if this update solves your problem?

Rodrigo Novo (rodarvus) wrote :

Just for reference, I've just uploaded an updated xorg-server package for Dapper, with the patch you provided. If at all possible, I'd be thankful if you could test it too.

On Fri, 2006-08-11 at 15:56 +0000, Rodrigo Novo wrote:
> Ben,
>
> I've uploaded a new version of xorg-server with a (different, hopefully
> more compreensive) patch for pci domains.
>
> Could you please check if this update solves your problem?

If you're talking about 1:7.0.22ubuntu7, then no, it doesn't work. It
only sees the first PCI domain during the scan.

Then again, I see no mention of the patch in this version.

Ben Collins (ben-collins) wrote :

On Fri, 2006-08-11 at 15:56 +0000, Rodrigo Novo wrote:
> Ben,
>
> I've uploaded a new version of xorg-server with a (different, hopefully
> more compreensive) patch for pci domains.

Scratch that, Xorg binary is in xserver-xorg-core, and it is version
1:1.1.1-0ubuntu5. I see the changelog mention, so I'm sure this is the
one you are talking about. It doesn't work though.

Emanuel Steen (kozz) wrote :

I downloaded the Dapper version of xserver-xorg-core (1.0.2-0ubuntu10.1) to my Edgy system and it worked for me. It has by the way always worked for me on my system since breezy and I seem to have my graphics card on an other pci domain. However, version 1:1.1.1-0ubuntu5 - 1:1.1.1-0ubuntu7 in Edgy do not work.

I have to install version 1:1.1.1-0ubuntu4 of xserver-xorg-core to be able to start X on my system :)

Unfortunately Ben's patch do not apply together with 011_fedora_pci_scan_fixes.patch. It applies to 1:1.1.1-0ubuntu7 if I remove 011_fedora_pci_scan_fixes.patch, but it takes a while to compile it. Can report back later weather it works or not.

Emanuel Steen (kozz) wrote :

I tried to disable 011_fedora_pci_scan_fixes.patch but instead add pci_domain.diff (the one Ben attached) but it didn't work for me on my machine. Must be some other change from 1:1.1.1-0ubuntu4 to 1:1.1.1-0ubuntu5 that stopped scanpci from finding all devices.

I also notified that 1:1.1.1-0ubuntu5 searches for devices in sysfs while 1:1.1.1-0ubuntu4 searches for devices in /proc. It seems like 011_fedora_pci_scan_fixes.patch modified that since my modified 1:1.1.1-0ubuntu7 version without 011_fedora_pci_scan_fixes.patch but without pci_domain.diff also searches in /proc but only in /proc/bus/pci/00 and not /proc/bus/pci/01.

Colin Watson (cjwatson) wrote :

I've approved Rodrigo's upload to dapper-updates.

Rodrigo Novo (rodarvus) wrote :

Unfortunately this patch breaks PCI detection for various users, and this patch had to be reverted.

We need to either fix the regresssion this patch created, or apply it only on platforms were PCI domains is used everywhere. (is this the case for either sparc or powerpc?)

According to https://bugs.freedesktop.org/show_bug.cgi?id=7248 there are now (ia64) patches in upstream (XOrg HEAD). Maybe these should be (back)ported to Ubuntu?

Ben Collins (ben-collins) wrote :

On Sun, 2006-12-17 at 13:23 +0000, Christian Neumair wrote:
> According to https://bugs.freedesktop.org/show_bug.cgi?id=7248 there are
> now (ia64) patches in upstream (XOrg HEAD). Maybe these should be
> (back)ported to Ubuntu?

But PPC is what I need.

As discussed in bug 61410 Matthias Hopf seems to have incorporated a patch series implementing domain support in XOrg GIT HEAD two months ago. This also included a linuxPciOpenFile() patchset, which at least seems to be the culprit for the lack of card detection.

didijeeeke (dieter-adant) wrote :

It still doesen't work on my sun ultra 80

The first pci domain is all i can see with feisty and worg 7.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers