xserver-xephyr doesn't support swedish/finnish keyboard layout

Bug #531872 reported by Elvis
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xephyr

On a Ubuntu Karmic desktop configured for a Swedish/Finnish keyboard layout, Xephyr doesn't handle combination keys with "AltGr". I cannot type '@' which is "AltGr+2" combination keys. Instead of '@', I get '2'.
I run Xephyr like that:
Xephyr :2 -host-cursor -screen 800x480x16 -dpi 96 -ac -kb

ProblemType: Bug
Architecture: i386
Date: Thu Mar 4 13:54:50 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/yelp
Package: yelp 2.28.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: yelp
Uname: Linux 2.6.31-19-generic i686

Revision history for this message
Elvis (foo6321) wrote :
Revision history for this message
Elvis (foo6321) wrote :
Bryce Harrington (bryce)
tags: added: karmic
Revision history for this message
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Elvis,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 531872

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 531872 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/531872

Changed in xorg-server (Ubuntu):
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Revision history for this message
Marcell Lengyel (miketkf) wrote :

I was trying to reproduce this in Lucid and this is how far I got.

Apparently Xephyr does not support -kb anymore, so I used this command:

Xephyr :2 -host-cursor -screen 800x480x16 -dpi 96 -ac -keybd evdev,,device=/dev/input/event4,xkbrules=xorg,xkbmodel=evdev,xkblayout=fi

then I got:

Failed to open evdev device /dev/input/event4

and sure enough, I can not input anything to Xephyr with the keyboard.
All files in /dev/input are owned by root and only root has read/write permissions. Google did not help with the error message either.

Revision history for this message
Bryce Harrington (bryce) wrote :

[Resetting to incomplete since we need a response from the original reporter on this].

Changed in xorg-server (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Revision history for this message
Elvis (foo6321) wrote :

In Lucid, Finnish keyboard layout is well supported, if I run Xephyr like:
Xephyr :2 -host-cursor -screen 800x480x16 -dpi 96 -ac -keybd ephyr,,,xkbmodel=evdev,xkblayout=fi

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for xorg-server (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers