nv driver crashing with segmentation fault in libpthread.so.0

Bug #494627 reported by Brad Figg on 2009-12-09
112
This bug affects 16 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-nv

This system had started out as a Karmic install and then was upgraded to Lucid. Since then I've been doing daily dist-upgrades without issue. After a dist-upgrade on 11/08/2009 I started encountering this issue.

ProblemType: Bug
Architecture: amd64
Date: Wed Dec 9 09:49:37 2009
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027.1)
MachineType: Dell Inc. XPS M1530
Package: xserver-xorg-video-nv 1:2.1.15-1ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-7-generic root=UUID=1fbb3072-585e-4863-a7b8-abaa52d2f82e ro single
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-7.10-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5~3ubuntu2
 libgl1-mesa-glx 7.6.1~rc2-1ubuntu1
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu2
SourcePackage: xserver-xorg-video-nv
Tags: lucid
Uname: Linux 2.6.32-7-generic x86_64
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
Xrandr: Error: command ['xrandr', '--verbose'] failed with exit code 1: Can't open display
dmi.bios.date: 07/14/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0D501F
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd07/14/2008:svnDellInc.:pnXPSM1530:pvr:rvnDellInc.:rn0D501F:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1530
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
glxinfo: Error: command ['glxinfo'] failed with exit code 255: Error: unable to open display
setxkbmap: Error: command ['setxkbmap', '-print'] failed with exit code 255: Cannot open display "default display"
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.32-7-generic
xdpyinfo: Error: command ['xdpyinfo'] failed with exit code 1: xdpyinfo: unable to open display "".
xkbcomp:
 Error: command ['xkbcomp', ':0', '-w0', '-'] failed with exit code 1: Error: Cannot open display ":0"
                   Exiting

Brad Figg (brad-figg) wrote :
Steve Langasek (vorlon) on 2009-12-09
Changed in xserver-xorg-video-nv (Ubuntu Lucid):
importance: Undecided → Critical
importance: Critical → High
milestone: none → lucid-alpha-2
Bryce Harrington (bryce) on 2009-12-10
tags: added: crash
tags: added: iso-testing
Martin Pitt (pitti) on 2009-12-11
Changed in xserver-xorg-video-nv (Ubuntu Lucid):
assignee: nobody → Bryce Harrington (bryceharrington)
Christopher (soft-kristal) wrote :

Is there any way I can get rid of the nvidia driver manually? I should never have installed the driver after the update from Karmic to Lucid removed it.

I have no monitor now in Lucid but have access to the partition via other partitions.

caillean (caillean) wrote :

I changed the driver in /etc/X11/xorg.conf, which exists because the install of the nvidia-driver created it.
Instead of "Driver Nvidia" i wrote "Driver vesa" and it worked for me.

TinyInt64 (brainbug75) wrote :

Trying to use vesa, does not solve the issue for me.
Some holds true for failsafe using vesa.

TinyInt64 (brainbug75) wrote :

I am sorry, I don't know how to add multiple files?!

Lane Lester (llester) wrote :

I did clean installs with the alternate iso, and two separate installs produced the same result:

1. After install and first hard drive boot, let Synaptic do updates. Booting immediately afterward left me at a terminal login, no X.

2. After install and first hard drive boot, activate nVidia driver 185. Booting immediately afterward left me at a terminal login, no X.

I have a fairly new motherboard with an nVidia chipset. This means a non-nVidia driver gives me an incorrectly sized, incorrectly positioned desktop. It's possible to do an install, but that's about it.

Vadim Peretokin (vperetokin) wrote :

I can barely see ubiquity and then nothing appears.

Lucid livecd, 8600gt.

Seth Hikari (sethhikari) wrote :

Fails here in both upgrade and fresh install. Seg fault
Also on another note if I try to install nvidia-glx-185 or 190 synaptic wants to uninstall all of X witch is... counter productive really.
Should that be it's own bug. So stuck with VESA... no other option..

Hein van Dam (h-t-vandam) wrote :

It looks as if I have the same problem. Lucid Lynx worked fine up to kernel upgrade 2.6.32-6 and only low resolution with 2.6.32-7.
Reinstall older CD (kernel 2.6.32-4) gives the normal resolution for my system and identical to the one for Karmic Koala.

With a more recent CD again only low resolution.

I append the failsafeX file created by the live-CD.

TinyInt64 (brainbug75) wrote :

#8 raised a good question.
Is this a different bug, and has it been reported yet?

Even if I uninstall the xserver-xorg-video-nv package and use plain vesa, with or without xorg.conf, I do not get the xserver to start. I tried everything, no xserver. If the devs need more info, just let me know. I even tried newer glx drivers from sevenmachines.
A wild guess into the blue, there xserver cannot decide what driver to use?

PS: karmic running fine

Alberto Milone (albertomilone) wrote :

Upstream (which is NVIDIA) is aware of the problem with the "nv" driver.

The release notes of xf86-video-nv say that version 2.1.16 (we have 2.1.15 in Lucid) contains a fix to not crash on xserver 1.7 but the driver still doesn't work correctly with xserver 1.7 "because the server never calls the old-style colormap setup code".

http://lists.freedesktop.org/archives/xorg-announce/2009-December/001219.html

description: updated
Martin Pitt (pitti) wrote :

Great, so it seems we just need to update to the new version then. Thanks Alberto!

Changed in xserver-xorg-video-nv (Ubuntu Lucid):
status: New → In Progress
André Barmasse (barmassus) wrote :

I am not sure if this is exactly related to your problems, but maybe it can help other people to get the nvidia driver working with Lucid Lynx Alpha 1, although I am sure that the X.org/Nvidia problem will be solved with one of the next alpha versions.

I have just upgraded to Lucid Lynx Alpha 1. When I try to install nvidia-glx-185, nvidia-glx-173 or nvidia-glx-96 synaptic wants to remove the xserver completely. The installation of nvidia-glx-180 is possible but the driver does not work the next time you reboot. Neither does the nvidia-glx-195 driver form the PPA repository. By the way, my card is a GeForce Go 6200/6400.

Same issue when I go to the console, kill gdm and install a freshly downloaded nvidia driver (190 or 195). If then I restart gdm, the nvidia driver is working fine for the time the computer is running. After the next reboot the nvidia driver is not loaded.

I have detected a strange workaround. First, I have removed all nvidia related stuff, and all xserver-xorg-video- drivers (including xserver-xorg-video-all), leaving ONLY xserver-xorg-video-nv installed. Then I have switched to the console, killed gdm, and installed the beta driver NVIDIA-Linux-x86-195.22-pkg1.run. From now on, when I start or reboot, there is no gdm. But when I log in, and start gdm manually, the nvidia driver works like a charm every time.

Seth Hikari (sethhikari) wrote :

André Barmasse, this sounds like a work around... kinda for Bug #494166

André Barmasse (barmassus) wrote :

Hi Seth

Thanks for the hint. You are of course right, so I will take a look there.

By the way: after yesterday's xserver update gdm seems to work again, and startup correctly with the nvidia driver. Let's hope it does again after today's kernel update ...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-nv - 1:2.1.15-1ubuntu2

---------------
xserver-xorg-video-nv (1:2.1.15-1ubuntu2) lucid; urgency=low

  * debian/patches/110_do_not_crash_on_17.patch:
    - merge git fix for LP: #494627
      (from http://cgit.freedesktop.org/xorg/driver/xf86-video-nv/commit/?id=85638b2f0acc418aa77241dd123f7de76ea3ce8f)
 -- Michael Vogt <email address hidden> Tue, 05 Jan 2010 13:24:33 +0100

Changed in xserver-xorg-video-nv (Ubuntu Lucid):
status: In Progress → Fix Released
Michael Vogt (mvo) wrote :

Reopening, the crash is fixed with the patch but it turns out that the colors are all wrong (just as Aaron wrote in his mail). I don't really know why it worked well for me in my testing yesterday, but today the colors are all wrong.

I think the best fix is to revert my patch and fix it in the xserver itself, I attach a patch for this.

Changed in xserver-xorg-video-nv (Ubuntu Lucid):
status: Fix Released → In Progress
Michael Vogt (mvo) wrote :

This patch for xserver-core fixed the crash for me. The colors are also correct (when reverting the stub gamme_set back to NULL) because xorg uses the old-sytle colormap code in this case.

Brad Figg (brad-figg) wrote :

I just tried the live image for today and yes, the colors are really messed up.

Martin Pitt (pitti) wrote :

xserver-xorg-video-nv 1:2.1.15-1ubuntu3 reverted the previous patch, so moving to xorg-server. Bryce, could you please check and upload this? Thanks!

affects: xserver-xorg-video-nv (Ubuntu Lucid) → xorg-server (Ubuntu Lucid)
Bryce Harrington (bryce) wrote :

Looks like it's already queued up in git. It will go out with the next upload of xorg-server.

Changed in xorg-server (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.7.3.902-1ubuntu1

---------------
xorg-server (2:1.7.3.902-1ubuntu1) lucid; urgency=low

  [ Timo Aaltonen ]
  * Merge from Debian unstable.

  [ Michael Vogt ]
  * Add 101_nv-crash-fix.diff: Do not crash if gamma_set is NULL.
    (LP: #494627)

  [ Alberto Milone ]
  * Install libglx.so and libdri.so in /usr/lib/standard-x11 as X
    seems to prefer the file in /usr/lib/xorg/modules/extensions/standard/
    over links in /usr/lib/xorg/modules/extensions/.

xorg-server (2:1.7.3.902-1) unstable; urgency=low

  [ Timo Aaltonen ]
  * Run udevadm trigger on postinst, and depend on udev [linux-any].

  [ Julien Cristau ]
  * Add xserver-common dependency on x11-xkb-utils for xkbcomp.
  * Remove our copy of input_id, add Depends on new enough udev instead.
  * New upstream release.
  * Make xserver-common recommend xfonts-base, some clients don't work without
    those.
  * Upload to unstable.

xorg-server (2:1.7.3.901-1ubuntu5) lucid; urgency=low

  * Use alternatives to make it easier to switch between X11 and 3rd
    party modules.
  * Add link to /usr/lib/xvmcconfig-standard/XvMCConfig and use it
    for alternatives.
 -- Timo Aaltonen <email address hidden> Fri, 08 Jan 2010 14:21:15 +0200

Changed in xorg-server (Ubuntu Lucid):
status: Fix Committed → Fix Released
Josema (jmvalbuenap) wrote :

This bug isn't solved with this fix. I continue without is able to install the packages "nvidia-glx-96", "nvidia-glx-185", "nvidia-glx-173" and "nvidia-glx-180" that one finds in the repositories.

Changed in xorg-server (Ubuntu Lucid):
status: Fix Released → In Progress
Timo Aaltonen (tjaalton) wrote :

No that's a different bug, and _not_ related to this one. See bug 494166.

Changed in xorg-server (Ubuntu Lucid):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Josema,

can you please rephrase what you meant with "I continue without is able to install the packages nvidia-glx..."? Since this bug is fixed for other people, and you are not the original reporter, it's probably better to file a new report.

Eric B (ebischoff) wrote :

Confirmed here. AMD64, and strangely enough occurs only with high resolution and 2 screens.

Eric B (ebischoff) wrote :

As a matter of fact, only high resolution matters. I avoid it as long as I remain 1024x768 on both screens.

Bryce Harrington (bryce) on 2010-02-24
Changed in xorg-server (Ubuntu Lucid):
assignee: Bryce Harrington (bryceharrington) → nobody
agardella (fishsmoke) on 2010-03-14
Changed in xorg-server (Ubuntu Lucid):
status: Fix Released → Fix Committed
status: Fix Committed → Confirmed
Steve Langasek (vorlon) wrote :

As noted earlier by Martin, since this bug is fixed for other people, you should open a new bug report if you're still having issues.

Changed in xorg-server (Ubuntu Lucid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers