Xorg crashed with SIGSEGV

Bug #485460 reported by tunznath on 2009-11-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Medium
Unassigned

Bug Description

my desktop has also dissapeared and I cannot access >places > harddrives either?????

ProblemType: Crash
Architecture: i386
Date: Thu Nov 19 14:13:44 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/Xorg
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 003: ID 0846:6a00 NetGear, Inc. WG111v2 54 Mbps Wireless [RealTek RTL8187L]
 Bus 001 Device 002: ID 0951:1625 Kingston Technology
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Package: xserver-xorg-core 2:1.6.4-2ubuntu4
ProcCmdLine: root=UUID=06c0de35-8cd2-4fc6-9b7c-c34bb689308e ro quiet splash
ProcCmdline: /usr/bin/X :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-7AbJox/database -nolisten tcp
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SegvAnalysis:
 Segfault happened at: 0x8122aec: movzwl 0x12(%edx),%esi
 PC (0x08122aec) ok
 source "0x12(%edx)" (0x00000011) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: xorg-server
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? () from /usr/lib/xorg/modules/drivers//intel_drv.so
 ?? ()
Title: Xorg crashed with SIGSEGV
Uname: Linux 2.6.31-14-generic i686
UserGroups:

dmi.bios.date: 09/25/2001
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: 6.00 PG
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvr6.00PG:bd09/25/2001:svn:pn:pvr:cvn:ct3:cvr:
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic

tunznath (tunznath) wrote :

StacktraceTop:miSpriteComputeSaved (pDev=0x8e84044, pScreen=<value optimized out>)
miSpriteSaveUnderCursor (pDev=0x8e83f60, pScreen=0x8cfe428)
miSpriteBlockHandler (i=0, blockData=0x0,
I810BlockHandler (i=0, blockData=0x0, pTimeout=0xbf858dac,
AnimCurScreenBlockHandler (screenNum=0, blockData=0x0,

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Bryce Harrington (bryce) on 2009-11-20
tags: added: crash
Bryce Harrington (bryce) on 2009-12-05
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2009-12-14
visibility: private → public
Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi tunznath,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 485460

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 485460 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/485460

Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.