xvfb-run totally broken

Bug #481591 reported by Kees Cook on 2009-11-12
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Unassigned
Karmic
High
Unassigned
Lucid
High
Unassigned

Bug Description

xvfb-run fails to launch any more on karmic. Reverting the patch from 2:1.6.4-2ubuntu3 fixes the problem. This breaks any tool that uses xvfb-run during its build (like openjdk-6).

impact: tools needing xvfb-run will fail (e.g. openjdk-6 does not perform any testsuite runs)
addressed: refactored to correctly wait for xvfb execution.
patch: see attached
discussion: regression potential is low, since xvfb-run doesn't actually function in karmic.
TEST CASE: the follow command should report "0":
  xvfb-run -a -e /dev/null -s "-extension GLX" true; echo $?

ProblemType: Bug
Architecture: amd64
Date: Thu Nov 12 14:02:47 2009
DistroRelease: Ubuntu 10.04
Package: xvfb 2:1.6.4-2ubuntu4
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: xorg-server
Uname: Linux 2.6.31-14-generic x86_64

Kees Cook (kees) wrote :
Changed in xorg-server (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in xorg-server (Ubuntu Karmic):
status: New → Confirmed
importance: Undecided → High
tags: added: regression-potential
Kees Cook (kees) wrote :

$ xvfb-run -a -e /dev/stderr -s "-extension GLX" true
xauth: creating new authority file /tmp/xvfb-run.KG5sTU/Xauthority
[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/Type1, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi, removing from list!
$ echo $?
1

Expected:
$ xvfb-run -a -e /dev/stderr -s "-extension GLX" true
xauth: creating new authority file /tmp/xvfb-run.t1oX3v/Xauthority
[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi/:unscaled, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/Type1, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/100dpi, removing from list!
[dix] Could not init font path element /usr/share/fonts/X11/75dpi, removing from list!
$ echo $?
0

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.6.4-2ubuntu5

---------------
xorg-server (2:1.6.4-2ubuntu5) lucid; urgency=low

  * Rework xvfb-run patch to wait for server to come up before checking
    status (LP: #481591, Debian bug 521075).
 -- Kees Cook <email address hidden> Fri, 13 Nov 2009 16:15:36 -0800

Changed in xorg-server (Ubuntu Lucid):
status: Confirmed → Fix Released
Kees Cook (kees) wrote :
description: updated
Kees Cook (kees) wrote :

Since this is a build-dep for openjdk-6, I'll be putting it through the security-proposed build queue so that future openjdk-6 builds get xvfb-run.

Steve Beattie (sbeattie) on 2009-12-02
tags: added: karmic regression-release
removed: regression-potential
Steve Beattie (sbeattie) on 2009-12-02
Changed in xorg-server (Ubuntu Karmic):
status: Confirmed → Fix Committed
Steve Beattie (sbeattie) on 2009-12-02
tags: added: verification-needed
Sergei Ianovich (ynvich-gmail) wrote :

I got the package for lucid from pushlog [1], installed with a few libs from lucid repo. xvfb-run now works. Waiting for karmic package.

1. https://launchpad.net/ubuntu/+archive/primary/+sourcepub/867752/+listing-archive-extra

Martin Pitt (pitti) wrote :

Sergey, any chance to test the package in karmic-proposed?

Sergei Ianovich (ynvich-gmail) wrote :

Martin, I can confirm this package works:
xvfb/karmic-proposed uptodate 2:1.6.4-2ubuntu4.1

Thank you for a pointer.

Martin Pitt (pitti) on 2010-01-20
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.6.4-2ubuntu4.1

---------------
xorg-server (2:1.6.4-2ubuntu4.1) karmic-proposed; urgency=low

  * Rework xvfb-run patch to wait for server to come up before checking
    status (LP: #481591, Debian bug 521075). Built in security queue
    so that future security-built packages that require xvfb-run will
    not fail.
 -- Kees Cook <email address hidden> Sat, 14 Nov 2009 09:25:06 -0800

Changed in xorg-server (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers