FFe for updating xorg-server to 1.6.4-2

Bug #447010 reported by Bryce Harrington on 2009-10-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Wishlist
Unassigned

Bug Description

[Request]
Update of xorg-server from version 1.6.3-xx to 1.6.4-2

[Justification]
1.6.4 is a bug-fix release that provide ~20 patches, fixing a number of critical issues.

5 of the 20 patches are ones we already carry, having cherrypicked them earlier.

4 more of the 20 patches solve severe issues (X crashes or performance problems). One of these four patches will fix launchpad bug 445491.

5 more address lower priority issues but look quite safe.

The remainder are probably irrelevant to us (version number changes, fixes for warnings, dropping dead code, etc.) The patch that drops dead code I would exclude since it changes a lot of code for no tangible benefit to us, the others look entirely harmless. The one that drops dead code already has been shown to cause one regression (a fix is included) so far, which is yet another reason for us to exclude it.

[Testing]
1.6.4-2 has only recently been released so has not received extensive testing, however an RC of it has been in xorg-edgers several days so presumably has gotten some testing there. The exact package we're looking at including is currently in Debian so has received some testing there.

[Contingency]
Due to the small number of changes involved in this update, if there are regressions it will be pretty straightforward to revert individual patches.

Alternatively, if desired it would not be hard to just cherrypick each of the desired fixes and apply them on our existing 1.6.3 xserver. But I am filing this FFe since I suspect by the time I'm done cherrypicking I'll have pretty much pulled in all of 1.6.4-2 anyway...

Related branches

Bryce Harrington (bryce) on 2009-10-09
Changed in xorg-server (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
summary: - FFe for updating xorg-server to 1.6.5
+ FFe for updating xorg-server to 1.6.4-2
description: updated
Bryce Harrington (bryce) wrote :

This spreadsheet shows a breakdown of all the patches I was using to organize my thoughts - what gets kept, what gets dropped, and the review commentary on each of the upstream changes. Apologies if it looks messy, I'll be happy to answer any questions.

Bryce Harrington (bryce) wrote :

Btw, the patch I referred to "just dropping dead code" which I proposed omitting, is discussed in more detail here:

http://article.gmane.org/gmane.comp.freedesktop.xorg.devel/1945

In short, the motivation for dropping the dead code is because it exposes a section of server memory to clients to mmap, which is not safe. In addition, the code has been non-functional for the FOSS drivers for about two years.

Martin Pitt (pitti) wrote :

Thanks for the .ods document, well prepared. I agree that this looks appropriate, no new features, just bug fixing. Keeping the DGA bits for now sounds sensible, though, as long as we don't need which of the third-party apps still use it.

Approved.

Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package xorg-server - 2:1.6.4-2ubuntu1

---------------
xorg-server (2:1.6.4-2ubuntu1) karmic; urgency=low

  * Merge from Debian unstable. (LP: #447010)
    Remaining Ubuntu changes:
    - debian/control:
      + set Conflicts: xkb-data (<< 0.9), since xkb-path is
        different from previous releases
      + do not Conflict with xserver-xorg-video
      + xvfb Depends on xauth, xfonts-base
      + Set Maintainer to Ubuntu Core Developers
    - debian/rules:
      + build using -fno-stack-protector
      + --with-os-vendor=Ubuntu
    - debian/xserver-xorg-core.install:
      + Add ioport, pcitweak, scanpci scripts & man pages
    - debian/patches:
      + 101_fedora_xserver-1.3.0-document-fontpath-correctly.patch:
        Specify correct paths to fonts
      + 102_ubuntu_sharevts_load_cpu.patch:
        close console fd only when ShareVTs
      + 103_psb_auto.patch:
        Autodetect poulsbo devices (but use -vesa since -psb is broken)
      + 110_fedora_no_move_damage.patch:
        further aiglx support
      + 121_only_switch_vt_when_active.diff:
        Add a check to prevent the X server from changing the VT when killing
        GDM from the console.
      + 135_rethrow_signals.patch:
        When aborting, re-raise signals for apport
      + 140_quell_acpi_errmsgs.patch:
        Avoid generating extraneous warnings when acpi is missing
      + 153_make_dmx_compile.patch:
        Change xcalloc -> calloc, so that dmx compiles.
      + 156_exevents_copykeyclass_nullptrcheck.patch,
        157_check_null_modes.patch, 162_null_crtc_in_rotation.patch,
        166_nullptr_xinerama_keyrepeat.patch, 167_nullptr_xisbread.patch
        169_mipointer_nullptr_checks.patch,
        172_cwgetbackingpicture_nullptr_check.patch:
        Fix various segfaults in xserver by checking pointers for NULL
        values before dereferencing them.
      + 164_trap-aspect-ratios.patch:
        Correct monitor EDIDs that have misreported aspect ratios.
      + 165_man_xorg_conf_no_device_ident.patch
        Correct man page
      + 168_glibc_trace_to_stderr.patch:
        Report abort traces to stderr instead of terminal
      + 174_set_bg_pixmap_of_cow_to_none.patch:
        Set background pixmap of composite overlay window to no background
      + 177_animated_cursor_change_master.patch:
        Don't create animated cursors for slave devices
      + 180_fedora_no_synaptics_mouse_synthesis.patch:
        Don't synthesize a mouse section if a synaptics device is found
      + 181_fedora_log_proc_cmdline.patch:
        Dump /proc/cmdline in the log file too
      + 184_virtual_devices_autodetect.patch:
        Use vesa for qemu device, which is not supported by cirrus
      + 185_dix_badwindow.patch:
        Don't return BadMatch from GetProperty if window isn't actually a window
      + 186_autoconfig_geode.patch
        Perform autodetection correctly for various geode devices
  * Update 184_virtual_devices_autodetect.patch to only include inserting
    cirrus, since vbox is covered by the new fedora patch.
  * Drop patches already included upstream:
    - 187_lastdeviceeventtime-no-reset.patch
    - 178_glx_flush_cache.patch
  ...

Read more...

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers