radeon graphics mode and console does not start - xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Bug #441653 reported by jamey0824 on 2009-10-03
374
This bug affects 71 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Unassigned

Bug Description

Fatal Server Error: xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

symptoms: stuck at command prompt,
possible not starting any graphical mode nor console (stuck at the boot-splash blue screen)
and alt+ctrl+F1..F8 not able to switch to any text nor any graphical mode.
"vtch command just hangs"

It is possible (but not verified) that problem affects people that use kdm instead of gdm (since a change to kdm conf is the workaround)

example affected systems:
karmic fully updated AMD x64 drivers: fglrx for ati radeon 4350
lucid fully updated AMD x64 dual core, radeon 3000

error message: the /var/log/X.org.log will contain near end text:
  Fatal server error:
  xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

workaround:
   1. in file /etc/init/kdm.conf insert a "sleep 1" before the "exec kdm" line. - and then restart the machine fully. Use kdm instead of gdm (any work around for gdm? or is it needed?).
-or/and-
  1. stop all X (as root: stop gdm ; stop kdm ; killall X ; kill `pidof X` ; killall startx) also remove locks: /tmp/.X0-lock and possibly all : /tmp/.X?-lock and make sure they are not re-created (no X/kdm/gdm running)
  2. after editing the file /etc/init/kdm.conf as above, instead restarting entire system, use alt+SysRq+R alt+SysRq+K magic combo keys on keyboard to restore non-X keyboard, use alt+ctrl+F1..F8 to get the defunct X mod, click there option to restart X.

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 3 14:13:25 2009
DistroRelease: Ubuntu 9.10
MachineType: BIOSTAR Group TA790GX A2+
NonfreeKernelModules: fglrx
Package: xorg 1:7.4+3ubuntu5
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=accf1fa8-088d-41c7-9a3c-527b72bdd860 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu7
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
SourcePackage: xorg
Uname: Linux 2.6.31-11-generic x86_64
dmi.bios.date: 05/25/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080014
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: TA790GX A2+
dmi.board.vendor: BIOSTAR Group
dmi.chassis.asset.tag: None
dmi.chassis.type: 3
dmi.chassis.vendor: BIOSTAR Group
dmi.chassis.version: 6.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080014:bd05/25/2009:svnBIOSTARGroup:pnTA790GXA2+:pvr:rvnBIOSTARGroup:rnTA790GXA2+:rvr:cvnBIOSTARGroup:ct3:cvr6.0:
dmi.product.name: TA790GX A2+
dmi.sys.vendor: BIOSTAR Group
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-11-generic
xkbcomp:
 Error: command ['xkbcomp', ':0', '-w0', '-'] failed with exit code 1: No protocol specified
 Error: Cannot open display ":0"
                   Exiting

jamey0824 (jamesforyst) wrote :
Victor Vargas (kamus) wrote :

reassigned to package xserver-xorg-video-ati

affects: ubuntu → xserver-xorg-video-ati (Ubuntu)
jamey0824 (jamesforyst) wrote :

I installed kdm and have been using that for some time, sometimes i have to uninstall kdm and reinstall it to get system to boot, that hasen't worked in this case. Although i have just discovered if i manuelly launch kdm once i get to the prompt the system comes up. I have no idea what script , or launch directory normally calls kdm, but i am looking into it.

Bryce Harrington (bryce) on 2009-10-04
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
jamey0824 (jamesforyst) wrote :

Looking into this matter further i've manged to get the additional info
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.3.log" for additional information.

 ddxSigGiveUp: Closing log
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
Warning: Could not generate /etc/X11/xorg.conf.failsafe for vesa driver

jamey0824 (jamesforyst) wrote :

I am using a multiseat setup which has been working fairly well under karmic, although it seems the order you start your xorg servers seem to be an issure perhaps with the latest round of updates, causes some sort of race condition to occur. Because now when I change the order of the seats i am able to get them all up for a few seconds then it terminates with the seat with the console session with the above error. Note that strangely this behavior only is exibited on the main console( by that i mean the terminal that is showing the boot sequence.) When i change back with a factory original kdmrc, it still exibits this behavoir. Which i never had any problems with before.

Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi jamey0824,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 441653

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 441653 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/441653

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
u2ix (u2ix) wrote :

Hi, I can confirm this bug for lucid. Have this problem on my notebook.

tags: added: lucid
IRQ (apavelm) wrote :

I offen have this bug, since I upgraded to Lucid.
My notebook Acer Extensa 4220, RAM extended to 2 GB (video Intel GMA-X3100).
Using kubuntu.
2 times from 5, I have only black screen.

Armand Delcros (armand-delcros) wrote :

Hello I have the same frozen issue since i reinstall my aspire 5100 notebook with radeon Xpress 200M :

(--) PCI:*(0:1:5:0) 1002:5975:1025:009f ATI Technologies Inc RS482 [Radeon Xpress 200M] rev 0, Mem @ 0xc0000000/268435456, 0xb0100000/65536, I/O @ 0x00009000/256, BIOS @ 0x????????/131072

----
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.1.log" for additional information.

 ddxSigGiveUp: Closing log
-----

I tried to use gnome or fluxbox, the same problem appears.

jd65pl (jamie-dumbill) wrote :

I am having this problem too

uname -r
2.6.32-22-generic

Graphics card: Nvidia GT240
Driver: 195.36.24

Same here, fresh install of Ubuntu 10.04 GA on an Asus Eee PC 1005PE, Intel i915 Video.

Often the screen goes black after I see the Ubuntu logo and 5 red dots under it.

Sometimes I have a small cursor blinking in the upper left corner. All I can do is Ctrl-Alt-Delete. If I'm lucky the system comes up on next boot, sometimes I have to use the Recovery Console, log in and then issue "startx". If I then reboot the system it comes up as expected.

Kernel: 2.6.32-22-generic
VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller

Joshua Kwan (joshk) wrote :

This bug clearly has nothing to do with xserver-xorg-video-ati, since nVidia and Intel graphics users are reporting the problem as well. I'm chiming in to report that this seems to be affecting VMware installs as well, but only on Kubuntu. It sounds like some sort of race condition, but it hits very often on VMware, which may provide reliable timings for the race condition to occur.

h1repp (heinz-repp) wrote :

Same bug here: on Lucid (Ubuntu, not Kubuntu) with Xorg radeon driver and an older ATI Radeon 9250 card with two monitors in clone mode: it happened two times to me since upgrade from Hardy to Lucid, and every time the computer hung on boot but I was able to reboot with C-A-D.

/var/log/Xorg.1.log.old says:
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call
...
 ddxSigGiveUp: Closing log

So summarizing:
This happens with ATI cards with Xorg and fglrx drivers, with Nvidia and with Intel cards and even within VMware, so it has nothing to do with the driver, but it has something to do with the X-server.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
h1repp (heinz-repp) on 2010-05-19
affects: xserver-xorg-video-ati (Ubuntu) → xorg-server (Ubuntu)
h1repp (heinz-repp) on 2010-05-19
tags: removed: amd64 needs-retested-on-lucid-by-june
hector (mailbox-deandreis) wrote :

I've the same bug on different PC, but all with nvidia card
X don't start, at boot remain the kubuntu spash, on press ctrl-alt-canc, the system restart, and at the reboot (not every time) the X starts OK.
Sometime I need to staaart in recovery mode and reconfigure the graphic card.

IRQ (apavelm) wrote :

I install ubuntu on my 2nd laptop with NVIDIA card, bug still present

Steve Bailey (stevobailey) wrote :

I've had this problem on both Mythbuntu 9.10 and 10.4, though it is intermittent. I'm running a dell dimension 2400 (integrated intel graphics).

Klaus Layer (klaus-layer) wrote :

can confirm this error. Occurs once per day on Lenovo T60 ATI Technologies Inc Radeon Mobility X1400. The system freezes with random graphics on the screen

Klaus Layer (klaus-layer) wrote :

Xorg.0.log

fsanchez (fransan-met) wrote :

I have exactly the same problem. But it didn't started after a clean intallation of Kubuntu Lucid Lynx but some actualization.

I'm seeing VT_WAITACTIVE failed: Interrupted system call on a macbook 4,1 with kubuntu lucid.

When I then log into the box via ssh I see /sbin/getty running on ttys 1-6 and
/usr/bin/X :0 -br -once -config /etc/X11/xorg.conf.failsafe -logfile /var/log/Xorg.failsafe.log

chvt 1 (or chvt any-other-vt) just hangs.

Not sure where to look next.

Ralf Jung (ralfjung-e) wrote :

I do have the same problem on my HP Compaq 615 (graphics card: AMD HD 3200). It only happens when the fglrx drivers are installed, which results in KMS being disabled. It does *not* matter whether I have an xorg.conf file to tell X to actually use the fglrx driver. This is the Xorg.0.log error message:
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

When above conditions are met, the lockup occurs about every 3rd to 4th time. Ctrl+Alt+Del sanely restarts the machine.
While googling for the problem, I found this old issue in Red Had with exactly the same symptoms (as in, only happening with KDM, irreproducible, and same error in X log file): https://bugzilla.redhat.com/show_bug.cgi?id=323501

StephenR0 (s9999) wrote :

I have the same problem when I try to use the second ATI 4670 card in a system with two of these cards. With the first one alone it works just fine. This is 10.4 64 bit with fglrx. The message in Xorg.1.log is:

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Please let me know if you need more information.

loloemr (lpouillo) wrote :

Hello same problem here with an Intel Graphics Card :
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12)

uname -r -m
2.6.32-22-generic x86_64

Xorg.1.log
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.1.log" for additional information.

 ddxSigGiveUp: Closing log

thx1011 (thx1011) wrote :

I have the same issue...

 Kubuntu 9.10 64 bit
 XServer 1.7.6
 Ati 4870 with proprietary drivers from ATI 10.5
 Kernel 2.6.32-22-generic

 Running on a i7 920 intel system.

 In my case a cold start hangs always at the Kubuntu blue screen with the white dots. Nothing "moves"
 CTRL-ALT-DEL reboot's the system and it starts ok.

The error log:

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
Current Operating System: Linux Kubuntu 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 x86_64
Kernel command line: root=UUID=2c815f75-8354-4dd3-85d8-e6607d7f638b ro xforcevesa splash
Build Date: 23 April 2010 05:11:46PM
xorg-server 2:1.7.6-2ubuntu7 (Bryce Harrington <email address hidden>)
Current version of pixman: 0.16.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 9 20:43:21 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
(==) ServerLayout "aticonfig Layout"
(**) |-->Screen "aticonfig-Screen[0]-0" (0)
(**) | |-->Monitor "aticonfig-Monitor[0]-0"
(**) | |-->Device "aticonfig-Device[0]-0"
(**) Option "DontZap" "False"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
        Entry deleted from font path.
(==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
        built-ins
(==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x7ca300
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 6.0
        X.Org XInput driver : 7.0
        X.Org Server Extension : 2.0
(++) using VT number 8

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 ddxSigGiveUp: Closing log

thx1011 (thx1011) wrote :

Sorry, Ubuntu 10.04 Lucid Lynx. Not 9.10

Patrick Chevalley (pch) wrote :

Kubuntu 10.4, ATI 5770, fglrx

I have the same problem since I upgrade to Lucid.
It occur randomly only one or two time a week, other boot are fine.
It stuck at the Plymouth screen and need to press Ctrl+Alt+Del to reboot. It always boot normally the second time.

After that both Xorg.0.log and Xorg.failsafe.log finish with :

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

sotanez (sotanez) wrote :

Same problem with a Kubuntu 10.04 Lucid Lynx 64-bits fully upgraded.
It happens like each 1 of 2 boots. Mostly the first time I try to boot it crash and then it works after rebooting.

----------------
Linux karmapolice 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 x86_64 GNU/Linux
Nvidia GeForce 9800 GT
Athlon Athlon 64 X2 3800+
----------------

PD: Could it have something to do with this old and solved bug https://bugzilla.redhat.com/show_bug.cgi?id=323501 reported by Linus Torvalds for Fedora 8?

I've started experiencing this bug after upgrading from Karmic to Lucid on x86_64.

The video card is an integrated Radeon HD 2100:

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon 2100

BTW, the fix for Bug #544590 seems to have fixed this issue for me, too.

tifff (horst-fiedler) wrote :

After upgrade to lucid 2 days ago:
Fatal server error: xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call
during normal boot. That never happended with karmic.

Kernel 2.6.32-22-generic
Core(TM)2 Quad CPU Q8200
NVIDIA UNIX x86 Kernel Module 195.36.24 Thu Apr 22 09:18:20 PDT 2010

The same bug here - Toshiba Satellite T130-14T (intel g4500) and Kubuntu 10.04 64 bit.
With a chance of 1 out 5, notebook will stop booting right before kdm start.
Usual splash screen is just shown (kubuntu with 5 stars).
Ctrl-alt-del or power button function normally, so it is possible to switch off/on on reboot and to get to the desktop.

Patrick Chevalley (pch) wrote :

The fix for 544590 (kernel 2.6.32-23.37) do not change anything for me, the bug is still there after upgrade.
The only way to go at the moment is to remove the "splash" boot option.

hector (mailbox-deandreis) wrote :

At this time i've "resolved" to start the system on safe mode, then after the consolle login manually start kdm (/sudo /etc/init.d/kdm start).

In this mode the system starts ok, in "Normal" mode I need to restart (ctr+alt+del) 2/ 3 times.

jsiebold (jsi150) wrote :

I also was affected by this bug on two machines. As a workaround I altered the file /etc/init/kdm.conf and inserted a
"sleep 1" before the "exec kdm" line. Since two weeks I don't have problems any more.

Indeed, regardless of the fix for Bug #544590 the problem still occurs on my machine from time to time.

I'm retracting what I said in comment #29.

hector (mailbox-deandreis) wrote :

Workaround at msg #34 seems to work also for me.

Rafal-maj-it (rafal-maj-it) wrote :

I have same problem.
Athlon + radeon.

It was all working, stoped working after CPU speed was increased (back to factory default).
The work around #34 does not work though.

Rafal-maj-it (rafal-maj-it) wrote :

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3200 Graphics
Ubuntu Lucid, amd64.

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Please consult the The X.Org Foundation support
   at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 ddxSigGiveUp: Closing log

Rafal-maj-it (rafal-maj-it) wrote :

using: unraw (alt+sysrq+R) and then sak (alt+sysrq+K combo) keys sent ma back to VT-1, and now ctr+alt+F... keys worked, so I was able to go back to VT8, there clicked restart X (it was running in low mode or soemthing, despite doing killall X kill `pidof X` etc).

After this operations, the GFX works now. The "sleep 1" work around as stated above is still in place.

summary: - xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call
+ radeon graphics mode and console does not start - xf86OpenConsole:
+ VT_WAITACTIVE failed: Interrupted system call
description: updated
description: updated
Bryce Harrington (bryce) on 2010-07-13
tags: added: kubuntu
Peshko R. (peshko-us) wrote :

Have exactly the same problem.

Linux my-lnx 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 08:03:28 UTC 2010 x86_64 GNU/Linux

# lspci |grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G86M [Quadro NVS 150M] (rev a1)

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
Current Operating System: Linux my-lnx 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 08:03:28 UTC 2010 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-23-generic root=UUID=f9b4d685-e4dd-4725-8cd9-6cf6dcc18270 ro vga=792 splash quiet splash
Build Date: 16 June 2010 09:34:29AM
xorg-server 2:1.7.6-2ubuntu7.2 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.16.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Wed Jul 21 20:22:21 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Device0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
        Entry deleted from font path.
(==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
        built-ins
(==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x7ca300
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 6.0
        X.Org XInput driver : 7.0
        X.Org Server Extension : 2.0
(--) using VT number 1

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.1.log" for additional information.

 ddxSigGiveUp: Closing log

Peshko R. (peshko-us) wrote :

Just to add I use gdm, and do NOT have kdm. Work around for gdm???

Peshko R. (peshko-us) wrote :

Wow...Just checked to and saw there is an update for xserver specifically to address this issue. Updated the Xserver and did a few restart test, and so far so good. I'll update with with any issues.

Vlado Plaga (vlado-gmx) wrote :

Seems like this bug also afftects me since my update to Lucid. /var/log/Xorg.0.log says:

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

I don't use that notebook computer very often, but a failure to display anything happens a bit less often then every second time I want to use it, randomly.

The system is an AMD64 dual core with "ATI Radeon XPRESS 200M 5975 (PCIE)" graphics.

Tom Worley (tom-worley) wrote :

Running Kubuntu Lucid 10.04, NVidia GTX 260 graphics card, dual monitors.
I've been having this issue on and off for months, and usually rebooting lets me log in, but it's stuck on the splash screen and rebooting/powering off has not fixed it (6 times in a row).
Xorg.0.log shows:

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

 ddxSigGiveUp: Closing log

Tom Worley (tom-worley) wrote :

Just to add to the above, I'm running:
kdm: 4:4.4.2-0ubuntu14
xserver-xorg: 1:7.5+5ubuntu1 (but Xorg.0.log shows: X.Org X Server 1.7.6)
uname -a shows:
Linux Beast 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:20:59 UTC 2010 x86_64 GNU/Linux

The sleep 1 workaround to /etc/init/kdm.conf didn't work the first time, without rebooting, making sure all X/kdm had stopped, "start kdm" didn't work and still had the same error (running via ssh).
However after a reboot it seems to be running again. I have done 5 reboots/shutdowns in a row and it's worked each time now, looks like the workaround worked here =)

Patrick Chevalley (pch) wrote :

The "sleep 1" in kdm.conf also fix the problem for me.
I do about 20 boot in two weeks without any problem.

Keith Baker (keibak) wrote :

The suggested solution (adding sleep 1 command to /etc/init.d/gdm.conf) solves this bug for me.

For me the bug was introducted with kernel 2.6.35.3. It prevented GDM from showing the login screen and any console.

I'm using a "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)" and the i915-module.

Keith Baker (keibak) wrote :

BTW, I'm using 10.04.

Albert Zeyer (albertzeyer) wrote :

I have had a similar behavior here. I am using the nvidia driver.

I don't really like any of the suggested workarounds here. They are all hacks that don't really fix the bug itself.

This is the relevant code:

            if (ioctl(xf86Info.consoleFd, VT_ACTIVATE, xf86Info.vtno) < 0)
                FatalError("xf86OpenConsole: VT_ACTIVATE failed: %s\n",
                           strerror(errno));

            if (ioctl(xf86Info.consoleFd, VT_WAITACTIVE, xf86Info.vtno) < 0)
                FatalError("xf86OpenConsole: VT_WAITACTIVE failed: %s\n",
                           strerror(errno));

What I think what happens is what Linus has also figured out a while ago (in a similar situation):

"I have chased it down, and what happens is that the new X server is trying
to switch to its newly allocated virtual console, but the old X server that
was started by rhgb is exiting at the same time, and apparently depending
on pure luck (or lack of it), the old X server will switch back to the
original VT (VT#0) JUST AFTER the new X server has tried to switch to its
new VT!

The end result is that when the new X server waits for that switch to take
effect, it will never happen (since we did actually switch to it, but then
the old X server switched back!), and it will wait forever - or rather, it
will wait until a timeout signal comes in, and at that point it will exit
with the above error!"

rhgb is the Red Hat Graphical Boot.

If that is the same scenario which is happening here, there are actually multiple bugs:

* Some process (Ubuntus graphical boot? another XServer spawned by KDM?) tries to activate a different VT just at the same time. Why does it do that? It should not do that.

* Xorg should not hang in such a case.

I filled in a bug about that problem in Xorg here:
https://bugs.freedesktop.org/show_bug.cgi?id=29975

You will find further references and details about the problem on that report.

Albert Zeyer (albertzeyer) wrote :

If I am right with my explanation, the title of this report should be changed.

There is analogous bug with intel videocards also.

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/576353

I hoped that it will be fixed in Maverick - nope, this bug is still in the Maverick also! I would say that now it is even more frequent than in was in Lucid.

Philip (rocketman768) wrote :

Using kdm, nvidia driver, Kubuntu 10.04. Same bug, started appearing with the 2.6.32-24-generic kernel.

I believe Linus Torvalds himself reports this bug back in 2007
https://bugzilla.redhat.com/show_bug.cgi?id=323501

It's some race condition that is an artifact of porting X to Linux ages ago. He says "we are stuck with it."

==/var/log/Xorg.0.log.old==
Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Grek-336 (kult01) wrote :
Download full text (19.2 KiB)

I have this problem today the first time.

It is an Samsung notebook with NVidia chip.

I using a new Lucid i386 installation (no upgrade from older Ubuntu version) from a USB-Stick (with PAE-Kernel).

The second boot works perfect. No Strg-Alt-Fx work but the Power Button.

=== Xorg.1.log ===

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server i686 Ubuntu
Current Operating System: Linux michael-laptop 2.6.32-24-generic-pae #42-Ubuntu SMP Fri Aug 20 15:37:22 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic-pae root=UUID=b9a28d98-8a98-4df4-bc12-18af03ac4703 ro quiet splash
Build Date: 21 July 2010 12:47:34PM
xorg-server 2:1.7.6-2ubuntu7.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.16.4
 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Sep 14 14:22:09 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
(==) No Layout section. Using the first Screen section.
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "<default monitor>"
(==) No device specified for screen "Default Screen".
 Using the first device section listed.
(**) | |-->Device "Default Device"
(==) No monitor specified for screen "Default Screen".
 Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
 Entry deleted from font path.
(==) FontPath set to:
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/100dpi/:unscaled,
 /usr/share/fonts/X11/75dpi/:unscaled,
 /usr/share/fonts/X11/Type1,
 /usr/share/fonts/X11/100dpi,
 /usr/share/fonts/X11/75dpi,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
 built-ins
(==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
 If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x81f0e80
(II) Module ABI versions:
 X.Org ANSI C Emulation: 0.4
 X.Org Video Driver: 6.0
 X.Org XInput driver : 7.0
 X.Org Server Extension : 2.0
(--) using VT number 1

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.1.log" for additional information.

 ddxSigGiveUp: Closing log

=== This is the second boot without problems === Xorg.0.log ===

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server i686 Ubuntu
Current Operating System: Linux michael-laptop 2.6.32-24-generic-pae #42-Ubuntu SMP Fri Aug 20 15:37:22 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic...

Roman (m01brv) wrote :

I have just installed the new linux-image-2.6.32-25 from Ubuntu repositories, and faced this problem too.
The booting stops just before KDM screen should appear after the KUbuntu logo

Xorg.0.log contained the same lines:

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

I could not boot my computer three times concequently, including the "failsafeX" mode. I could load it only without any graphical login manager, and used this opportunity to reinstall back 2.6.32-24 kernel. However, after that the 2.6.32-25 kernel is booting normally. Not sure how this could be reproduced again.

I've never seen such things with earlier kernels.

Roman (m01brv) wrote :

I've done a few extra reboots after this, KDM is now always starting. However, the KUbuntu logo with five dots, which is shown before that, was corrupted on each boot. The colors were quite strange in some regions and the letters "KUbuntu" are surrounded by many dense green dots. Not sure whether it is related to this bug, but it suspicious that it started to happen with the same linux kernel. I've never seen such things before.

BTW, I use KUbuntu 10.04 and intel video card (i915 driver)

David Faure (faure) wrote :

I can't confirm #54, the same problem happens here with kernel 2.6.32-24.

Video card is: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller

Happened all of a sudden -without- having done any updates to the system; weird.

Fabio A. (fadamo) wrote :

The problem is still here:

Kubuntu 10.04.1 (clean install).

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
        Subsystem: Hewlett-Packard Company Device 30db
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 30
        Region 0: Memory at 90000000 (64-bit, non-prefetchable) [size=4M]
        Region 2: Memory at 80000000 (64-bit, prefetchable) [size=256M]
        Region 4: I/O ports at 7110 [size=8]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+
                Address: fee0200c Data: 41b9
        Capabilities: [d0] Power Management version 3
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

        Kernel driver in use: i915
        Kernel modules: i915

Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

up-whatever (up-whatever) wrote :

Same problem here, seems quite random.
Ubuntu 10.04 amd64, Kernel 2.6.32-26-generic, Nvidia GeForce 9600GT with proprietary drivers.

The title of this bug should be changed as the problem is obviously not related to radeon drivers.

$uname -r
2.6.35-22-generic
$lspci |grep VGA
nVidia Corporation G86 [GeForce 8600M GS] (rev a1)

Fatal Error in "Xorg.1.log":
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

As mentioned by people before it affects all cards and chipsets (ATI & Nvidia). It seems to be an Xserver issue/bug/race condition.

reem.bs (reem-bs) wrote :

This also happens to me

$ uname -r
2.6.35-23-generic
$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 LE] (rev a1)

Exact same error in Xorg log

It might just be a crazy coincidence, but this only happens to me when I'm using an audio player. Any audio player. Tried Amarok, Banshee and Rhythmbox. This happens to me since I upgraded to Maverick, and so it has happened a lot by now, but I don't recall it ever occurring when neither of those apps were running. Music doesn't even have to be played, which is plain weird to me cause I can't see what else is in common and exclusive to those three apps. Video players work fine. Does this happen to anyone else?

I also tried disabling the proprietary drivers to no avail.

dorpm (dorpmueller) wrote :
Download full text (17.9 KiB)

Same problem here on a Thinkpad R51 with a Mobility Radeon 7500. Happens quite randomly.

Here my xorg-log:

[ 35.239]
X.Org X Server 1.9.0
Release Date: 2010-08-20
[ 35.239] X Protocol Version 11, Revision 0
[ 35.239] Build Operating System: Linux 2.6.24-27-server i686 Ubuntu
[ 35.239] Current Operating System: Linux mm-mobil 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 10:18:49 UTC 2010 i686
[ 35.239] Kernel command line: root=UUID=3df77956-9fb8-4faf-b61f-62332003633d ro quiet splash
[ 35.239] Build Date: 16 September 2010 05:39:22PM
[ 35.239] xorg-server 2:1.9.0-0ubuntu7 (For technical support please see http://www.ubuntu.com/support)
[ 35.239] Current version of pixman: 0.18.4
[ 35.240] Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
[ 35.240] Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 35.240] (==) Log file: "/var/log/Xorg.1.log", Time: Sat Dec 4 13:19:56 2010
[ 35.255] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 35.255] (==) No Layout section. Using the first Screen section.
[ 35.255] (==) No screen section available. Using defaults.
[ 35.255] (**) |-->Screen "Default Screen Section" (0)
[ 35.255] (**) | |-->Monitor "<default monitor>"
[ 35.256] (==) No monitor specified for screen "Default Screen Section".
 Using a default monitor configuration.
[ 35.256] (==) Automatically adding devices
[ 35.256] (==) Automatically enabling devices
[ 35.256] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 35.256] Entry deleted from font path.
[ 35.256] (==) FontPath set to:
 /usr/share/fonts/X11/misc,
 /usr/share/fonts/X11/100dpi/:unscaled,
 /usr/share/fonts/X11/75dpi/:unscaled,
 /usr/share/fonts/X11/Type1,
 /usr/share/fonts/X11/100dpi,
 /usr/share/fonts/X11/75dpi,
 /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
 built-ins
[ 35.256] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[ 35.256] (II) The server relies on udev to provide the list of input devices.
 If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 35.256] (II) Loader magic: 0x81f8e00
[ 35.256] (II) Module ABI versions:
[ 35.256] X.Org ANSI C Emulation: 0.4
[ 35.256] X.Org Video Driver: 8.0
[ 35.256] X.Org XInput driver : 11.0
[ 35.256] X.Org Server Extension : 4.0
[ 35.257] (--) PCI:*(0:1:0:0) 1002:4c57:1014:0530 rev 0, Mem @ 0xe0000000/134217728, 0xc0100000/65536, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
[ 35.258] (II) Open ACPI successful (/var/run/acpid.socket)
[ 35.258] (II) LoadModule: "extmod"
[ 35.523] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 35.523] (II) Module extmod: vendor="X.Org Foundation"
[ 35.524] compiled for 1.9.0, module version = 1.0.0
[ 35.524] Module class: X.Org Server Extension
[ 35.524] ABI class: X.Org Server Extension, version 4.0
[ 35.524] (II) Loading extension MIT-SCREEN-SAVER
[ 35.524] (II) Loading extension X...

David Faure (faure) wrote :

In reply to #32: I don't think this is exactly the same as the RedHat bug report by Linus Torvalds, which was about the rhgb-client program specifically. The symptom (VT_WAITACTIVE failing) was the same, and the investigations might help with the bug here, but it's not the same bug (the rhgb one got fixed).

What I wonder is:
1) could someone from the ubuntu Xorg team look into this (and at least retitle the bug)
2) does anyone experience this bug with another distro, or is it only happening on [k]ubuntu...

Albert Zeyer (albertzeyer) wrote :

@David:

Read my comment #49. And also the linked Freedesktop bug. http://bugs.freedesktop.org/show_bug.cgi?id=29975

I read the relevant Xorg-server code and the same bug is still there and not fixed. There may be various possible reasons why VT_ACTIVATE succeeds but VT_WAITACTIVE will wait forever because in between, some other process has grabbed it.

A clean solution would be to do lock somehow the VT switching. I have read that this is possible, though very complicated and very messy.

Another possible fix/workaround would be do do the VT_ACTIVE in a endless loop in a separate thread and halt when either the VT_WAITACTIVE returns or when one of them return an error.

In any case, fixing this at another place than in Xorg would be the wrong way!

Ralf Jung (ralfjung-e) wrote :

These issues went completely away for me after I upgraded to Kubuntu 10.10.

Elliot (elliot-orwells) wrote :

Same black screen (with cursor) with Ubuntu 10.10 and Intel drivers.

Note, I didn't have this on 32bit, this is on amd64.

This is with a vanilla install and haven't been able to reproduce it. It happens say 30% of the times.

Thorsten Glaser (mirabilos) wrote :

FWIW, I just had the same problem in Debian Squeeze with fglrx.

Turns out that the “sleep 1” was a good idea – in Debian, I just installed file-rc to revert to “legacy” (as opposed to parallel) boot ordering, which fixed the problem there.

No idea about what init system *buntu uses these days, but thought you could use the information.

Žilvinas Valinskas (zval) wrote :

Same problem here:

[ 58.504] Fatal server error:
[ 58.504] xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call

hw/xfree86/os-support/linux/lnx_init.c:

 62 static void
 63 switch_to(int vt, const char *from)
 64 {
 65 if (ioctl(xf86Info.consoleFd, VT_ACTIVATE, vt) < 0)
 66 FatalError("%s: VT_ACTIVATE failed: %s\n", from, strerror(errno));
 67
 68 if (ioctl(xf86Info.consoleFd, VT_WAITACTIVE, vt) < 0)
 69 FatalError("%s: VT_WAITACTIVE failed: %s\n", from, strerror(errno));
 70 }

lines 68 is interrupt by signal ... and ioctl(VT_WAITACTIVE) return -1, errno == EINTR.
Xserver must retry operation again! See kernel sources, VT_WAITACTIVE ioctl() handler
does wait interruptable() and can return EINTR.

Patch like this might help:

diff --git a/hw/xfree86/os-support/linux/lnx_init.c b/hw/xfree86/os-support/linux/lnx_init.c
index 9c71a42..d17e039 100644
--- a/hw/xfree86/os-support/linux/lnx_init.c
+++ b/hw/xfree86/os-support/linux/lnx_init.c
@@ -62,10 +62,13 @@ drain_console(int fd, void *closure)
 static void
 switch_to(int vt, const char *from)
 {
+ int result;
+
     if (ioctl(xf86Info.consoleFd, VT_ACTIVATE, vt) < 0)
         FatalError("%s: VT_ACTIVATE failed: %s\n", from, strerror(errno));

- if (ioctl(xf86Info.consoleFd, VT_WAITACTIVE, vt) < 0)
+ SYSCALL(result = ioctl(xf86Info.consoleFd, VT_WAITACTIVE, vt));
+ if (result < 0)
         FatalError("%s: VT_WAITACTIVE failed: %s\n", from, strerror(errno));
 }

description: updated
Žilvinas Valinskas (zval) wrote :

Problem should be fixed by this commit, not sure if it was backported to ubuntu/natty.

commit 88c4622b594a1725d0cee86bc82ad640d241c520
Author: Aaron Plattner <email address hidden>
Date: Mon Apr 18 08:23:48 2011 -0700

    linux: Retry VT ioctls while errno == EINTR

    When the smart scheduler is enabled, the VT ioctls (particularly
    VT_WAITACTIVE) can be interrupted by the smart scheduler's SIGALRMs.
    Previously, this caused the server to immediately continue on to
    ScreenInit, almost certainly causing a crash or failure because the X
    server that owned the VT hadn't finished cleaning up. As of commit
    7ee965a300c9eddcc1acacf9414cfe3e589222a8, it causes a FatalError
    instead.

    Retrying the ioctl as long as it fails with errno == EINTR fixes the
    problem and allows server regenerations to trigger VT switches that
    actually succeed.

    Signed-off-by: Aaron Plattner <email address hidden>
    Reviewed-by: Peter Hutterer <email address hidden>
    Reviewed-by: Cyril Brulebois <email address hidden>
    Signed-off-by: Keith Packard <email address hidden>

Timo Aaltonen (tjaalton) wrote :

It's not included in 1.10.2, but available upstream on the server-1.10-branch.

Changed in xorg-server (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → High
status: Confirmed → In Progress
Timo Aaltonen (tjaalton) wrote :

committed to git

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.10.2.902-1ubuntu1

---------------
xorg-server (2:1.10.2.902-1ubuntu1) oneiric; urgency=low

  * Merge from Debian unstable. (LP: #441653)
    - Update 500_xi2.1.patch to apply.
    - Drop patch 218_randr-check-rotated-virtual-size-limits-correctly.diff,
      fixed upstream.
  * Update the crtc confinement patch with one that should work, with
    further fixes from upstream. (LP: #389519)
  * Dropped a bunch of old Breaks from xserver-xorg-core.

xorg-server (2:1.10.2.902-1) unstable; urgency=low

  * New upstream release (1.10.3 rc2):
    - DIX: Set backgroundState correctly for root window (Closes: #632134).
  * Drop 20-workaround-36986.diff, fixed upstream.
  * Bump Standards-Version to 3.9.2 (no changes).

xorg-server (2:1.10.2-2) unstable; urgency=low

  * Bump libgl1-mesa-dri versioned Recommends to 7.10.2-4, to lower the
    odds of having a server built against multiarched mesa, installed
    along a pre-multiarch mesa. The Breaks in mesa packages take care of
    the other way round already.
  * And since the server's binNMU managed to migrate to testing way too
    early, add a Breaks against pre-multiarch libgl1-mesa-dri and
    libgl1-mesa-dri-experimental.
 -- Timo Aaltonen <email address hidden> Tue, 05 Jul 2011 16:22:23 +0300

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
Id2ndR (id2ndr) wrote :

I encountred the trouble in natty today, so I can confirm that it has been fixed for natty.

It prevent the computer to boot, but I can shutdown it pressing the power off (acpi event).
Here is the end of /var/log/Xorg.1.log :
[ 19.465] (II) VESA: driver for VESA chipsets: vesa
[ 19.465] (II) FBDEV: driver for framebuffer: fbdev
[ 19.465] (--) using VT number 1

[ 30.720]
Fatal server error:
[ 30.720] xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call
[ 30.720]
[ 30.720]
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[ 30.720] Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[ 30.720]

Alexander Hartl (alx321) wrote :

I still encounter this bug on a Lucid Lynx LTS once in a while. If it was fixed for natty could Lucid's repository please be updated?

Rune K. Svendsen (runeks) wrote :

I have started to experience this in Natty as well. Normally only from a cold boot though; upon restarting, the issue is gone.

gak (khan-ghazanfar) wrote :

Experiencing same on Natty. No terminal switching works.

[ 24.750] (II) FBDEV: driver for framebuffer: fbdev
[ 24.750] (--) using VT number 1

[ 75.172]
Fatal server error:
[ 75.172] xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call
[ 75.172]
[ 75.172]
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[ 75.172] Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[ 75.172]

Timo Aaltonen (tjaalton) on 2011-09-29
Changed in xorg-server (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.