[Needs SRU] segfault when running Xdmx

Bug #402260 reported by qe2eqe on 2009-07-21
102
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned
Karmic
High
Unassigned

Bug Description

I get a segmentation fault when i run xdmx.

http://ubuntu.pastebin.com/f66315f80
^^output of Xdmx :2 -display :1, inside xfce4-terminal

Xdmx :2 -noglxproxy -norender -nomulticursor -input dummy -nooffscreenopt -nosubdivprims -noxkb -display :1 +xinerama

also fails in the same way.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xdmx 2:1.6.0-0ubuntu14
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg-server
Uname: Linux 2.6.28-13-generic i686

SRU-information:
This bug makes the xdmx package completely unusable on karmic. Lucid has a newer upstream release of xorg-server included, which includes various patches to xdmx. To make xdmx work on karmic at least 4 patches to xdmx are needed, these are cherrypicked from upstream git. The patches only modify files in hw/dmx/, so there should be no impact on other parts of xorg-server.

TEST CASE:
- install xdmx and Xephyr: aptitude install xserver-xephyr xdmx
- start Xephyr on display 1: Xephyr :1
- start xdmx on display 2, taking Xephyr on 1 as its only display: Xdmx :2 -display :1
- xdmx will crash on karmic with a segfault right away.

qe2eqe (qe2eqe) wrote :
qe2eqe (qe2eqe) wrote :

I just ran a similar command from a different computer, this time, no local X was displaying, and I told it connect to remote display. Same issue.

Philip Muškovac (yofel) on 2009-07-21
summary: - segfault
+ segfault when running Xdmx

Hi qe2eqe,

Thanks for including the attached files. Could you also include your /var/log/Xorg.0.log (or Xorg.0.log.old) from after reproducing the issue?

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in xorg-server (Ubuntu):
status: New → Incomplete
qe2eqe (qe2eqe) wrote :

In the name of reproducibility, I popped in the Xubuntu 9.04 live cd, and did the following.

ubuntu@ubuntu:~$ sudo apt-get install Xnest Xdmx
...
ubuntu@ubuntu:~$ Xdmx :2 -display :0
...
(II) dmx[o0/:0]: 0x3b TrueColor 32b 8b/rgb 256 0xff0000 0xff00 0x00ff
Segmentation fault (core dumped)

http://pastebin.ubuntu.com/227226/
^^^the out of Xdmx :2 -display :0
-----------

I submitted it to apport, at "Thu Jul 23 12:52:12 UTC 2009", plus or minus 30 seconds...

Attached is the Xorg.0.log from the LiveCD's crash.

qe2eqe (qe2eqe) wrote :

Here's the xorg log that's related to the first post.

jMyles (justin-justinholmes) wrote :

I am experiencing the same problem on both Jaunty 32-bit and 64-bit.

Bryce Harrington (bryce) on 2009-08-12
Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Rolf Leggewie (r0lf) wrote :

bug 334264 comment 11 says this is fixed in lucid, you may want to give the live cd a try

Rolf Leggewie (r0lf) wrote :

I can confirm the segfault and I can confirm it's fixed in the lucid live cd

This was fixed in Debian upstream around September last year (see Changelog)

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Ralf Doering (rdoering) on 2010-02-12
tags: added: karmic
Ralf Doering (rdoering) wrote :

Althoug this is fixed upstream and in latest Lucid packages, it still does affect karmic. xdmx under karmic is completely unusable due to this bug (and some others, which can't be seen due to xdmx not starting...). I have a set of patches ready, handpicked from upstream xorg git, which make xdmx on karmic usable again. Based on these patches, I made a ppa which builds xdmx and xdmx-tools from karmics patched xorg-server source package. It can be found at https://launchpad.net/~rdoering/+archive/xdmx-fix. If this bug affects you, please try packages from this PPA and report back if the problem is fixed.

I will add the individual patches here one after the other with a short description. Fortunately, xorg-server package uses quilt, so they may be integrated easily.

Changed in xorg-server (Ubuntu):
status: Fix Released → Confirmed
Ralf Doering (rdoering) wrote :

The first patch to get something running with xdmx in Karmic is 191_xdmx_segfault_on_start.patch. Without this patch, xdmx in karmic won't even start, it crashes with a segfault. This patch is upstream commit b159a98f7fbdb3f8b337cd1bfd2ff27312856619.

It does a simple modification in just on line in hw/dmx/dmxscrinit.c and does not affect the rest of xorg-server.

Ralf Doering (rdoering) wrote :

The second patch needed is 190_xdmx_fix_pointer.patch. After applying 191_xdmx_segfault_on_start.patch xdmx will start, but the mouse pointer gets mad and is stuck at the upper screen border after you move it. This patch fixes this. It is picked from xorg upstream commit e4edb4f2e6ca960b68629783459920faa86d8671.

Ralf Doering (rdoering) wrote :

The third patch is 189_xdmx_destroywindow.patch, which is needed to prevent xdmx segfaults when a window gets closed. It is picked from xorg upstream commit f713f447a2110718dfc091380699362d76f0cd6c. The only file modified is hw/dmx/dmxwindow.c, this patch does not change other parts of xorg-server.

Ralf Doering (rdoering) wrote :

And last but not least I have 192_xdmx_window_pixmap.patch, picked from xorg upstream commit 20fb8c2e2fccb28c1b89e6e2a5c685e1287baedb. This prevents some more xdmx segfaults (like when openbox opens its right-mousbutton menu, an xterm starts on plain xdmx without a windowmanager, ...). It is a simple modification to hw/dmx/dmxscrinit.c and does not affect other parts of xorg-server.

tags: added: patch
Bryce Harrington (bryce) wrote :

Thanks Ralf, looks like this is fixed in lucid but needs an SRU filed for karmic, so I've targeted the bug to that release.

summary: - segfault when running Xdmx
+ [Needs SRU] segfault when running Xdmx
Ralf Doering (rdoering) wrote :

Here is a debdiff against the current karmic version of xserver-xorg, including all patches mentioned above.

Ralf Doering (rdoering) on 2010-02-26
description: updated
Ralf Doering (rdoering) wrote :

Fixed in Lucid, still exists in Karmic.

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Ralf Doering (rdoering) on 2010-02-26
description: updated
John Dong (jdong) wrote :

ACK from ubuntu-sru for the karmic-proposed debdiff in comment #15.

Bryce Harrington (bryce) wrote :

Thanks, upload sponsored for karmic-proposed.

I've reviewed all the patches and they look acceptable. All are cherrypicks from upstream we carry in Lucid and look to be of low regression risk.

Changed in xorg-server (Ubuntu Karmic):
status: New → In Progress
importance: Undecided → High

Accepted xorg-server into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xorg-server (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Ralf Doering (rdoering) wrote :

Works for me with the packages from karmic-proposed (not surprisingly, as it is a sponsored upload of my patches ;)

Paul Elliott (omahn) wrote :

Verified - I'm also happy to report that the karmic-proposed packages fix this issue.

Mitch Towner (kermiac) wrote :

Changed tag to verification-done as 2 people have now verified the package in -proposed. Thanks for testing.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.6.4-2ubuntu4.2

---------------
xorg-server (2:1.6.4-2ubuntu4.2) karmic-proposed; urgency=low

  * Make xdmx work on Karmic. (LP: #402260)
    Adds the following patches:
    - 189_xdmx_destroywindow.patch: Fix segfault of xdmx when closing
      windows.
    - 190_xdmx_fix_pointer.patch: Fix pointer stuck at the upper screen
      border.
    - 191_xdmx_segfault_on_start.patch: prevent segfault right after
      starting xdmx.
    - 192_xdmx_window_pixmap.patch: Fix segfault by disabling
      Get/SetWindopixmap for xmdx.
 -- Ralf Doering <email address hidden> Tue, 23 Feb 2010 20:00:52 +0100

Changed in xorg-server (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers