X crashes in FindGlyphByHash

Bug #401045 reported by jcdutton on 2009-07-18
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
xserver-xorg-driver-ati
Fix Released
High
xorg-server (Ubuntu)
Medium
Robert Hooker

Bug Description

In karmic X session exits, kills all applications that are running and returns to the login prompt.
Description: Ubuntu karmic (development branch)
Release: 9.10

Xorg.0.log.old gives:

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x81353db]
1: /usr/bin/X(xf86SigHandler+0x55) [0x80c3185]
2: [0x718400]
3: /usr/bin/X(FindGlyphByHash+0x3c) [0x816f9dc]
4: /usr/bin/X [0x817c30c]
5: /usr/bin/X [0x8175455]
6: /usr/bin/X(Dispatch+0x33f) [0x808d67f]
7: /usr/bin/X(main+0x3bd) [0x80723dd]
8: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb2c7a5]
9: /usr/bin/X [0x8071891]
Saw signal 11. Server aborting.

Related branches

jcdutton (james-superbug) wrote :

In karmic X session exits, kills all applications that are running and returns to the login prompt.
Description: Ubuntu karmic (development branch)
Release: 9.10

Xorg.0.log.old gives:

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x81353db]
1: /usr/bin/X(xf86SigHandler+0x55) [0x80c3185]
2: [0x718400]
3: /usr/bin/X(FindGlyphByHash+0x3c) [0x816f9dc]
4: /usr/bin/X [0x817c30c]
5: /usr/bin/X [0x8175455]
6: /usr/bin/X(Dispatch+0x33f) [0x808d67f]
7: /usr/bin/X(main+0x3bd) [0x80723dd]
8: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb2c7a5]
9: /usr/bin/X [0x8071891]
Saw signal 11. Server aborting.

jcdutton (james-superbug) wrote :
jcdutton (james-superbug) wrote :

I cannot find a way to reliably cause this crash. It has happen a second time now within 1 hour.

affects: ubuntu → xorg (Ubuntu)
Bryce Harrington (bryce) on 2009-07-23
tags: added: crash
Robert Hooker (sarvatt) wrote :

You're using a mixture of jaunty and karmic packages here, if you're going to use edgers change the sources to karmic. If you dont want to use xorg-edgers any longer, then remove it completely from your sources, and do a dpkg -l | grep sarvatt (or ~jaunty perhaps) and for every package it lists add /karmic to the end of apt-get (sudo apt-get install packagename/karmic packagename2/karmic for example)

Bryce Harrington (bryce) on 2009-07-23
Changed in xorg (Ubuntu):
status: New → Invalid
jcdutton (james-superbug) wrote :

After doing all Robert Hooker suggested, it still crashes.
Is this really Invalid ?

jcdutton (james-superbug) wrote :

Summary of Xorg.0.log file
Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x8133a3b]
1: /usr/bin/X(xf86SigHandler+0x55) [0x80c7945]
2: [0x79a400]
3: /usr/bin/X(FindGlyphRef+0x11) [0x816daf1]
4: /usr/bin/X(FindGlyphByHash+0x3c) [0x816e1dc]
5: /usr/bin/X [0x817abfc]
6: /usr/bin/X [0x8173da5]
7: /usr/bin/X(Dispatch+0x347) [0x808ce27]
8: /usr/bin/X(main+0x395) [0x80723d5]
9: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0x1b97c5]
10: /usr/bin/X [0x8071881]
Saw signal 11. Server aborting.

Changed in xorg (Ubuntu):
status: Invalid → New
Bryce Harrington (bryce) on 2009-08-11
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) wrote :

Please collect a full backtrace on this issue - see http://wiki.ubuntu.com/X/Backtracing for guidance on how to collect this info.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2009-08-13
tags: added: karmic

Doesn't happen anymore with

Name : xorg-x11-server Relocations: (not relocatable)
Version : 7.4 Vendor: openSUSE
Release : 17.6.1 Build Date: Do 02 Jul 2009 10:09:59 CEST
Install Date: Do 16 Jul 2009 22:11:47 CEST Build Host: kuckuk
Group : System/X11/Servers/XF86_4 Source RPM: xorg-x11-server-7.4-17.6.1.src.rpm
Size : 5630085 License: X11/MIT
Signature : RSA/8, Do 02 Jul 2009 10:10:43 CEST, Key ID b88b2fd43dbdc284
Packager : http://bugs.opensuse.org
URL : http://xorg.freedesktop.org/
Summary : X.Org Server

So i feel free to close it.

Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Invalid

Apparently, this isn't entirely fixed. I have a bug report [1] in Gentoo for that, I'll tell the user to bring more info in here.

Thanks

[1] https://bugs.gentoo.org/288747

Klaus Layer (klaus-layer) wrote :

same crash here with release version of karmic. Sporadic crash of xserver.

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x8133d6b]
1: /usr/bin/X(xf86SigHandler+0x55) [0x80c7d35]
2: [0x508400]
3: /usr/bin/X(FindGlyphByHash+0x3c) [0x816e71c]
4: /usr/bin/X [0x817b13c]
5: /usr/bin/X [0x81742e5]
6: /usr/bin/X(Dispatch+0x35f) [0x808d17f]
7: /usr/bin/X(main+0x395) [0x8072515]
8: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x801b56]
9: /usr/bin/X [0x80719c1]
Saw signal 11. Server aborting.

I applied dbg packages to my system. Hopefully the next crash will provide a better backtrace

Changed in xserver-xorg-video-ati (Ubuntu):
status: Invalid → New
Tormod Volden (tormodvolden) wrote :

Klaus, what applications and desktop environment were you using when it crashed?

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Klaus Layer (klaus-layer) wrote :

I am using KDE desktop. The crash seems to be related to kmail. Everytime a crash occured I was working in kmail

Tormod Volden (tormodvolden) wrote :

Thanks, can you please attach your Xorg.0.log.old after a crash?

Klaus Layer (klaus-layer) wrote :

I just had another crash. I was displaying a message in kmail.

Tormod Volden (tormodvolden) wrote :

Please install the xserver-xorg-video-ati-dbg, xserver-xorg-video-radeon-dbg, xserver-xorg-core-dbg packages.

Klaus Layer (klaus-layer) wrote :

The last Xorg.0.log.old is from a system with the xserver-xorg-video-ati-dbg, xserver-xorg-video-radeon-dbg, xserver-xorg-core-dbg packages installed. I checked the https://wiki.ubuntu.com/X/Backtracing. Am I missing something?

Tormod Volden (tormodvolden) wrote :

You must be missing some other -dbg packages then, but I don't see which ones.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Confirmed
Changed in xserver-xorg-driver-ati:
status: Unknown → Confirmed

(i'm the one reporting the pb on gentoo)

i keep on having this crash using xorg-server 1.7.1
Most of the time it happens when i select some text in kmail.

The last backtrace (today..) is slightly different:

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x46dce8]
1: /usr/bin/X (0x400000+0x6e269) [0x46e269]
2: /lib/libpthread.so.0 (0x7fdec13bf000+0xf030) [0x7fdec13ce030]
3: /usr/bin/X (FindGlyphRef+0x1c) [0x4d4b3c]
4: /usr/bin/X (FindGlyphByHash+0x32) [0x4d4e52]
5: /usr/bin/X (0x400000+0xdc137) [0x4dc137]
6: /usr/bin/X (0x400000+0x54db4) [0x454db4]
7: /usr/bin/X (0x400000+0x2512d) [0x42512d]
8: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7fdebffebbbd]
9: /usr/bin/X (0x400000+0x24ca9) [0x424ca9]
Segmentation fault at address 0x4

I've experienced the bug with x11-drivers/xf86-video-ati-6.12.4 and the same driver from git repository (latest try : git version of november 21st)

I've never been able to reproduce the crash once i had applied the patch on:
http://lists.freedesktop.org/archives/xorg/2009-March/044396.html

Guillermo (cubero) wrote :

I have the same problem but I have Nvidia graphic card.
It happens working with QTCreator 1.2.1 opening a *.ui file after a full project recompilation.
My system is a fresh Ubuntu 9.10, graphic driver Nvidia 190 (but also happens with 185)

A piece of my /var/log/Xorg.0.log.old :

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x8133d6b]
1: /usr/bin/X(xf86SigHandler+0x55) [0x80c7d35]
2: [0xa79400]
3: /usr/bin/X(FindGlyphByHash+0x3c) [0x816e71c]
4: /usr/bin/X [0x817b13c]
5: /usr/bin/X [0x81742e5]
6: /usr/bin/X(Dispatch+0x35f) [0x808d17f]
7: /usr/bin/X(main+0x395) [0x8072515]
8: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x24db56]
9: /usr/bin/X [0x80719c1]
Saw signal 11. Server aborting.

Yes. At least on gentoo, I know of several people that suffered from this bug and who now apply the patch (Gentoo does not apply the patch to its package, yet?)

Klaus Layer (klaus-layer) wrote :

after several weeks without a crash on my system, I just got a new crash

Florian Lentsch (lentschi) wrote :

Almost the same here - however I only get the first three lines of the stack trace (and nothing at all in detail) - s. attachment.
I'm using a GeForce 6700 XL and a karmic that I auto-upgraded from jaunty.

*** Bug 26801 has been marked as a duplicate of this bug. ***

I also occasionally experience this issue when opening the "new mail" window in KMail. My attempt to get a readable backtrace resulted in this (I used addr2line on a debug binary, not the one which actually crashed - but it looks right):

3: FindGlyphByHash
/build/buildd/xorg-server-1.6.4/obj-i486-linux-gnu/render/../../render/glyph.c:263
4: ProcRenderAddGlyphs
/build/buildd/xorg-server-1.6.4/obj-i486-linux-gnu/render/../../render/render.c:1131
5: ProcRenderDispatch
/build/buildd/xorg-server-1.6.4/obj-i486-linux-gnu/render/../../render/render.c:2092
6: Dispatch
/build/buildd/xorg-server-1.6.4/obj-i486-linux-gnu/dix/../../dix/dispatch.c:457
7: main
/build/buildd/xorg-server-1.6.4/obj-i486-linux-gnu/dix/../../dix/main.c:399

This is with Kubuntu 9.10, X.Org X Server 1.6.4, NVidia binary drivers 185.18.36, KDE 4.3.5, KMail 1.12.4.

Robert Hooker (sarvatt) on 2010-03-23
affects: xserver-xorg-video-ati (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
Robert Hooker (sarvatt) wrote :

Untested patch for xorg-server which should fix this issue. It exists as far back as 2007 it looks like. Sorry I do not have packages including it ready for testing at the moment but I will provide them in a PPA as soon as I can.

Taken from:
http://lists.x.org/archives/xorg-devel/2010-March/006436.html

Robert Hooker (sarvatt) wrote :

I have uploaded a fixed xorg-server to this PPA for karmic. Can anyone experiencing the problem currently give it a shot and report your findings?

https://edge.launchpad.net/~sarvatt/+archive/bugfixes

Changed in xorg-server (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
status: Confirmed → In Progress
tags: added: patch
Bryce Harrington (bryce) wrote :

Since the crash occurs sporadically it might be hard for people to definitively test and prove it solves the issue. But in examining the patch it looks perfectly sane to me; it is essentially just a check against dereferencing a null pointer. Upstream may prefer a different fix but this looks quite fine for Lucid. We can drop it if/when upstream has it in a release.

Fixed in 185185eeb44a277c324be0f58a4b4a469b56b69b, and nominated for backport.

Thank you very much :) . Now I pray that this patch makes it into the next *buntu.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.7.6-1ubuntu1

---------------
xorg-server (2:1.7.6-1ubuntu1) lucid; urgency=low

  [Timo Aaltonen]
  * Merge from Debian unstable.
  * Drop patch 107, included in Debian.
  * Drop patch 108, included upstream.
  * control: Drop the udeb, we don't need it for lucid.
  * control: Relax/drop some build-deps caused by the udeb.

  [Bryce Harrington]
  * Add 110_findglyphbyhash-fix.patch from upstream to fix a sporadic
    crash in FindGlyphByHash.
    (LP: #401045)
  * Renumber patch 201_armel-drv-fallbacks.patch to 111

xorg-server (2:1.7.6-1) unstable; urgency=low

  [ Brice Goglin ]
  * Add 06_dont_trap_access_to_timer_and_keyboard.diff,
    thanks Samuel Thibault.

  [ Timo Aaltonen ]
  * New upstream release, closes: #574354.

  [ Julien Cristau ]
  * Don't build xserver-xorg-core-udeb on sparc. The linker fails because
    relocations have to be truncated when building statically against
    libnettle.

xorg-server (2:1.7.5.902-1) unstable; urgency=low

  [ Julien Cristau ]
  * config/udev: fix adding unnamed devices.
  * Build two flavours, one for the main package and one for the udeb.
  * Add patch to fix Xorg build with XV disabled.

  [ Timo Aaltonen ]
  * Add 16-config-dont-filter-input-subsys.diff so for instance serial
    wacom devices are initialized by the udev backend (LP: #522318,
    closes: #568236).

  [ Brice Goglin ]
  * New upstream release.
    + Allow for missing or disabled compat_output, closes: #572268, #554450.
    + Reenable RECORD extension, closes: #570680.
    + dix: try to ring the bell even if the current device doesn't have one,
      closes: #564200.
  * Refresh patches.
  * Fix typo in xvfb-run.1, thanks Joey Hess, closes: #527490.
  * Add 06_dont_trap_access_to_timer_and_keyboard.diff,
    thanks Samuel Thibault.

  [ Cyril Brulebois ]
  * Add udeb needed for the graphical installer: xserver-xorg-core-udeb.
  * Version/Bump some B-D to make sure xserver-xorg-core-udeb gets its
    dependencies on the (recently-added) udebs rather than on the
    libraries:
     - libpciaccess-dev
     - libudev-dev
     - libxau-dev
     - libxfont-dev
  * Replace 02_Add-libgcrypt-as-an-option-for-sha1.diff with
    02_Add-libgcrypt-and-libnettle-as-options-for-sha1.diff so that it's
    also possible to link against libnettle. Link (unconditionally)
    statically against libnettle.a to avoid an extra udeb for a few bytes.
  * Add nettle-dev to Build-Depends; and pass --with-sha1=libnettle for
    the udeb build (and --with-sha1=libgcrypt for the main build).
  * Add myself to Uploaders.
  * Tweak builderstring to use the name of the person responsible for the
    upload instead of an host-specific one (Closes: #574017).
 -- Bryce Harrington <email address hidden> Wed, 24 Mar 2010 12:04:20 -0700

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Released
Changed in xserver-xorg-driver-ati:
status: Confirmed → Fix Released
iaberis (iaberis) wrote :

I just added this ppa for the patch, if I ever get this problem again, I'll post it here

iaberis (iaberis) wrote :

I just had the crash again...

*** Bug 28343 has been marked as a duplicate of this bug. ***

Changed in xserver-xorg-driver-ati:
importance: Unknown → High
Changed in xserver-xorg-driver-ati:
importance: High → Unknown
Changed in xserver-xorg-driver-ati:
importance: Unknown → High

*** Bug 25840 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.