Changes to x11 mouse theme require restarting X.

Bug #398202 reported by ..::Jérémie::.. on 2009-07-11
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by potito
Nominated for Lucid by potito

Bug Description

when i change my x11 mouse theme, i need to restart X for the theme to apply.

BUT: befor i restart X when i go in firefox, the cursor changes but only in firefox...

using ubuntu 9.04

description: updated
tags: added: 9.04 mouse ubuntu x11
summary: - x11 mouse theme need restart X to work
+ x11 mouse theme need restart X to apply

I can confirm that. Exactly the same happens to me as well. I am using Karmic, just updated.

Problem* still exists in 9.10, Karmic Koala. It would be interesting to know why the cursor image updates for Firefox, but not anything else**.

*Not really a problem, a restart takes what, two seconds? More of an annoyance, if anything.

**I've only noticed the change in Firefox, it's possible that other applications recognise the change in cursor image as well.

Luke Symes (allsymes) wrote :

Confirmed on Lucid Alpha 3, all updates applied.

tags: added: 9.10
removed: 9.04
summary: - x11 mouse theme need restart X to apply
+ Changes to x11 mouse theme require restarting X.
tags: removed: 9.10
Changed in ubuntu:
status: New → Confirmed

Can someone run "apport-collect 398202" in a terminal so we can have more information about this bug? Thanks!

affects: ubuntu → xorg (Ubuntu)
Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) on 2010-08-30
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers