Comment 49 for bug 397839

To check to see if it is a gnome-power-manager bug:
1) killall gnome-power-manager
2) gnome-power-manager --verbose

when the blanking occurs, look at the last lines from the terminal to
see if GPM emitted anything that would cause the monitor to blank. If
nothing is shown, then the blanking is being called from something
else.

You can monitor the dbus:

$ dbus-monitor --session
"type='signal',interface='org.freedesktop.PowerManagement'"
$ dbus-monitor --session
"type='signal',interface='org.freedesktop.DeviceKit.Power

(I think karmic uses DKP only and not PowerManagement, so the first
one might not work).

After the blanking, see if there are any messages in the terminal that
would indicate what happened.

Since some people have this fixed and others do not, it might be an
x/video card interaction problem.
Thanks for the help!

On Fri, Sep 11, 2009 at 6:40 AM, John Vivirito <email address hidden> wrote:
> On 09/10/2009 10:02 AM, mac_v wrote:
>> The thing is that the patches described in Richard's blog have been applied but none of them seem to have fixed this issue... :(
>> Seems like no one really knows where the problem really is !
>>
>> Scott Howard , you might wanna consider re-opening this bug against gpm
>> ...
>>
> updates have fixed it i havent seen this is a while.
>
> --
> Sincerely Yours,
>    John Vivirito
>
> https://launchpad.net/~gnomefreak
> https://wiki.ubuntu.com/JohnVivirito
> Linux User# 414246
>
> "How can i get lost, if i have no where to go"
>    -- Metallica from Unforgiven III
>
> --
> Screen randomly goes off in karmic
> https://bugs.launchpad.net/bugs/397839
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org XServer - ATI gfx chipset driver: Confirmed
> Status in “gnome-power-manager” package in Ubuntu: Fix Released
> Status in “xorg-server” package in Ubuntu: Fix Released
> Status in “gnome-power-manager” package in Fedora: Fix Committed
>
> Bug description:
> Binary package hint: xserver-xorg-video-ati
>
> Sometimes the internal laptop display (LVDS) goes off (like a DPMS standby) for no reason (there is user activity going on).
> Moving the mouse or typing on the keyboard makes the screen turn on again (no password request or user logout happens)
>
> This happens on a fully updated Karmic with a mobility radeon X700 using the standard radeon driver.
>
> ProblemType: Bug
> Architecture: i386
> Date: Fri Jul 10 15:11:22 2009
> DistroRelease: Ubuntu 9.10
> Lsusb:
>  Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>  Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>  Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>  Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: Acer, inc. Yspire 1690
> Package: xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu1
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-2-generic root=UUID=79c83fad-2c20-4754-b080-8a8e9e451b51 ro quiet splash
> ProcEnviron:
>  LANG=it_IT.UTF-8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-2.16-generic
> RelatedPackageVersions:
>  xserver-xorg 1:7.4+3ubuntu5
>  libgl1-mesa-glx 7.5~rc4-1ubuntu3
>  libdrm2 2.4.11-1ubuntu1
>  xserver-xorg-video-intel 2:2.7.99.901+git20090702.74227141-0ubuntu1
>  xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu1
> SourcePackage: xserver-xorg-video-ati
> Uname: Linux 2.6.31-2-generic i686
> dmi.bios.date: 03/14/06
> dmi.bios.vendor: Acer
> dmi.bios.version: 3A44
> dmi.board.name: Crane II
> dmi.board.vendor: Acer, Inc.
> dmi.board.version: Not Applicable
> dmi.chassis.type: 1
> dmi.chassis.vendor: , Inc.
> dmi.chassis.version: N/A
> dmi.modalias: dmi:bvnAcer:bvr3A44:bd03/14/06:svnAcer,inc.:pnYspire1690:pvrNotApplicable:rvnAcer,Inc.:rnCraneII:rvrNotApplicable:cvn,Inc.:ct1:cvrN/A:
> dmi.product.name: Yspire 1690
> dmi.product.version: Not Applicable
> dmi.sys.vendor: Acer, inc.
> fglrx: Not loaded
> system:
>  distro:             Ubuntu
>  architecture:       i686kernel:             2.6.31-2-generic
>
> [lspci]
> 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility X700 (PCIE) [1002:5653]
>        Subsystem: Acer Incorporated [ALI] Device [1025:0066]
>
>