Incorrect autodetection of appropriate DPI

Bug #394498 reported by Tony Whitmore on 2009-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I have a 32" Samsung TV connected to a Viglen MPC-L via VGA. When the system boots with the VGA cable attached, X starts with a DPI of 29x39. If X starts without a VGA cable attached, it starts with a DPI of 96x96.

X is obviously doing some autodetection to calculate an appropriate DPI for a high resolution screen. However the size of text onscreen (in GDM, in the main WM UI and most applications) is too small to read comfortably, even close up to the screen.

96 DPI seems comfortable and allows the screen to be used from a reasonable distance.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: xorg 1:7.4~5ubuntu3
ProcEnviron:
 PATH=/home/username/.bin:/home/username/bin:/usr/bin/crunchbang:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.27-14-generic (buildd@palmer) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu12) ) #1 SMP Wed Apr 15 18:59:16 UTC 2009

SourcePackage: xorg
Uname: Linux 2.6.27-14-generic i586
xkbcomp:

Tony Whitmore (tonywhitmore) wrote :
Bryce Harrington (bryce) on 2009-07-06
Changed in xorg (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Several things are confusing in this report. You mention that it comes up with a 29x39 dpi, however none of your log files show that dpi. Second, your xorg.conf appears to be hardcoding the DisplaySize... why? Third, your xdpyinfo.txt file shows 1280x1024 pixels (361x203 millimeters), which is 90x128 dots per inch, and that does not look incorrect.

One other question, are you using GNOME or KDE? On Jaunty's GNOME it should already be forcing it to a fixed dpi, which gets around a lot of the issues.

Beyond this, I've written up a guide on how to debug font size issues due to incorrect dpi. Please review this and update this bug with the relevant information:
https://wiki.ubuntu.com/X/Troubleshooting/HugeFonts

Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) on 2009-07-07
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Tony Whitmore (tonywhitmore) wrote :

Hi Bryce, sorry for the delay in responding, I've been on holiday!

I'm not sure why none of the files attached to the report the DPI as 29x39. This was the DPI reported by xdpyinfo when running X without the DisplaySize hardcoded in xorg.conf or when X is started without the VGA cable attached to the PC. I've not used the command line bug reporting tool before. I was told to start X using the "broken" configuration and then start X with a "working" default then run the ubuntu bug command line tool. That's what I did, but I see that the xorg.conf and xdpyinfo output attached to the report is the "working" version, not the "broken" one.

I put a DisplaySize line in to xorg.conf, calculated as best I could following the formula given on the ubuntu forums, which suited my 32" TFT TV. This is a 16:9 display but I don't think the graphics card in the MPC-L computer supports widescreen resolutions, so I was aiming to run the display at 1280x1024. With this DisplaySize line in place, text is rendered clearly. Without it, text is tiny on the screen.

Having looked at the wiki page you posted above it seems likely that it is an EDID issue. The "Max Image Size" in the xorg log file is 10cm bigger in both dimensioons than the visible screen size on the TV. I'm not sure whether this is sufficiently incorrect to cause this error?

I have had this issue with Xubuntu and Openbox. Due to the very low spec of the CPU in the MPC-L it is very slow running KDE or GNOME. However, Openbox uses gdm AIUI and the issue is present there.

Bryce Harrington (bryce) on 2009-08-13
tags: added: intrepid
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi Tony,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 394498

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 394498 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/394498

Changed in xorg-server (Ubuntu):
status: Incomplete → New
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
Tony Whitmore (tonywhitmore) wrote :

I have tested a new install of Lucid on the MPC-L with the same Samsung display and it appears to be resolved now.

Changed in xorg-server (Ubuntu):
status: Expired → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers