Ubuntu

[Needs quirk] Huge font in GDM on HP Compaq nc8430

Reported by Jörn Horstmann on 2009-05-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by attisan

Bug Description

Release: Ubuntu Jaunty
Hardware: HP Compaq nc8430, ATI Technologies Inc M56P [Radeon Mobility X1600]

I am experiencing huge font sizes in GDM, probably for the same reason as in Bug #353074. Here is the relevant part of Xorg.log, please note the line which says "Image Size: 289 x 21 mm":

(II) RADEON(0): EDID vendor "LPL", prod id 5750
(II) RADEON(0): Printing DDC gathered Modelines:
(II) RADEON(0): Modeline "1280x800"x0.0 71.25 1280 1328 1360 1440 800 802 808 823 -hsync -vsync (49.5 kHz)
(II) RADEON(0): Output: LVDS, Detected Monitor Type: 2
(II) RADEON(0): EDID data from the display on output: LVDS ----------------------
(II) RADEON(0): Manufacturer: LPL Model: 1676 Serial#: 0
(II) RADEON(0): Year: 2005 Week: 0
(II) RADEON(0): EDID Version: 1.2
(II) RADEON(0): Digital Display Input
(II) RADEON(0): Max Image Size [cm]: horiz.: 33 vert.: 21
(II) RADEON(0): Gamma: 2.20
(II) RADEON(0): No DPMS capabilities specified
(II) RADEON(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
(II) RADEON(0): First detailed timing is preferred mode
(II) RADEON(0): redX: 0.590 redY: 0.344 greenX: 0.323 greenY: 0.534
(II) RADEON(0): blueX: 0.156 blueY: 0.138 whiteX: 0.312 whiteY: 0.328
(II) RADEON(0): Manufacturer's mask: 0
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 71.2 MHz Image Size: 289 x 21 mm
(II) RADEON(0): h_active: 1280 h_sync: 1328 h_sync_end 1360 h_blank_end 1440 h_border: 0
(II) RADEON(0): v_active: 800 v_sync: 802 v_sync_end 808 v_blanking: 823 v_border: 0
(WW) RADEON(0): Unknown vendor-specific block 0
(II) RADEON(0): LGPhilipsLCD
(II) RADEON(0): LP154W01-TLA8
(II) RADEON(0): EDID (in hex):
(II) RADEON(0): 00ffffffffffff00320c761600000000
(II) RADEON(0): 000f0102802115780a0f109758528828
(II) RADEON(0): 23505400000001010101010101010101
(II) RADEON(0): 010101010101d51b00a0502017303020
(II) RADEON(0): 26002115100000190000000000000000
(II) RADEON(0): 00000000000000000000000000fe004c
(II) RADEON(0): 475068696c6970734c43440a000000fe
(II) RADEON(0): 004c503135345730312d544c41380076

Jörn Horstmann (jhorstmann) wrote :

The attached patch against xorg-server_1.6.0-0ubuntu14 fixes the problem for me. This is my first time working with debian patches and quilt, so please correct me if anything is wrong with this patch.

Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Bryce Harrington (bryce) wrote :

Hi jhorstmann,

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with the latest development release of Ubuntu? (ISO CD images are available from http://cdimage.ubuntu.com/releases/)

If it remains an issue, could you also attach a new /var/log/Xorg.0.log?
Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-verification
Changed in xorg-server (Ubuntu):
status: New → Incomplete
Jörn Horstmann (jhorstmann) wrote :

Hi,

I just booted the Karmic Alpha 6 live cd to try to reproduce this bug. Since the live cd does not show the gdm login screen I have no visual confirmation but Xorg.0.log, xdpyinfo and xrandr all still report a wrong size or dpi.

xdpyinfo:

default screen number: 0
number of screens: 1

screen #0:
  dimensions: 1280x800 pixels (289x21 millimeters)
  resolution: 112x968 dots per inch
  depths (7): 24, 1, 4, 8, 15, 16, 32
  root window id: 0x66
  depth of root window: 24 planes

xrandr:

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 289mm x 21mm
   1280x800 60.1*+
   1280x720 59.9
   1152x768 59.8
   1024x768 59.9
   800x600 59.9
   640x480 59.4
DVI-0 disconnected (normal left inverted right x axis y axis)

Bryce Harrington (bryce) on 2009-10-13
Changed in xorg-server (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.6.4-2ubuntu2

---------------
xorg-server (2:1.6.4-2ubuntu2) karmic; urgency=low

  * Add 187_edid_quirk_hp_nc8430.patch: Quirk for another LPL monitor, to
    fix huge font sizes due to invalid EDID from the hardware.
    (LP: #380009)

 -- Bryce Harrington <email address hidden> Tue, 13 Oct 2009 02:25:46 -0700

Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
eocanha (eocanha) wrote :

I have the same bug in a Packard Bell EasyNote MX35 with an Intel 945GM (I guess).

The problem could be solved specifying the DPI by hand to the X server in the /etc/gdm/gdm.conf. You have to change the lines:

[server-Standard]
name=Standard server
command=/usr/bin/X -br -audit 0

by...

[server-Standard]
name=Standard server
command=/usr/bin/X -br -dpi 75 -audit 0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments