No keyboard or Mouse on Login Screen

Bug #372679 reported by Mind0ne on 2009-05-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

I upgraded to 9.04 from 8.10 last night from the update manager. After the update/upgrade completed, I restarted the computer as instructed. When it came to the login screen my keyboard and mouse did not respond. I have tried restarting and using the recovery console to start dbus and hal to no success. I turn the numlock on to see when the keyboard shuts off and it is after Ubuntu is loaded but before the login screen appears. The computer is not frozen so some how 9.04 is disabling my mouse and keyboard. I am using a standard ps/2 keyboard and a 7 button usb mouse.

Scott Howard (showard314) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please attach your X server configuration file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.0.log) to the bug report as individual uncompressed file attachments using the "Attachment:" box below.

Assigning to xorg-server.

affects: ubuntu → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
jazzkdh (jazzkdh) wrote :

please re-open, I have this same issue with a fresh install of Ubuntu Studio 9.04 (amd64). I have tested with both usb and ps2 QWERTY and mouse. As Mind0ne states, the mouse and keyboard cease to function at the login splash - however all usb ports are still active, as a few of my devices stay "lit up" when there is no driver present. I did some digging and saw this type of issue in 8.10 an various forum threads like this: http://ubuntuforums.org/showthread.php?t=1023153 however there seems to be no working solution.

I am willing to attach whatever files are needed to diagnose, if someone could give me the steps to do so.

thanks!

Scott Howard (showard314) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Karmic Koala. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

You can try the Ubuntu Studio liveCD for Karmic Koala as well.

If the bug still exists in Karmic, you can follow X-debugging instructions at:
https://wiki.ubuntu.com/X/Debugging

You could also use a linux liveCD to access your hard drive and attach the following files to this report:
 /var/log/Xorg.0.log
~/.xsession-errors

Changed in xorg-server (Ubuntu):
status: Invalid → Incomplete

Hey Scott,

     After reinstalling with different scenarios, I believe the problem lies
in the default USA keyboard layout. I've only tested this with Ubuntu Studio
9.04 amd64 version.. Basically, the default selection in the install process
is to not detect the keyboard layout. By doing this and selecting the
default USA keyboard selections, the installed seems to null all QWERTY and
mouse input.

    However, going through the keyboard detection process (press the "insert
letter here" key) I was able to get keyboard and mouse working no problems.
Perhaps the default USA layouts are missing/corrupt/blank?

    I will gladly take a look at Karmic when I get the chance - my day gig
at Open Labs tends to keep me pretty busy.

peace,

gabriel

On Jul 6, 2009 4:25 PM, "Scott Howard" <email address hidden> wrote:

Thank you for taking the time to report this bug and helping to make
Ubuntu better. The issue that you reported is one that should be
reproducible with the live environment of the Desktop CD of the
development release - Karmic Koala. It would help us greatly if you
could test with it so we can work on getting it fixed in the next
release of Ubuntu. You can find out more about the development release
at http://www.ubuntu.com/testing/. Thanks again and we appreciate your
help.

You can try the Ubuntu Studio liveCD for Karmic Koala as well.

If the bug still exists in Karmic, you can follow X-debugging instructions
at:
https://wiki.ubuntu.com/X/Debugging

You could also use a linux liveCD to access your hard drive and attach the
following files to this report:
 /var/log/Xorg.0.log
~/.xsession-errors

** Changed in: xorg-server (Ubuntu)
      Status: Invalid => Incomplete

-- No keyboard or Mouse on Login Screen
https://bugs.launchpad.net/bugs/372679 You received this b...
Status in “xorg-server” package in Ubuntu: Incomplete

Bug description: I upgraded to 9.04 from 8.10 last night from the update
manager. After the update...

Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Bryce Harrington (bryce) on 2010-02-27
Changed in xorg-server (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

[re-closing this bug report since requested logs and other info has not been provided.]

Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers