Xorg crashed with SIGSEGV in DeleteInputDeviceRequest()

Bug #358643 reported by Geir Ove Myhr on 2009-04-09
76
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
High
Unassigned
wacom-tools (Ubuntu)
Medium
Timo Aaltonen
Jaunty
Medium
Timo Aaltonen
Karmic
Medium
Timo Aaltonen
xorg-server (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

After package update today (2009-04-09, previous one was 2009,04-06) X hangs on logout from both Gnome and KDE. This crash was detected by apport after reboot, so I assume it is the same problem.

Hardware: Lenovo Thinkpad X61 Tablet.

Seems similar to bug 259035 which indicates that this may be caused by the wacom tablet.

[Update]
What I didn't notice in the beginning was that in addition hanging or crashing on logout and reboot (sometimes it crashes and X restarts, sometimes it just hangs), the VTs are all corrupted.

Downgrading to xserver-xorg-input-wacom_0.8.1.6-1ubuntu8 solved the problem, and so did removing my xorg.conf with tablet "InputDevice" sections and a "ServerLayout" section that was required for 0.8.1.6-1ubuntu8 (see comment).

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/Xorg
Package: xserver-xorg-core 2:1.6.0-0ubuntu14
ProcAttrCurrent: unconfined
ProcCmdline: /usr/X11R6/bin/X :0 -br -audit 0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
ProcVersion: Linux version 2.6.28-11-generic (buildd@rothera) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #41-Ubuntu SMP Wed Apr 8 04:38:53 UTC 2009
Signal: 11
SourcePackage: xorg-server
StacktraceTop:
 DeleteInputDeviceRequest ()
 CloseDownDevices ()
 main ()
Title: Xorg crashed with SIGSEGV in DeleteInputDeviceRequest()
Uname: Linux 2.6.28-11-generic i686
UserGroups:

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
     Subsystem: Lenovo Device [17aa:20b3]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)
     Subsystem: Lenovo Device [17aa:20b5]

Geir Ove Myhr (gomyhr) wrote :
visibility: private → public
Changed in xorg-server (Ubuntu):
status: New → Incomplete
tags: removed: need-i386-retrace
Geir Ove Myhr (gomyhr) wrote :

The Apport retracing service has labeled this a duplicate of bug 357331 which is probably true, but not very useful since that bug report is not public.

I think this bug may be a regression due to the updated wacom-tools package (see bug 355340).

Geir Ove Myhr (gomyhr) wrote :

Downgrading xserver-xorg-input-wacom to 0.8.1.6-1ubuntu8 solved the problem (thanks to the mirror http://ubuntu.patan.com.ar for being sufficiently far behind so that I could get the old package), thereby confirming that this is a problem with this package.

Moreover, removing my /etc/X11/xorg.conf where I had the wacom configuration (which was mandatory for the old package) also solved the problem. Probably the new hotplug support clashes with my definitions, and this is what causes the problems.

Geir Ove Myhr (gomyhr) on 2009-04-09
description: updated
Geir Ove Myhr (gomyhr) on 2009-04-09
Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
Steve Langasek (vorlon) wrote :

ideally we would transition xorg.conf on upgrade to jaunty; barring that, this does need to go in the release notes.

Changed in wacom-tools (Ubuntu Jaunty):
importance: Undecided → Medium
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Timo, can you please look at the feasibility of xorg.conf auto-migration?

Changed in wacom-tools (Ubuntu Jaunty):
assignee: nobody → tjaalton
Timo Aaltonen (tjaalton) wrote :

Sure will: It shouldn't crash though, since the input devices in xorg.conf should be ignored when HAL is used.

I looked a little bit more into this, and there seems to be a
difference in whether I use /dev/ttyS0 /dev/input/wacom as the
"Device" in the "InputDevice" section. /dev/input/wacom is a symlink
to /dev/ttyS0, but maybe the driver doesn't realize that it it a
collision if the different names are used.

I have tested with the attached xorg.conf where I have stripped away
most of the stuff that was irrelevant for this bug. With
  Option "Device" "/dev/ttyS0"
uncommented, X crashes already on startup (it keeps restarting for a
while after boot). The screen flashes several times between general
corrupted screen and black during this and finally stops in the
courrupted state.

With
  Option "Device" "/dev/input/wacom"
X starts just fine. During the first X session VT switching works
fine. At logout, though, the X-server crashes and when gdm comes up
again the VTs are corrupted. They still work as I can run commands
blindly, but after switching to a VT I cannot get the X-session back.

Finally, when commenting out
  InputDevice "stylus" "SendCoreEvents"
in the "ServerLayout" section, everything works fine no matter which
line I use in the input device.

I attach Xorg.0.log for each case, two for the case of
/dev/input/wacom, since I don't always get a crash with a backtrace in
the log for this case.

Let me know if there is anything more I can test.

Timo Aaltonen (tjaalton) wrote :

try building wacom-tools after applying this patch from 0.8.3.x (just edit it directly and drop the ifndef/endifs):

diff -Naur linuxwacom-0.8.2-2/src/xdrv/wcmConfig.c linuxwacom-0.8.3-2/src/xdrv/wcmConfig.c
--- linuxwacom-0.8.2-2/src/xdrv/wcmConfig.c 2009-01-19 20:58:37.000000000 +0200
+++ linuxwacom-0.8.3-2/src/xdrv/wcmConfig.c 2009-04-03 22:31:24.000000000 +0300
@@ -376,13 +377,10 @@
        if (priv->pPressCurve)
                xfree(priv->pPressCurve);

-#ifndef WCM_XORG_XSERVER_1_6
- /* don't free priv for X server 1.6 or later here
- * otherwise X server crashes
+ /* free priv here otherwise X server 1.6 or later crashes
         */
        xfree(priv);
        local->private = NULL;
-#endif

        xf86DeleteInput(local, 0);
 }

--

If you don't know how, I can provide a package on my PPA tomorrow or so.

Geir Ove Myhr (gomyhr) wrote :

I think I know the basic steps to build a package, and will try it tonight. If I run into problems, I may need to get it from your PPA.

Timo Aaltonen (tjaalton) wrote :

you could also try the xserver-xorg-core from my PPA, should fix bug 361972 and possibly this one too. It'll take a while to build.

Geir Ove Myhr (gomyhr) wrote :

I was able to build wacom-tools just fine and I have tested both the
patch in comment 8 and the xserver-xorg-core (2:1.6.0-0ubuntu11.1)
from Timo's PPA.

With only the patched xserver-xorg-input-wacom (1:0.8.2.2-0ubuntu2)
there wasn't any difference from the unpatched one. I wasn't able to
reproduce the result from comment 7 where the xserver would crash
right away when the "Device" was set to "/dev/ttyS0" in either case,
and I don't know why.

The new xserver-xorg-core from PPA solves the problem with the corrupt
TTYs. As for the rest:

With xserver-xorg-core from PPA (without patched wacom):

If /dev/ttyS0:
No crash or hang!

If /dev/input/wacom:
On boot, the first X-session works fine. On logout, the next X-session
hangs. If I start with /dev/ttyS0 and during the X-session edit to
/dev/input/wacom, it hangs.
When it hangs, it the log ends with:
usbDetect: can not ioctl version
xf86WcmSerialValidate: bad magic at 3 v=c0 l=9
On first session after boot, the log is basically the same to this
point, but it continues and on logout the UnloadModule: "wacom" seems
to go fine and there is no Backtrace at the end.

With xserver-xorg-core from PPA and patched xserver-xorg-input-wacom:

If /dev/ttyS0:
No crash or hang!

If /dev/input/wacom:
Works mostly fine. Still has the "bad magic" lines in the log and
takes longer to get login screen (maybe it hangs for a while at the
"bad magic at 3"). It hung on me once (first session after boot), at
the same place where the second session after boot would hang every
time without the patch.

I'm still a little puzzled that it makes a difference whether I use
/dev/input/wacom or /dev/ttyS0 as "Device" in the "InputDevice"
section. Maybe I should try what happens if I use a bogus device name?
(but not tonight)

Bryce Harrington (bryce) on 2009-04-21
description: updated
Steve Langasek (vorlon) wrote :

This still needs to be release-noted; Timo, Bryce, could one of you suggest some text that explains this issue and an appropriate workaround?

Changed in ubuntu-release-notes:
importance: Undecided → High
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

I'll write something in the morning unless someone beats me to it.

Timo Aaltonen (tjaalton) wrote :

Ok, here's that something to add under "Upgrading", edit at will:

The Xserver crashes when using a wacom tablet

The wacom driver in 9.04 supports automatic configuration, but it conflicts with the wacom entries in /etc/X11/xorg.conf resulting in the Xserver crashing either on startup or shutdown. Until an update is provided, please comment out or remove the entries from xorg.conf to get rid of the crashes.

On Thu, 23 Apr 2009, Timo Aaltonen wrote:

> Ok, here's that something to add under "Upgrading", edit at will:
>
> The Xserver crashes when using a wacom tablet
>
> The wacom driver in 9.04 supports automatic configuration, but it
> conflicts with the wacom entries in /etc/X11/xorg.conf resulting in the
> Xserver crashing either on startup or shutdown. Until an update is
> provided, please comment out or remove the entries from xorg.conf to get
> rid of the crashes.

err, actually remove the "until an update is provided" part, since there
should be no need to add them back after the update :)

Steve Langasek (vorlon) wrote :

Documented at <https://wiki.ubuntu.com/JauntyJackalope/ReleaseNotes#X%20server%20crashes%20when%20using%20a%20wacom%20tablet>:

  The wacom driver in Ubuntu 9.04 supports automatic configuration, but it conflicts with manual device entries for wacom tablets in /etc/X11/xorg.conf, causing the X server to crash either on startup or shutdown. Please comment out or remove the entries from xorg.conf to get rid of the crashes. (358643)

Changed in ubuntu-release-notes:
status: Incomplete → Fix Released
mu3en (mu3en) wrote :

maybe i duplicated this one by mistake under 364996 x server crash (wacom on hp tc1100), please take a look.

commenting out the lines from my xorg.conf does prevent crashes, but leaves no right click button on the stylus and no working xsetwacom function for rotation, so it's not really a solution at all.

i am available to help resolve this issue in any feedback or assistance i can provide.

Chris Drost (chris-drostie) wrote :

Timo:

There may still be a need to have them (the xorg.conf sections), as far as I can tell. In particular, the [xsetwacom set] command requires a device name, which is configured in xorg.conf. As far as I know, there's no documentation on the default name for the tablet autoconfiguration.

@mu3en: Did you give Timo's xserver-xorg-core package a try?
https://launchpad.net/~tjaalton/+archive/ppa
xserver-xorg-core_1.6.0-0ubuntu11.1_i386.deb or the corrsponding amd64
package would be the one you want.

I have been running Jaunty with this and the patch in comment 8 to
wacom-tools, and the same xorg.conf that I had in Intrepid. With this,
xsetwacom works (at least the automatic screen-and-stylus-rotation on
swivel up/down from
http://www.thinkwiki.org/index.php?title=Installing_Ubuntu_8.10_(Intrepid_Ibex)_on_a_ThinkPad_X61_Tablet
works).

mu3en (mu3en) wrote :

okay, that was fast:
1. purge/reinstall wacom-tools

sudo apt-get purge wacom-tools xserver-xorg-input-wacom

2. download:

http://ppa.launchpad.net/tjaalton/ppa/ubuntu/pool/main/x/xorg-server/xserver-xorg-core_1.6.0-0ubuntu11.1_i386.deb

and install

sudo dpkg -i xserver-xorg-core_1.6.0-0ubuntu11.1_i386.deb

then build the latest linuxwacom driver from sourceforge
(i think http://prdownloads.sourceforge.net/linuxwacom/linuxwacom-0.8.3-2.tar.bz2)?
and copy it:
sudo cp ./src/2.6.28/wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/wacom.ko

(backup first...)

xorg.conf as attached.

that seems to do everything pretty much exactly as expected - no crashes yet.

mu3en (mu3en) wrote :

yeah seems to work.
this rotates using the indented 'monitor key' on tc1100 with above changes.
may have been this too:
/usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi as below:

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">
  <device>
      <match <email address hidden>:pnp.id" contains_outof="WACf001;WACf002;WACf003;WACf004;WACf005;WACf006;WACf007;WACf008;WACf009;WACf00a;WACf00b;WACf00c;FUJ02e5">
        <append key="info.capabilities" type="strlist">input</append>
        <merge key="input.x11_driver" type="string">wacom</merge>
        <merge key="input.x11_options.Type" type="string">stylus</merge>
        <merge key="input.x11_options.ForceDevice" type="string">ISDV4</merge>
        <merge key="input.device" type="copy_property">serial.device</merge>
        <append key="info.callouts.add" type="strlist">hal-setup-wacom</append>
    </match>
  </device>
</deviceinfo>

Chris Drost (chris-drostie) wrote :

After reading the above posts by mu3en and having a little extra time to fiddle with these things, I can confirm that the xserver-xorg-core deb in Timo's PPA (more specifically, the amd64 one for me) fixes the problem on my tablet PC -- I can now go back to the old xorg.conf (see bug # 359133 -- in particular, I also use a /dev/ttyS0 module).

I didn't have to recompile linuxwacom -- it just worked with the wacom-tools package in the repos (aptitude shows it as 0.8.2.2-0ubuntu2). Hurray!

Timo, you rock!

Also, xsetwacom apparently has a "list dev" option that I didn't know about before, but when X autoconfigures the tablet, it doesn't create any entries under there. Maybe I shouldn't worry about that, though -- if you're setting up manual tablet rotation with xsetwacom, you should probably expect to have to manually reconfigure your tablet in X too.

ujean (eugenio-fullsite) wrote :

Hi,
I have the same problem with my tablet TC1100.
Currently I have to comment the line:
  # InputDevice "stylus" "SendCoreEvents"
In order to make X work (and the stylus as well), otherwise it crashes on boot with the message "Cannot open device /dev/input/wacom".

I'm trying to follow the instructions found in this page (mu3en comment #20) .
Once installed the deb package (sudo dpkg -i xserver-xorg-core_1.6.0-0ubuntu11.1_i386.deb) when I enter the ./configure command for compiling the linuxwacom driver I get:
----------------------------------------
  BUILD ENVIRONMENT:
       architecture - i486-linux-gnu
       linux kernel - yes 2.6.28
  module versioning - no
      kernel source - yes /lib/modules/2.6.28-11-generic/build
     XFree86 source - no
           Xorg SDK - yes /usr/include/xorg
          XSERVER64 - no
           dlloader - yes
               XLib - yes /usr/lib
         xf86config - no
                TCL - yes /usr/include/tcl
                 TK - yes /usr/include/tcl
            ncurses - yes

  BUILD OPTIONS:
            wacom.o - no
            wacdump - yes
             xidump - yes
        libwacomcfg - yes
         libwacomxi - yes
          xsetwacom - yes
              hid.o - no
       wacom_drv.so - yes /usr/lib/xorg/modules/input
        wacom_drv.o - no
  wacom*_drv quirks - Uninit-called IsXExtensionPointer key-events dixScreenOrigins
----------------------------------------

then when I enter the command "make" I get a lot of errors:

./../include/xdrv-config.h:11:1: warning: this is the location of the previous definition
/usr/include/xorg/xorg-server.h:195:1: warning: "XFree86LOADER" redefined
***Note: Drivers not enabled as modules in your kernel config but requested through configure are NOT built

what can I do?

thanks for any advice.

Chris Drost (chris-drostie) wrote :

ujean: have you tried just installing wacom-tools from the repositories? I'm really not sure that it's necessary to recompile.

If it is necessary to compile, well, those three messages look like compiler warnings but not errors. Does the compiling process finish despite them? You might be still be able to copy wacom.so over to where it needs to go.

mu3en (mu3en) wrote :

ujean: the following is simpler than the method i mentioned above (no need to build anything, as mentioned by chris in his post):

1. purge/reinstall wacom-tools:

sudo apt-get purge wacom-tools xserver-xorg-input-wacom
sudo apt-get install wacom-tools xserver-xorg-input-wacom

2. download timo's xorg-core:

http://ppa.launchpad.net/tjaalton/ppa/ubuntu/pool/main/x/xorg-server/xserver-xorg-core_1.6.0-0ubuntu11.1_i386.deb

to your home folder and install:

sudo dpkg -i xserver-xorg-core_1.6.0-0ubuntu11.1_i386.deb

use my xorg.conf provided above.

after restart everything should be working almost perfectly, you might want to pin timo's package until the official versions are corrected.

i attached a desktop/menu entry above for the rotate, but forgot the script to go with it, here it is too:

ujean (eugenio-fullsite) wrote :

it works!

I copied wacom.so file despite the errors and then, follwing mu3en procedure, everythig seems to working fine.
I attached the rotation script I use, it includes the rotation of the sylus as well.

many, many thanks

PS since this morning the automatic system updating service keeps asking me to update xserver-xorg-core, I think I've to skip this update...

mu3en (mu3en) wrote :

ujean, two points,

1. wacom.so portion is not really necessary according to Chris (default version 0.8.2.2 instead of self compiled 0.8.3.2) but seems to work fine for us both, so no issue. others may want to skip the whole driver step since it involves compiling, errors, etc...

2. i referred to "you might want to pin timo's package until the official versions are corrected". to do this, edit the file /etc/apt/preferences:

sudo vi /etc/apt/preferences

to look like this:

Package: xserver-xorg-core
Pin: version 2:1.6.0-0ubuntu11.1
Pin-Priority: 1000

this will lock the package as timo's version and adept will stop bothering you. do remember to keep track of any official updates that will include timo's changes in the future.

ujean (eugenio-fullsite) wrote :

hi mu3en,
I "pinned" the timo's package.
Thanks again.

ujean (eugenio-fullsite) wrote :

hi,
does anybody know if the latest xserver-xorg-core (2:1.6.0-0ubuntu14) includes timo`s fix?

thanks for any advice

Geir Ove Myhr (gomyhr) wrote :

I don't think it does. At least I'm still running Timo's package. 2:1.6.0-0ubuntu14 was the one released with Jaunty, and there has been no updates since then.

ujean (eugenio-fullsite) wrote :

thanks!

Christof Warlich (cwarlich) wrote :

Hi,

I got rotation to work properly so far, thanks to Timo's patched xserver-xorg-core package. But now, the Stylus only works until the first suspend (to disk) - resume cycle! After that, a restart of the xserver is required to get it back to operation.

When I comment the line

InputDevice "stylus" "CorePointer"

the problem disappears, i.e. the Stylus continues to work even after suspend. But then, naturally, rotation doesn't work properly any longer.

Can anyone confirm this behaviour, or even better, does anyone know a way how to fix it?

Thanks,

Christof

Andreas B. (andreas-b123) wrote :

Hi,

I can confirm this more ore less, you don't need to suspend, only logout and login works (for me)...

Since Ubuntu 9.04 rotation don't work correctly, i cannot take a screenshot and its not so easy to describe;-) If I rotate the screen with 90° the cursor is OK, i can take it everywhere with the pen, and it has the correct size, but the rest is stretcht, i cannot see the whole screen, only 2/3 in the width, but all in the height, but it fills only 2/3 of the screen. The under part is black, only the curser is visible in this rect.

May Cristoph, can you describe it better? Do you have the same problem with rotation? It woked with Ubuntu 8.10!

Andreas

mu3en (mu3en) wrote :

@ christof: like andreas, i found that restarting the X server fixes this. Also, the problem occurs mainly if you suspend with the screen rotated. if the screen is at 0° rotation, suspend/resume usually works normally.

@ andreas: i can confirm the situation you experienced, but not in Jaunty. ( i had the same normal rotation with 1/3 black area in intrepid). i'm inclined to believe this is a problem with setup (drivers/xorg.conf/xserver-input) etc...

On a slightly separate note, I seem to have found an almost identical crash to this bug with a non Wacom tablet, same timing, same X server crash, same xorg.conf influence:

Can anyone point me in the right direction to get Timo's package under the Arm port, feels like that might solve it?

Christof Warlich (cwarlich) wrote :

@Andreas: As I described above: Rotation works like a charm on my TC1100 with Timo's patched xorg-xserver-core package. I cannot observe the behaviour described by you. The only issue that I observe is that the stylus stops working after a suspend / resume cycle. There is nothing else to describe, it's just that simple. Do you use Jaunty? And if so, is it a fresh install or an upgrade? What does your xorg.conf look like? I hope that mu3en is right that your problen is due to a setup issue. Could you try a fresh install, use Timo's xorg-xserver-core and mu3en's xorg.conf and report if your issue still exists?

@mu3en: Yes, that's what I said above: Restarting the xserver brings the stylus back to operation. But as this also terminates all running X applications, this "fix" degrades the suspend / resume cycle to something that's not better than an ordinary reboot. And on my system, the issue shows up even if the screen is not rotated :-(.

I'm not sure if Timo is still following this bug report. But as he fixed the stylus issue in the first place, he is probably the only one who would be able to fix the suspend / resume issue with reasonable effort.

Andreas B. (andreas-b123) wrote :

Hi

I've installed the latest updates, Kernel, X11 etc. Nothing works anymore.
So I did what mu3en wrote on 2009-04-24, but it didn't work.

I use Ubuntu 9.04.

I've attached a screenshot, monitor rotatet 90°, that worked with Ubuntu 8.10 (I don't know the names at all, sorry;-))

I try no to get i working...;-)

My xorg.conf:
Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/ttyS0" # SERIAL ONLY
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "stylus" "SendCoreEvents"
EndSection

Section "Device"
 Identifier "Configured Video Device"
EndSection

Section "ServerFlags"
 Option "DontZap" "False"
EndSection

Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
mu3en (mu3en) wrote :

Quick note on karmic status 20091017:

clean install, nvidia drivers, full update/upgrade + install wacom-tools:

using above xorg.conf, everything works as expected except screen rotation (cursor rotation seems to work using the rotate script above, but xrandr spits errors & screen does not rotate).

looking forward to further updates/advisory...

mu3en (mu3en) wrote :

can't seem to edit/delete my last post, so please ignore it.

in reality, as far as i can tell, installing wacom-tools on fresh install of karmic WORKS out of the box with the above xorg.conf, including rotation etc...

beautiful!

sachin (sachin-dcom) wrote :

hi !
I have installed Ubuntu 9.10 and i am facing problem of Xserver crashes sometimes
when i boot system. Also xserver crashes in between session sometimes.

And there is no xorg.conf file in ubuntu 9.10 so where to make changes ?
or how to make xorg.conf for ubuntu 9.10 ?

Thank You !!!

mu3en (mu3en) wrote :

@sachin

best response i can give you is, unfortunately, that there are serious issues with 9.10 karmic in some configurations.

you can add your own xorg.conf in karmic to get things working (pretty much just as explained above), but for me at least there are still constant crashes and calibration issues at boot, after suspend, etc...

i should point out that these various issues may not in fact be related to this bug at all though.

Timo Aaltonen (tjaalton) wrote :

It should work on karmic, and most certainly does in lucid with the new driver, so closing the bug.

Changed in wacom-tools (Ubuntu Jaunty):
status: Confirmed → Won't Fix
Changed in wacom-tools (Ubuntu Karmic):
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) on 2010-03-05
Changed in wacom-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.