xvfb-run broken in jaunty using dash

Bug #357338 reported by Sebastien Bacher on 2009-04-07
2
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Unassigned
Jaunty
High
Unassigned

Bug Description

the recent change for bug #348052 seems to not work using dash

"+ if [ "$XVFBPID" -eq "$(</tmp/.X${SERVERNUM}-lock)" ]; then"

the $() is "" which breaks any "xvfb-run command" call, using bash works correctly though

Related branches

Sebastien Bacher (seb128) wrote :

setting a jaunty milestone since that breaks other builds using xvfb-run for example

Changed in xorg-server (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-9.04
Sebastien Bacher (seb128) wrote :

running it several time seems also to break due to the change

Steve Langasek (vorlon) wrote :

End of the output of sh -x /usr/bin/xvfb-run, showing this going awry:

+ XAUTHORITY=/tmp/xvfb-run.19975/Xauthority Xvfb :99 -screen 0 640x480x8 -extension Composite -nolisten tcp
+ XVFBPID=19986
+
+ [ 19986 -eq ]
[: 1: Illegal number:
+ [ ]
+ error display :99 already in use
+ message error: display :99 already in use
+ echo xvfb-run: error: display :99 already in use
+ fmt -t -w 80
xvfb-run: error: display :99 already in use
+ exit 1
+ clean_up
+ [ -e /tmp/xvfb-run.19975/Xauthority ]
+ XAUTHORITY=/tmp/xvfb-run.19975/Xauthority xauth remove :99
+ [ -n /tmp/xvfb-run.19975 ]
+ rm -r /tmp/xvfb-run.19975

Changed in xorg-server (Ubuntu Jaunty):
status: New → Triaged
Sebastien Bacher (seb128) wrote :

the issue is not dash specific, running it using bash workaround the first issue but multiple calls break saying that the display is already in use, undoing the change mentionned fixes the issue

Steve Langasek (vorlon) wrote :

The issue is that "$(</tmp/.X${SERVERNUM}-lock)" is a bashism.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.6.0-0ubuntu12

---------------
xorg-server (2:1.6.0-0ubuntu12) jaunty; urgency=low

  * local/xvfb-run: Revert change from 2:1.6.0-0ubuntu9; prevents running
    multiple times.
    (LP: #357338. Reopen 348052 rejecting patch)

 -- Bryce Harrington <email address hidden> Tue, 07 Apr 2009 15:21:32 -0700

Changed in xorg-server (Ubuntu Jaunty):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers