Ubuntu

(Needs mesa >= 7.5.1) Blender is unusable with UXA (DRI2 bug)

Reported by Johannes Langlotz on 2009-04-02
40
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
mesa (Ubuntu)
Medium
Unassigned
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

On Jaunty 64 bit with Intel GM965 and UXA enabled Blender is not usable because all GUI elements change their position on hovering. This does not happen with EXA.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
     Subsystem: Dell Device [1028:01f9]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)
     Subsystem: Dell Device [1028:01f9]

Related branches

Created an attachment (id=21307)
xorg.0.log

Created an attachment (id=21309)
reflect_demo

And I think the demo "winpos" also has such problem.

This will be common across all intel chipsets, and all testcases that use frontbuffer rendering will be broken. Enumerating them won't be interesting.

Luckily real apps don't use frontbuffer rendering, so it's not a high priority.

*** Bug 19270 has been marked as a duplicate of this bug. ***

*** Bug 19679 has been marked as a duplicate of this bug. ***

Increasing priority, since blender (bug#19679) is a real app.

*** Bug 19455 has been marked as a duplicate of this bug. ***

It still existed with the following configuration:
Kernel_version: 2.6.29-rc6
Libdrm: (master)2e2e8575b1ed4703653a72ac2b60b75316c388d7
Mesa: (mesa_7_4_branch)a8528a2e8653b5237c1d1d66fe98c6e031d007f9
Xserver: (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel: (2.7)238c2c40afd9f8b61479b8640d53f20d52fd7ddf

Binary package hint: xserver-xorg-video-intel

On Jaunty 64 bit with Intel GM965 and UXA enabled Blender is not usable because all GUI elements change their position on hovering. This does not happen with EXA.

Bryce Harrington (bryce) wrote :

Hi johannes-langlotz,

Thanks for including an image to demonstrate the issue. Could you also please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log or Xorg.0.log.old file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete

I made two small changes in xorg.conf:

1.) I enabled [ALT] + [CTRL] + [Backspace]
2.) I enabled two additional resolutions for my external Display

Popolon (popolon) wrote :

This bug with blender is only in window mode, in full screen mode, everything was well displayed but there still a graphic translation between the rendering window (F12) and it's content.

Since the middle or end of this week, new changes on the driver display lot of traces on the 3d view of blender, see following attachement
I use an Intel 82945G/GZ (after lscpi), that's in fact a 945GC (most common graphic chips with intel atom330).

Bryce Harrington (bryce) wrote :

What does this return?

glxinfo | grep GLX_EXT_texture_from_pixmap

glxinfo | grep GLX_EXT_texture_from_pixmap
   GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_texture_from_pixmap,
   GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
   GLX_EXT_texture_from_pixmap

All the pop-ups and menus seem to be absolute positioned from the top
left of the screen and not from the top left of the blender window
content. Have a look at the screenshot. I tried to visualizing it. All
red rectangles have the same size.

Bryce Harrington wrote:
> What does this return?
>
> glxinfo | grep GLX_EXT_texture_from_pixmap
>

and also the lspci -vvnn
informations attached, in case they give helpful insights...

Prunus dulcis (prunus-dulcis) wrote :

sorry, replied in the wrong report...
Should have gone here:
https://bugs.launchpad.net/ubuntu/+source/blender/+bug/360415

Bryce Harrington (bryce) on 2009-04-20
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
smkururu (smkururu) wrote :

I think I got the same problem here, but the full screen is also unusable. It appears that there's a problem with the pointer.

Bryce Harrington (bryce) on 2009-04-21
description: updated
Bryce Harrington (bryce) on 2009-04-24
summary: - [jaunty] Blender is unusable with UXA
+ [i965gm] [jaunty] Blender is unusable with UXA
Bryce Harrington (bryce) on 2009-04-25
tags: added: jaunty
summary: - [i965gm] [jaunty] Blender is unusable with UXA
+ [i965gm] Blender is unusable with UXA
Bryce Harrington (bryce) on 2009-04-25
summary: - [i965gm] Blender is unusable with UXA
+ [i965gm] Blender is unusable with UXA (UXA bug)

Try to use blender 2.49 rc1 it work better.

Michael (idmer) wrote :

Sorry, not look on my last post. I try "Static" version from blender.org. The static build has the OpenGL libraries compiled in. It works better, but have UI is transparent on composited screen. Same bag on blender tracker (need login): https://projects.blender.org/tracker/index.php?func=detail&aid=18626&group_id=9&atid=231

Bryce Harrington (bryce) on 2009-05-01
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
Bryce Harrington (bryce) wrote :

For Karmic we're making UXA bugs like these a top priority, so I would like to forward this one upstream. First though, we need to verify the issue still exists with the latest upstream release. Would you please install and test the 2.7.0 driver and reproduce the bug, and let us know ASAP? A PPA with a Jaunty version of this driver is available at: https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates/

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Juho Rutila (juho-rutila) wrote :

Bryce,
I'm actually experiencing the same problem (actually the menus don't even show without alt+tab "refresh") with some packages from xorg-edgers. Here's the info:
xserver-xorg-video-intel 2:2.7.99.1+git20090427.e55d9431-0ubuntu0sarvatt

xorg.conf (relevant part)

Section "Device"
 Identifier "Configured Video Device"
 Option "AccelMethod" "uxa"
 #Option "AccelMethod" "EXA"
 Option "EXAOptimizeMigration" "true"
 Option "MigrationHeuristic" "greedy"
 Option "Tiling" "false"
EndSection

And the problem occurs when uxa is enabled. Exa works fine.

Is my driver recent enough? I can test this with 2.7.0 also if needed.

Bryce Harrington (bryce) wrote :

Thanks. Btw, I notice you're using "uxa" and "greedy" together... do those have an effect beyond just setting "uxa" alone?

Testing 2.7.99.1+git is definitely recent enough for us to send this upstream. If you have time to test against 2.7.0, that would be useful in that we probably will be merging 2.7.0 into karmic fairly shortly, but will likely wait a bit for 2.8.0. (2.8.0 drops EXA entirely, so I'd like to verify all of the high importance UXA bugs are gone before we make the commitment to abandon EXA entirely.)

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged

I still have exactly the same problems after installing
* libdrm2_2.4.9-1ubuntu1~xup~1_amd64.deb
* libdrm-intel1_2.4.9-1ubuntu1~xup~1_amd64.deb
* xserver-xorg-video-intel_2.7.0-1ubuntu1~xup~1_amd64.deb

This is fixed in the master branches of xserver, dri2proto, xf86-video-intel, and Mesa. I'm expecting to bring the fixes into the stable release branches (i.e., xserver server-1.6-branch, xf86-video-intel 2.7, etc.) next week.

*** Bug 21577 has been marked as a duplicate of this bug. ***

Thanks Johannes,

I've forwarded your issue upstream to https://bugs.freedesktop.org/show_bug.cgi?id=21577 - please subscribe to that bug report in case upstream needs further information or wishes you to test something. Thanks ahead of time.

Also, in case upstream needs you to test an even newer version of -intel, you can look here for recent git snapshots: https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Bryce Harrington (bryce) on 2009-05-06
Changed in xserver-xorg-video-intel:
status: Confirmed → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Bryce Harrington (bryce) on 2009-05-06
tags: added: 3d

Now it works well with in master branches.

Maybe the summary is a bit misleading, as the same problem exists with i945 (as already mentioned by Pololon). I am not sure, but I think Bug #360415 is a duplicate of this one.

Juho Rutila (juho-rutila) wrote :

According to the upstream (https://bugs.freedesktop.org/show_bug.cgi?id=19174#c12) this issue should be fixed in the master branch of xserver, libdrm, mesa and xf86-video-intel. I tried to install latest prebuilt packages from xorg-edgers ppa.
I'm now running the following packages:

xserver-xorg-video-intel 2:2.7.99.1+git20090515.87332a7c-0ubuntu0sarvatt~jaunty
mesa 7.5.0~git20090515+mesa-7-5-branch.483e2478-0ubuntu0sarvatt2
libdrm 2.4.11+git20090514.r1.f57d7f4b-0ubuntu0sarvatt~jaunty
xserver-xorg 1:7.4~5ubuntu18

and same error occurs. I think the fix is included in those builds. Maybe I should try latest xserver (where to get it)?

Robert Hooker (sarvatt) wrote :

Just installed blender to see and the same issue happens for me in karmic on 945GME under UXA.

Packages:
xserver-xorg-video-intel 2:2.7.99.1+git20090520.ad212882-0ubuntu0sarvatt
xorg-server 2:1.6.1.901-0ubuntu0sarvatt
mesa 7.6.0~git20090519.d0eccc41-0ubuntu0sarvatt
libdrm 2.4.11+git20090519.f355ad89-0ubuntu0sarvatt

They mention that the fix would be in xserver 1.6 branch back in the beginning of may but I'm using the latest 1.6 branch from git and all of those packages I update those packages on xorg-edgers just about every day if there are any non-trivial commits.

Could it be dri2proto that needs to be updated and stuff rebuilt against that? They added DRI2GetBuffersWithFormat interface to both -intel and dri2proto as well as fixed a dri2 version check in xserver 1.6 branch a bit before this comment
https://bugs.freedesktop.org/show_bug.cgi?id=19174#c10

Relevant commits -
http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=5d6f4f6eb7a4dcbe1ce5a134d882e56f958ed2ba

http://cgit.freedesktop.org/xorg/proto/dri2proto/commit/?id=66c56ab10d917e3f47f93178d7eac6430970d3c4

I'll try updating mine and rebuilding everything against it when I get some free time.

>Thanks. Btw, I notice you're using "uxa" and "greedy" together... do those have an effect beyond just setting "uxa" alone?

It ignores in UXA it so it's no problem
(WW) intel(0): Option "MigrationHeuristic" is not used

Robert Hooker (sarvatt) wrote :

I updated xserver to master branch along with the requisite x11proto-dri2-dev 2.1 and x11proto-input-dev 1.9.99.6 and there isn't an offset menu rendering problem anymore using the static mesa version on the blender website. The ubuntu repo version and static python version from blender.org doesn't show dropdown menus though leading me to think it's a mesa bug in 7.6 left still.

xserver-xorg-core 2:1.6.99.1+git20090521-0ubuntu0sarvatt2

Juho Rutila (juho-rutila) wrote :

Well that's good news, Robert.

Now, how can I test this in Jaunty? Can you point me to some deb-packages or preferably to some good howto about compiling xserver myself to deb-packages. I checked auto-xorg-git and that sounds promising. Have to check it little bit more.

Juho Rutila (juho-rutila) wrote :

So,

the static-mesa blender from blender.org works fine even with the official ubuntu repo versions of xserver, xorg-video-intel, mesa and libdrm. I can confirm this on Jaunty.

But, I think this bug is still valid because the non-static-mesa version of the blender doesn't work with the latest mesa (that has Ian Romanick's patches on it).

Is this status information right? Should the upstream be noted (because now this bug is duplicate to other bug that is marked as fixed)?

Robert Hooker (sarvatt) wrote :

Well I should have been clearer, the offset menu problem is gone on all versions using the latest git master branch versions of everything, but the dropdowns do not render any more in anything but the static mesa version. Hovering over the buttons still selects the menu in the correct place now. I have only packaged everything for karmic since it is such a large change against jaunty, but if you have a spare machine or install to test it you can use my packages here

https://edge.launchpad.net/~sarvatt/+archive/xorg-testing

According to the blender website its a known problem with blender for the menus to not render correctly on intel.

"Users with Intel on-board graphics: some graphics operations (menus or border select) don't show due to driver bug."

To get around the problem for the immediate future, you can launch blender with

LIBGL_ALWAYS_SOFTWARE=1 blender

which works perfect for me.

*** Bug 21958 has been marked as a duplicate of this bug. ***

*** Bug 21393 has been marked as a duplicate of this bug. ***

*** Bug 22453 has been marked as a duplicate of this bug. ***

Can one of you guys that have been able to reproduce the bug let me know if it still occurs against current karmic? If it does, I'll re-open the upstream bug on it. Fresh Xorg.0.log and screenshot would be helpful.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete

It can still reproduce this bug in Karmic.

Bryce Harrington (bryce) on 2009-07-23
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed

I have been testing this and is not fixed in Karmic yet, but it is fixed upstream (in the sense that blender now is unusable in a new and different way). The upstream bug requires fixes in xorg-server, the intel driver and the kernel, and the xorg-server version currently in Karmic (1.6.1.901 IIRC) does not contain the fix. The xorg-edgers PPA has it (1.6.2). See my comments on bug 401067 (which probably is a duplicate of this one).

I would like to report the new problems upstream using the xorg-edgers PPA, but before I got far enough to collect the information I wanted, my computer crashed and my karmic partition got corrupted. So if anyone beats me to it, it would be great. (Don't know when I will have the time to reinstall)

tags: added: 965gm karmic
removed: needs-xorglog
Bryce Harrington (bryce) on 2009-07-28
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged

Hi Geir, thanks for that information, that helps narrow it down.

From what you've indicated, am I reading correctly that we have appropriate versions of -intel and the kernel, but just need to update to a newer xserver (e.g. 1.6.3) to gain the fix? Assuming that to be true, I'll move this bug to the xserver. Hopefully we should have 1.6.3 before too long.

summary: - [i965gm] Blender is unusable with UXA (UXA bug)
+ [i965gm] (Needs xserver 1.6.3) Blender is unusable with UXA (UXA bug)
affects: xserver-xorg-video-intel (Ubuntu) → xorg-server (Ubuntu)
Robert Hooker (sarvatt) wrote :

I wish it was that easy.. UXA with the old dri2proto rendered menus offset, but with the new dri2 features it doesnt render dropdowns at all still even on xserver 1.7 that had the commits that were supposed to fix it well before they hit 1.6.2. There are _many_ upstream bug reports on it, but it doesnt seem like the fix it going to make it until blender 2.5 where they switch from single buffered to triple buffered rendering. The bug is hitting radeons now as well now that they are moving to dri2.

Geir Ove Myhr (gomyhr) wrote :

Robert describes the situation accurately (and better than I would).

Robert, you seem to follow the upstream bugs more closely than I am able to, could you list some of those many bug reports?

Geir Ove Myhr (gomyhr) wrote :

This should have been fixed in mesa today, with this commit:
http://cgit.freedesktop.org/mesa/mesa/commit/?id=fd65418f600874b05f902b622078b40bc1abb24a

Since Robert updated mesa in xorg-edgers a few minutes ago with this patch included, it should be easy to test it.

Robert Hooker (sarvatt) wrote :

Yep it is indeed fixed!

summary: - [i965gm] (Needs xserver 1.6.3) Blender is unusable with UXA (UXA bug)
+ [i965gm] (Needs mesa 7.6) Blender is unusable with UXA (DRI2 bug)
Robert Hooker (sarvatt) wrote :
Robert Hooker (sarvatt) wrote :

The fix has now been comitted to mesa 7.5 branch and will be included in 7.5.1 when it is released in a few days. Probably not much point cherry picking it into our 7.5 because its very close to release and contains a bunch of other bug fixes, but this is the commit for 7.5 for future reference.

http://cgit.freedesktop.org/mesa/mesa/commit/?h=mesa_7_5_branch&id=61673aebb0c92bf187189c496e6c3a856825eceb

Here are the other bugs fixed in 7.5.1 so far:

Added missing GLEW library to MesaDemos tarballs.
Fixed swapbuffers jerkiness in Doom3/etc in Intel drivers.
Fixed front buffer rendering bug in Intel drivers.
Fixed minor GLX memory leaks.
Fixed some texture env / fragment program state bugs.

Changed in mesa (Ubuntu):
status: New → Confirmed
summary: - [i965gm] (Needs mesa 7.6) Blender is unusable with UXA (DRI2 bug)
+ [i965gm] (Needs mesa >= 7.5.1) Blender is unusable with UXA (DRI2 bug)
Robert Hooker (sarvatt) on 2009-08-04
summary: - [i965gm] (Needs mesa >= 7.5.1) Blender is unusable with UXA (DRI2 bug)
+ (Needs mesa >= 7.5.1) Blender is unusable with UXA (DRI2 bug)
Bryce Harrington (bryce) on 2009-08-21
Changed in xorg-server (Ubuntu):
status: Triaged → Fix Released
Changed in mesa (Ubuntu):
importance: Undecided → Medium
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 7.6.0~git20090817.7c422387-0ubuntu1

---------------
mesa (7.6.0~git20090817.7c422387-0ubuntu1) karmic; urgency=low

  [Bryce Harrington]
  * Checkout from git 20090817 (master branch) up to commit
    7c4223876b4f8a78335687c7fcd7448b5a83ad10
    + Add DRI2 support to -ati
      (LP: #329654, #404428, #327698, #321108)
    + Fix portion of MythTV Frontend does not work with RADEON DRI
      (LP: #341898)
    + Fix selection mode on RS482
      (LP: #273329)
    + Fix issue running 3D acceleration games on ATI chipsets
      (LP: #374590)
    + Provide DRI2 swap buffers
      (LP: #377090)
    + Fix blender unusable with UXA when DRI2 enabled
      (LP: #353763)
  * Drop 108_bo_assertion.patch (applied upstream)

  [Robert Hooker]
  * Only added debian/ tree from origin/ubuntu
  * Enable r600 driver. Note that it requires seperate drm modules
    not provided in this PPA or in ubuntu, and also does not work with
    KMS.

 -- Bryce Harrington <email address hidden> Fri, 21 Aug 2009 16:13:50 -0700

Changed in mesa (Ubuntu):
status: In Progress → Fix Released
capi /. (barraponto) wrote :

please backport to jaunty...

Geir Ove Myhr (gomyhr) wrote :

Sorry, that is probably not possible as the changes needed are too extensive.

mass_konfuzion (lherard) wrote :

I just recently jumped into this thread, but I had been having similar issues with Blender that you all have mentioned. I can confirm that I got Blender to perform properly in Jaunty. The short story is, I simply updated my display drivers.

If you like long stories, continue reading :-D

I took the following steps:

1 - Followed the instructions in post #12 from Bryce Harrington. (Note: This didn't seem to solve the problem, and I'm not sure if the drivers in the PPA contributed to my eventual success, because I think I ended up further updating those drivers in step 2. But I've included the step for the sake of tracking what I did.)

2 - Updated to the latest driver of https://wiki.ubuntu.com/X/Troubleshooting/IntelPerformance#Use%20preview%20of%202.8%20driver

3 - Edited /etc/X11/xorg.conf to enable UXA

Some notes:
- Blender now runs correctly, even with my Visual Effects settings at the max (before, when using the software renderer for Blender, I had to turn off Visual Effects).

- When I run glxinfo, I get the following error: "get fences failed: -1". Even after searching around the forums and interwebz, I'm not exactly sure what that means, but my graphics accelerations seems to be working. And, from what I understand, that fences error is harmless. If anyone knows the real deal, please point me in the right direction. I'm curious.

- One other very minor issue is that now, when I mouse over items in a drop-down menu (not within Blender), it appears as though only the top half of the word is highlighted. I've included a screenshot. It's liveable, but I thought I should point it out.

mass_konfuzion (lherard) wrote :

I've discovered that I'm not out of the woods yet--Blender seg faults when I do certain things. I need to investigate further...

mass_konfuzion (lherard) wrote :

So as it turns out, I still have major problems with Blender. Since the Intel gfx chip driver update (I have an Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller), Blender opens up and it looks beautiful . But, Blender segfaults out once I try to start doing just about anything. I guess I'll have to wait until the driver bugs are resolved.

On Mon, Sep 14, 2009 at 2:37 AM, mass_konfuzion wrote:
> But, Blender segfaults out
> once I try to start doing just about anything.  I guess I'll have to
> wait until the driver bugs are resolved.

Yes. Of course there is a much higher chance of those bugs being
resolved if you report them. If you have a reproducable segfault with
a backtrace, I think that should be fairly straightforward to
troubleshoot.

Note that this is not a forum thread but a bug report and that this
particular bug has been fixed.

mass_konfuzion (lherard) wrote :

Ahh, gotcha--please forgive.. I'm new :-D

And fortunately, the latest updates (I just got an update this evening through the Update Manager) solved whatever issue I was having, so I'm good to go.

Michael Soluyanov (crantisz) wrote :

Blender in ubuntu 9.10 completely better. But I noted, that some select modes works very slow. It is rect select (B-key) lasso (ctrl+left mouse key) clip border (alt+B)

Changed in xserver-xorg-video-intel:
importance: Unknown → High
Changed in xserver-xorg-video-intel:
importance: High → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.