Ubuntu

Comment 300 for bug 353126

Can you tell us how you setup xorg so we can get this working?
thanks

On Tue, Jun 29, 2010 at 2:36 PM, jose <email address hidden> wrote:
> I couldn't either until I actually set up xorg. Apparently after installing the driver the xorg.conf file did not get created so it wasn't actually using the driver, even though sysinfo said it was being used
> Jose
>
> --
> Compiz / vnc screen refresh with nvidia-restricted driver/VirtualBox/ATI fglrx driver using X.org
> https://bugs.launchpad.net/bugs/353126
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in AMD fglrx video driver: Confirmed
> Status in NVIDIA Drivers Ubuntu: In Progress
> Status in GNOME Remote Desktop: Incomplete
> Status in X.Org X server: Confirmed
> Status in “vino” package in Ubuntu: Fix Released
> Status in “xorg-server” package in Ubuntu: Fix Released
> Status in “vino” package in Fedora: Unknown
>
> Bug description:
> Binary package hint: compiz
>
> When using the nvidia-restricted or some ATI drivers and compiz desktop effects the vnc server will not refresh the screen. This is being caused by the xserver not getting "damaged" by the nvidia-restricted drivers (see https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/353126/comments/245 for details). Linked bugs confirm this is not an issue on intel chipsets or nv driver.
>
> Steps to reproduce:
> Enable desktop-effects (default) with nvidia-restricted, virtualBox's display or some ATI driver like RV610
> Enable remote desktop
> Connect with VNC
>
> Results:
> You see a screen snapshot of your desktop but if you click a menu item there are no updates to the screen.
> Notes:
> If you close and restart the vnc session, you get an updated snapshot but still no refreshes.
>
> Workarounds:
> Use the -noxdamage argument with vncviewer. This is really inefficient and bandwidth hungry since the whole screen refreshes.
> Kill compiz and use a different wm (metacity).
>
> [Tested with nvidia] Run compiz with the --use-root-window option, eg:
> compiz --replace --use-root-window &
>
> This bug has been confirmed by many others with linked reports. Might be an issue with xorg since there is a report of ATI drivers with similar issues in https://bugs.launchpad.net/bugs/328559 .
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/fglrx/+bug/353126/+subscribe
>